[PLUGIN] Forum_XH

Ein CMSimple Support Forum für deutsch sprechende Nutzer und Entwickler
cmb
Posts: 12663
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: [PLUGIN] Forum_XH

Post by cmb » Sun Feb 08, 2015 8:03 pm

Hallo zusammen,

ich habe gerade Forum_XH 1.0beta4 veröffentlicht.

Ich habe einen gravierenden Bug behoben, durch den das Plugin unter CMSimple_XH 1.6.5 nahezu unbenutzbar war (außer im Adminmodus). Vielen Dank an pmschulze für das Melden des Fehlers.

Viel Spaß,
Christoph

PS: @Der Zwerch: ich habe noch keine weiteren Features implementiert -- es fehlt die Zeit. Sorry.
Christoph M. Becker –Plugins for CMSimple_XH, but not for CMSimple 4+

mhz
Posts: 534
Joined: Tue Jun 25, 2013 8:46 pm
Location: Heusenstamm, Hessen
Contact:

Re: [PLUGIN] Forum_XH

Post by mhz » Thu Feb 12, 2015 11:19 pm

Hallo,
Bei den letzten Änderungen steht ein deutsch-englisches Mischmasch:
"... letzter Eintrag von NN am February 11, 2015 um ..."
Wie und wo kann die Datumsangabe auf die deutsche Schreibweise geändert werden?

Gruß
Michael
Michael Zajusch (mhz)-- Mein Tutorial für CMSimple_XH. Früher

cmb
Posts: 12663
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: [PLUGIN] Forum_XH

Post by cmb » Fri Feb 13, 2015 12:04 am

mhz wrote:Bei den letzten Änderungen steht ein deutsch-englisches Mischmasch:
"... letzter Eintrag von NN am February 11, 2015 um ..."
Danke für den Bug-Report. :)
mhz wrote:Wie und wo kann die Datumsangabe auf die deutsche Schreibweise geändert werden?
In der Sprachdatei (Plugins -> Sprache) unter Format->Date. Dort würde ich "j,n.Y" oder "d.m.Y" eintragen. Dt. Monatsnamen sind derzeit leider nicht möglich.

Da Forum_XH mittlerweile sowieso CMSimple_XH >= 1.6 erfordert, werde ich vielleicht zu strftime() wechseln, womit das prinzipiell möglich wäre, aber so recht traue ich den Locales bei Multithreading nicht. IntlDateFormatter ist da vielleicht verlässlicher, aber der ist u.U. nicht verfügbar. Das müsste ich mir mal genauer anschauen.
Christoph M. Becker –Plugins for CMSimple_XH, but not for CMSimple 4+

cmb
Posts: 12663
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: [PLUGIN] Forum_XH

Post by cmb » Thu May 18, 2017 3:22 pm

Hallo zusammen!

Forum_XH 1.0beta5 wurde gerade freigegeben.

Ein paar Fehler wurden behoben, und einige Verbesserungen durchgeführt. Details entnehmt dem
Changelog. Die beachtenswertesten Änderungen:
  1. Die Anforderungen wurden erhöht (XH ≥ 1.6.3, Fa_XH, PHP ≥ 5.4.0)
  2. Der Ort der Datendateien ist nicht mehr konfigurierbar; statt dessen werden sie nun immer im content/ Ordner von CMSimple_XH erwartet.
  3. E-Mail-Benachrichtigung ist nun verfügbar
  4. Die Foren wurden "ajaxifiziert" (erfordert einen zeitgemäßen Browser; mindestens IE 10), was sie für Onepager und ähnliches geeignet macht.
Viel Spaß!
Christoph M. Becker –Plugins for CMSimple_XH, but not for CMSimple 4+

Kreative-Gruppe
Posts: 65
Joined: Fri Feb 17, 2017 2:41 pm

Re: [PLUGIN] Forum_XH

Post by Kreative-Gruppe » Fri May 19, 2017 12:57 pm

cmb hat geschrieben:
The requirements have been lifted (XH ≥ 1.6.3, Fa_XH, PHP ≥ 5.4.0
but still XH < 1.7, unfortunately. :(

Angelika

Matipa
Posts: 4
Joined: Tue Jul 04, 2017 1:17 pm

Re: [PLUGIN] Forum_XH

Post by Matipa » Tue Jul 04, 2017 1:27 pm

Hallo,
ich habe das gerde installieren wollen und bekomme nun einen white screen mit der debug Meldung
Parse error: syntax error, unexpected T_OBJECT_OPERATOR in /mnt/web208/d2/11/5609511/htdocs/SIMBA2/plugins/twocents/classes/Router.php on line 84
Ich bin ziemlicher Laie, kann mir da wer weiter helfen? Realblog habe ich entfernt, macht keinen Unterschied.
Danke
Thomas

cmb
Posts: 12663
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: [PLUGIN] Forum_XH

Post by cmb » Tue Jul 04, 2017 1:36 pm

Matipa wrote:Parse error: syntax error, unexpected T_OBJECT_OPERATOR in /mnt/web208/d2/11/5609511/htdocs/SIMBA2/plugins/twocents/classes/Router.php on line 84
Zumindest seit Version 1.0beta3 benötigt Twocents_XH mindestens PHP 5.4.0, bei dir läuft anscheinend aber noch eine ältere PHP-Version. Ich empfehle dir ein Update auf PHP 5.6 oder höher (kannst du u.U. selbst im Control-Panel durchführen; ansonsten den Provider kontaktieren).
Christoph M. Becker –Plugins for CMSimple_XH, but not for CMSimple 4+

Matipa
Posts: 4
Joined: Tue Jul 04, 2017 1:17 pm

Re: [PLUGIN] Forum_XH

Post by Matipa » Tue Jul 04, 2017 2:02 pm

Vielen Dank, werde mal bei Strato gucken - und dann habe ich auch noch im falschen Subforum gepostet.
Gruesse aus Simbabwe,
Thomas

Post Reply