Forum_XH

Third Party Plugins to CMSimple - how to install, use and create plugins

Moderator: Tata

cmb
Posts: 11108
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Forum_XH

Postby cmb » Sat Jun 09, 2012 2:41 pm

Hello Community,

I've just released Forum_XH 1beta1. For details and a demo just visit my site.

Any feedback is welcome.

Christoph
Christoph M. Becker –Plugins for CMSimple_XH, but not for CMSimple 4+

svasti
Posts: 1648
Joined: Wed Dec 17, 2008 5:08 pm
Location: Bielefeld, Germany
Contact:

Re: Forum_XH

Postby svasti » Tue Jun 12, 2012 3:55 pm

Very nice... a very welcome addition to the ever increasing plugin list of CMSimple.

Hm, why has nobody else posted some comments? Nobody using CMSimple any more?

Some little remarks:
German language file all English? :?
The emoticons... look a little pale ... I like the ones on this forum here better.

I have a German subsite on an English CMSimple, if in the subsite I try to submit a reply without subject line, an empty javascript alert appears. Besides I get:
NOTICE: Undefined index: lbl_title_missing
NOTICE: Undefined index: lbl_comment_missing
However in the main language everything is working fine (up to now).

svasti

cmb
Posts: 11108
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Forum_XH

Postby cmb » Tue Jun 12, 2012 4:32 pm

Thanks for your feedback :)

svasti wrote:Hm, why has nobody else posted some comments? Nobody using CMSimple any more?

I'm quite sure, that everybody is eagerly awaiting the switch from phpBB to Forum_XH :lol:

svasti wrote:German language file all English?

There's no German language file included in the download yet (I'd rather wait with the translation; there might be quite some changes). Your's is probably just the automatic copy of default.php.

svasti wrote:The emoticons... look a little pale ... I like the ones on this forum here better.

Well, the emoticons... It took me quite a while to find a set that's available under a compatible license. In fact I hadn't actually considered to look for the phpBB ones, which should be under GPL. I'll check that, and will include them in the next release. If anybody has another free emoticon icon set, please tell me! And of course everybody can replace the emoticons in images/ with the preferred ones.

svasti wrote: have a German subsite on an English CMSimple, if in the subsite I try to submit a reply without subject line, an empty javascript alert appears. Besides I get:
NOTICE: Undefined index: lbl_title_missing
NOTICE: Undefined index: lbl_comment_missing

Yes, indeed. I can reproduce the behaviour! The problem is, that default.php is outdated :oops: For now just copy en.php to default.php and delete de.php. Than it should work.

Christoph
Christoph M. Becker –Plugins for CMSimple_XH, but not for CMSimple 4+

cmb
Posts: 11108
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Forum_XH

Postby cmb » Tue Oct 07, 2014 8:38 pm

Hello Community,

I have just released Forum_XH 1.0beta2.

I have finally added the possibility to edit existing post. Furthermore I fixed several flaws and minor bugs, added the German and Danish translation (the latter contributed by maeg -- thanks!), supported several new CMSimple_XH 1.6 APIs and did considerable refactoring. For details see the CHANGELOG.

The new version requires CMSimple_XH >= 1.6 and PHP >= 5.1.2.

Enjoy,
Christoph
Christoph M. Becker –Plugins for CMSimple_XH, but not for CMSimple 4+

cmb
Posts: 11108
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Forum_XH

Postby cmb » Wed Oct 08, 2014 12:12 pm

Hello Community,

I have just released Forum_XH 1.0beta3.

I have fixed two bugs and made some minor improvements. Thanks to Frank (Der Zwerch) for reporting the issues.

Enjoy,
Christoph
Christoph M. Becker –Plugins for CMSimple_XH, but not for CMSimple 4+

cmb
Posts: 11108
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Forum_XH

Postby cmb » Sun Feb 08, 2015 8:00 pm

Hello Community,

I have just released Forum_XH 1.0beta4.

I have fixed a severe bug, where the plugin was nearly unusable under CMSimple_XH 1.6.5 (except in admin mode). Many thanks to pmschulze for reporting the bug.

Enjoy,
Christoph
Christoph M. Becker –Plugins for CMSimple_XH, but not for CMSimple 4+

cmb
Posts: 11108
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Forum_XH

Postby cmb » Thu May 18, 2017 3:22 pm

Hi everybody!

Forum_XH 1.0beta5 has just been released.

Some bugs have been fixed, and several enhancements have been made. For details see the changelog. The most notable changes:

  1. The requirements have been lifted (XH ≥ 1.6.3, Fa_XH, PHP ≥ 5.4.0)
  2. The location of the data files isn't configurable anymore; instead the are expected in CMSimple_XH's contents/ folder
  3. Email notification is now available
  4. The forums have been "ajaxified" (requires a contemporary browser; at least IE 10), what makes them suitable for Onepagers and such.

Enjoy!
Christoph M. Becker –Plugins for CMSimple_XH, but not for CMSimple 4+

Kreative-Gruppe
Posts: 54
Joined: Fri Feb 17, 2017 2:41 pm

Re: Forum_XH

Postby Kreative-Gruppe » Fri May 19, 2017 12:53 pm

cmb wrote:The requirements have been lifted (XH ≥ 1.6.3, Fa_XH, PHP ≥ 5.4.0


but still XH < 1.7, unfortunately. :(

Angelika

cmb
Posts: 11108
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Forum_XH

Postby cmb » Fri May 19, 2017 1:41 pm

Kreative-Gruppe wrote:but still XH < 1.7, unfortunately. :(

Forum_XH 1.0beta5 is supposed to be fully compatible with CMSimple_XH 1.7. What doesn't work for you?
Christoph M. Becker –Plugins for CMSimple_XH, but not for CMSimple 4+


Return to “Addons and Plugins”

Who is online

Users browsing this forum: No registered users and 0 guests