Problem mit fontawesome

A place to report and discuss bugs - please mention CMSimple-version, server, platform and browser version
Post Reply
Tata
Posts: 3176
Joined: Tue May 20, 2008 5:34 am
Location: Slovakia
Contact:

Problem mit fontawesome

Post by Tata » Sat Mar 21, 2020 7:59 pm

Auf einer Seite nutze ich CSS text animation (typewriter). Die texte sind in SPANs verlangt. Ich wollte die in SPAN geschriebene Links noch mit z.B. <i class="fa fa-external-link-square"></i> ergänzen. TinyMCE fügt es aber immer in <span>...</span>. Das zerstört die Animation. Überschreibe ich es wieder zu <i class="fa fa-external-link-square"></i>, verschwindet es komplet.
Liegt es am Editor oder am FA Plugin? Wie soll ich es lösen?
CMSimple.sk
It's no shame to ask for an answer if all efforts failed.
But it's awful to ask without any effort to find the answer yourself.

frase
Posts: 3324
Joined: Thu Apr 21, 2016 6:32 am
Location: Saxony
Contact:

Re: Problem mit fontawesome

Post by frase » Sun Mar 22, 2020 9:27 am

Der Editor bereinigt den Code automatisch, vor allem wenn leere Tags vorhanden sind.
Du könntest die Init-Datei anpassen, damit er das nicht tut.
Es geht aber auch einfacher.
Verwende 2 x <span> ineinander verschachtelt und sorge dafür, dass in beiden Inhalt drin ist. Das geht bei FA auch mit einem geschützen Leerzeichen.
Beispiel:

Code: Select all

<span class="text_1">
<span class="fa fa-external-link-square">&nbsp;</span> 
Denné menu sa vydáva len v menu boxe so sebou od 10:00 - 13:30 hod.<br>Cena s balením 4,30€.
</span>

Tata
Posts: 3176
Joined: Tue May 20, 2008 5:34 am
Location: Slovakia
Contact:

Re: Problem mit fontawesome

Post by Tata » Sun Mar 22, 2020 10:41 am

Danke sehr.
CMSimple.sk
It's no shame to ask for an answer if all efforts failed.
But it's awful to ask without any effort to find the answer yourself.

Post Reply