XH-Forum

Ein CMSimple Support Forum für deutsch sprechende Nutzer und Entwickler
lck
Posts: 1360
Joined: Wed Mar 23, 2011 11:43 am
Contact:

XH-Forum

Post by lck » Tue Oct 30, 2018 6:24 pm

frase wrote: Was ist mit dem Forum los? Zu viele Angriffe?
Schon seit gestern kann man sich nur manchmal einloggen.
Kann ich bestätigen. Ich hatte deswegen auch bei Frank und Holger nachgefragt, das war am 27.10.. Gestern Abend so ca. 18:35 Uhr hatte ich nochmal das Problem. Es geht mal, dann wieder nicht und dann kann man sich wieder einloggen :?
Ich hatte das auch schon mal vor ein paar Monaten, wann genau kann ich nicht mehr sagen. Komisch ist auch der Besucherrekord unten auf der Foren-Übersichtsseite, das kann nicht stimmen, schön wär's ;)
Der Besucherrekord liegt bei 669 Besuchern, die am Di 5. Jun 2018, 23:17 gleichzeitig online waren.
„Bevor du den Pfeil der Wahrheit abschießt, tauche die Spitze in Honig!“   👉 Ludwig's XH-Templates for MultiPage & OnePage

frase
Posts: 2261
Joined: Thu Apr 21, 2016 6:32 am
Location: Saxony
Contact:

Re: XH-Forum

Post by frase » Tue Oct 30, 2018 6:31 pm

lck wrote:
Tue Oct 30, 2018 6:24 pm
Es geht mal, dann wieder nicht und dann kann man sich wieder einloggen
Stimmt genau.
Und meistens ist es morgens und vormittags - und da sind zufällig gerade immer so zwischen 100 und 200 User online.
Sehr verwunderlich.

cmb
Posts: 12877
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: XH-Forum

Post by cmb » Tue Oct 30, 2018 7:10 pm

lck wrote:
Tue Oct 30, 2018 6:24 pm
Kann ich bestätigen. Ich hatte deswegen auch bei Frank und Holger nachgefragt, das war am 27.10.. Gestern Abend so ca. 18:35 Uhr hatte ich nochmal das Problem. Es geht mal, dann wieder nicht und dann kann man sich wieder einloggen :?
Kann schon sein, dass der Server da einfach mal überfordert ist.
lck wrote:
Tue Oct 30, 2018 6:24 pm
Komisch ist auch der Besucherrekord unten auf der Foren-Übersichtsseite, das kann nicht stimmen, schön wär's ;)
Der Besucherrekord liegt bei 669 Besuchern, die am Di 5. Jun 2018, 23:17 gleichzeitig online waren.
Ja, das kann nicht sein. Soweit ich weiß, sind meist mehrere tausend Besucher aktiv. ;)
frase wrote:
Tue Oct 30, 2018 6:31 pm
Und meistens ist es morgens und vormittags - und da sind zufällig gerade immer so zwischen 100 und 200 User online.
Sehr verwunderlich.
Na ja, keine Ahnung wie phpBB nicht angemeldete Besucher zählt. Weder IP-Adressen noch Cookies sind absolut verlässlich.
Christoph M. Becker –Plugins for CMSimple_XH, but not for CMSimple 4+

Korwin
Posts: 52
Joined: Sat Oct 13, 2018 3:27 pm
Location: Russia, Yekaterinburg
Contact:

Re: XH-Forum

Post by Korwin » Wed Oct 31, 2018 5:47 am

cmb wrote:
Tue Oct 30, 2018 7:10 pm
lck wrote:
Tue Oct 30, 2018 6:24 pm
Komisch ist auch der Besucherrekord unten auf der Foren-Übersichtsseite, das kann nicht stimmen, schön wär's ;)
Der Besucherrekord liegt bei 669 Besuchern, die am Di 5. Jun 2018, 23:17 gleichzeitig online waren.
Ja, das kann nicht sein. Soweit ich weiß, sind meist mehrere tausend Besucher aktiv. ;)
frase wrote:
Tue Oct 30, 2018 6:31 pm
Und meistens ist es morgens und vormittags - und da sind zufällig gerade immer so zwischen 100 und 200 User online.
Sehr verwunderlich.
Na ja, keine Ahnung wie phpBB nicht angemeldete Besucher zählt. Weder IP-Adressen noch Cookies sind absolut verlässlich.

Ich habe Links zu unserem Wikipedia-Forum gemacht - könnte ein Angriff eine Folge wachsender Beliebtheit sein?
Ich meine Popularität unter Bots?

Holger
Site Admin
Posts: 2896
Joined: Mon May 19, 2008 7:10 pm
Location: Hessen, Germany
Contact:

Re: XH-Forum

Post by Holger » Wed Oct 31, 2018 9:57 am

Ich habe mir eben mal bei 60 Usern (57 Gäste) die online sind die Details angesehen. Das waren hauptsächlich Bots, die sich auch als solche ausgeben und diverse Feed-Reader. Die IP-Adressen waren unterschiedlich, wenn auch manchmal nur im letzten Oktett.
Die Angabe der Online-User ist also schon "irgendwie realistisch", was die laufenden Sessions betrifft.

Wenn es wieder zu Login-Problemen kommt dann schaut doch bitte mal auf die gemeldete Anzahl von Online-Usern. Eventuell kann man dann Rückschlüsse auf die Ursache ziehen.
Ich schau' auch mal in den Logs des Forums nach...

Edit: der Error-Log gibt nichts her :?. Serverseitig muss ich noch schauen.

frase
Posts: 2261
Joined: Thu Apr 21, 2016 6:32 am
Location: Saxony
Contact:

Re: XH-Forum

Post by frase » Wed Oct 31, 2018 10:23 am

Holger wrote:
Wed Oct 31, 2018 9:57 am
Wenn es wieder zu Login-Problemen kommt dann schaut doch bitte mal auf die gemeldete Anzahl von Online-Usern.
Wie oben schon erwähnt:
In den letzten Tagen war es bei mir meist vormittags der Fall, dass ich mich nicht einloggen konnte. Und immer genau da waren so ca. 100-200 Leute online.

Heute keine Probleme.

lck
Posts: 1360
Joined: Wed Mar 23, 2011 11:43 am
Contact:

Re: XH-Forum

Post by lck » Wed Oct 31, 2018 1:00 pm

So, wieder mal einloggen nicht möglich um 12:40 Uhr. [1]Was ging dem voraus, ich hatte den Browser-Cache gelöscht!!!

Loginversuch ca. 12:40 Uhr, nicht möglich!
Wer ist onlie? wrote:In total there are 3 users online :: 1 registered, 0 hidden and 2 guests (based on users active over the past 5 minutes)
Nach 8 Loginversuchen um 13:40 Uhr ging es wieder. Genau 1 Stunde nach dem ersten Versuch. Was passiert da, was wird da gelöscht, geleert oder verfällt da?

Versuch macht kluch, also Cache wieder gelöscht und es geht wieder nicht.
Aber:
Login geht mit "Remember me" und "Hide my online status this session"

Aber:
Beim Abmelden tauch folgende Info kurz auf:
Information
Du wurdest nicht abgemeldet, da die Anfrage nicht zu deiner Sitzung passte. Bitte wende dich an die Board-Administration, sofern das Problem regelmäßig auftritt.
Löschen der Board-Cookies brachte nichts.
Nachdem ich mit den Dev-Tools des Browsers "Clear Site storage" gemacht hatte und die Seite neu geladen, wurde ich auch ausgeloggt.
Aber jetzt kann ich mich nicht mehr normal einloggen (wahrscheinlich wieder 1 Stunde lang), aber mit "Remember me" geht's, aber "Und täglich grüßt das Murmeltier".

* Beim Verfassen dieses Posts hatte ich am Anfang auch eine Meldung bei der Vorschau, dass das Formular nicht erneut gesendet werden kann oder so ähnlich :?

Nachtrag zu [1]: scheint Zufall gewesen zu sein. Gerade nochmal probiert, normales Login möglich.
„Bevor du den Pfeil der Wahrheit abschießt, tauche die Spitze in Honig!“   👉 Ludwig's XH-Templates for MultiPage & OnePage

cmb
Posts: 12877
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: XH-Forum

Post by cmb » Wed Oct 31, 2018 2:10 pm

lck wrote:
Wed Oct 31, 2018 1:00 pm
So, wieder mal einloggen nicht möglich um 12:40 Uhr.
Das Problem hatte ich nun auch zum ersten Mal. Ich habe Holger per E-Mail bereits einige Details zugesandt. Zusammenfassend kann man wohl sagen, dass es Probleme mit der Session-ID gibt, und eigentlich existierende Sessions nicht als solche erkannt werden (das Board erzeugt dann immer wieder neue sid=xyz in der URL).
lck wrote:
Wed Oct 31, 2018 1:00 pm
Nach 8 Loginversuchen um 13:40 Uhr ging es wieder. Genau 1 Stunde nach dem ersten Versuch. Was passiert da, was wird da gelöscht, geleert oder verfällt da?
Ich könnte mir vorstellen, dass ein Cron-Job stündlich alte Session-Dateien löscht, und vorher einfach viel zu viele davon existierten, was die Software (phpBB oder PHP selbst) durcheinander bringen könnte.
Christoph M. Becker –Plugins for CMSimple_XH, but not for CMSimple 4+

Holger
Site Admin
Posts: 2896
Joined: Mon May 19, 2008 7:10 pm
Location: Hessen, Germany
Contact:

Re: XH-Forum

Post by Holger » Thu Nov 01, 2018 8:18 am

cmb wrote:
Wed Oct 31, 2018 2:10 pm
Ich könnte mir vorstellen, dass ein Cron-Job stündlich alte Session-Dateien löscht, und vorher einfach viel zu viele davon existierten, was die Software (phpBB oder PHP selbst) durcheinander bringen könnte.
Das ist so. Und nachdem der Job gelaufen ist, konnte ich mich auch wieder anmelden.
Aber woher kommen auf einmal die vielen Sessions?

olape
Posts: 652
Joined: Fri Mar 13, 2015 8:47 am
Contact:

Re: XH-Forum

Post by olape » Thu Nov 01, 2018 8:46 am

lck wrote:
Wed Oct 31, 2018 1:00 pm
Login geht mit "Remember me"
Das kann ich bestätigen. Seit ein paar Tagen habe ich das auch.
Allerdings habe ich dem keine große Bedeutung beigemessen. :oops:
Mit dem Häkchen habe ich seither keine Probleme.

Vielleicht kann man ein paar, na sagen wir mal, unliebsame Bots abhalten, die Seite zu besuchen.

https://ip-bannliste.de/websicherheit/bad-bots.html

Post Reply