Page Administration tree empty

A place to report and discuss bugs - please mention CMSimple-version, server, platform and browser version
Post Reply
OH1KH
Posts: 3
Joined: Mon Jun 11, 2018 5:38 pm

Page Administration tree empty

Post by OH1KH » Mon Jun 11, 2018 6:25 pm

Hi!
Just updated to new CMSimple because of some problems with the old version and web hosting system.

I upgraded my pages manually to 1.7.2 at my home server (lubuntu17 with php 7.1.15) and when it was working moved it to web hosting.
There it shows like:
System Info
Installed CMSimple Version
CMSimple_XH 1.7.2 Released: 2017-12-21
Installed Plugins
Fa 1.2
Filebrowser for CMSimple_XH 1.7.2
Hi_updatecheck 1.4
Jquery 1.6.4
Meta_tags for CMSimple_XH 1.7.2
Pagemanager 3.2
Page_params for CMSimple_XH 1.7.2
Tinymce4
Webserver
LiteSpeed
PHP-Version
5.6.36
PHP Info » (opens in a new window or tab)
And all system checks OK.

At start it did not work at all, bu I noticed php was too old. I was able to select default php for my pages at webhosting's cpanel.
Tried with 7.1, but moved back to 5.6 as old phpBB forum there did not like 7,1.

Now everything is nearly working except in admin mode the selection "Pages" gives all buttons (active, not gray), but nothing into the form where the page map tree should exist.
So no editing/deletin/adding can be done.
Pages itself can be modified and saved ok.
New page, or subpage can only be done/deleted by manually editing content.htm with text editor. Not very cool !

As I had to fix content.htm manually replacing all <h1> etc to <!--XH_ml1: type headings I made another installation to web hosting using just the data that I got from CMSimple_XH-1.7.2.zip. Just changed the password and made whole test directory tree to have 777 rights.
In that installation I get the directory tree to page administration. But it does not work still.

If I add one page to start or end it goes to tree as should. If I then press save button I have popup "Message from www.mypage.com" without any other text as "OK" button. Pressing it the popup closes.
If I the go to other place, or press "pages" again I get another popup saying that leaving this page could make changes lost !!!
I think the first popup tries to say something more like:"can not save... or similar" but that does not show up. If I leave "pages" and come back the page tree does not have the new page I added.

In both installations NO errors appear if debug is on. So tracing is very hard.
I have tried to change template, change php short tag on/off and lots of other things. No help. And at home server directory tree shows up and can be modified. But not at web hosting's server.

Just found one similar hit by Googling, but also there were no error messages and so no solution either.

Any suggestions?

--
Saku
--
Saku

cmb
Posts: 12882
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Page Administration tree empty

Post by cmb » Mon Jun 11, 2018 9:14 pm

Hi!
OH1KH wrote:
Mon Jun 11, 2018 6:25 pm
Now everything is nearly working except in admin mode the selection "Pages" gives all buttons (active, not gray), but nothing into the form where the page map tree should exist.
So no editing/deletin/adding can be done.
I suggest that you look at the browser's error console (typically F12) – are there any JavaScript errors shown? If not, the next step could be to enter the URL which is supposed to retrieve the page structure into the browser's address bar (http://example.com/?pagemanager&admin=p ... _data&edit); this should show the JSON structure of all pages.
OH1KH wrote:
Mon Jun 11, 2018 6:25 pm
As I had to fix content.htm manually replacing all <h1> etc to <!--XH_ml1: type headings […]
Just for the record: there is the Exchange_XH plugin which allows to export the content of CMSimple_XH 1.6 and import these into CMSimple_XH 1.7.
Christoph M. Becker –Plugins for CMSimple_XH, but not for CMSimple 4+

OH1KH
Posts: 3
Joined: Mon Jun 11, 2018 5:38 pm

Re: Page Administration tree empty

Post by OH1KH » Tue Jun 12, 2018 11:51 am

Thanks for suggestions.

How ever they did not solve the problem.
Lookng at JavaScript errors cleared out that page administration shows out differently with different browsers and sent by different servers (as said earlier)

Opera 53:
-page administration shows up page tree and can be edited and saved if page comes from home server (ubuntu 17)
-page administration does not show up any page tree if page comes from web hosting server with own web pages (LiteSpeed)
-page administration shows up page tree and can be edited, but not saved if page comes from web hosting server with original pages from 1.7.2 install ZIP. Shows empty message when save pressed.

Firiefox 63:
-page administration shows up page tree and can be used if page comes from home server (ubuntu 17)
-page administration shows up page tree that can be modified, but NOT saved. (LiteSpeed) Shows message "forbidden" when save pressed.
Same with own pages, or original install pages from 1.7.2 ZIP
NOTE ! whole cmsimple_xh directory structure is chmod:ed with -R 777 so it is not file permission question (with original install pages version)
Screenshot_20180612_144749.png
No Java script errors shown with firefox.
No errors when "pages" accessed with _XHdebug set to 6

Only error seen so far comes when accessing "files/downloads":
NOTICE: getimagesize(): Read error!
/home/saku/public_html/4/plugins/filebrowser/classes/View.php:306

And this happens with both home server and web hosting server. But I think this is not related to "pages" probelm.

JSON output with Firefox looks nice. ids from pagemanager_0 to _49 nicely in order.

So. Firefox is better for edit works with web hosting's server. Still one problem to resolve. Why saving gives popup "Forbidden" and all permissions are 777 ?
You do not have the required permissions to view the files attached to this post.
--
Saku

cmb
Posts: 12882
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Page Administration tree empty

Post by cmb » Tue Jun 12, 2018 2:45 pm

OH1KH wrote:
Tue Jun 12, 2018 11:51 am
-page administration shows up page tree that can be modified, but NOT saved. (LiteSpeed) Shows message "forbidden" when save pressed.
“Forbidden” is the HTTP response code returned by the server (it's actually “403 Forbidden”). I guess that there's a firewall in place, which rejects the payload of the POST request for some reason. Can you access the server's error logs?
OH1KH wrote:
Tue Jun 12, 2018 11:51 am
Only error seen so far comes when accessing "files/downloads":
NOTICE: getimagesize(): Read error!
/home/saku/public_html/4/plugins/filebrowser/classes/View.php:306
That's a known bug. It's pretty harmless, though, so you can ignore it for now.
Christoph M. Becker –Plugins for CMSimple_XH, but not for CMSimple 4+

OH1KH
Posts: 3
Joined: Mon Jun 11, 2018 5:38 pm

Re: Page Administration tree empty

Post by OH1KH » Tue Jun 12, 2018 5:25 pm

Hi!

Not proper error log. There is cpanel/errors that gets line:
File not found [/home/xxxxxxxx/public_html/403.shtml]
every time saving pompts "Forbidden".

If I make ~/public_html/403.shtml it still makes that error line.
If I give console command cat /home/xxxxxxxx/public_html/403.shtml I get "file not found" but if I give cat ~/public_html/403.shtm it shows file.
This makes me wonder if user's sandbox is properly set up...

On the other hand. I can edit the content of any page and save it normally. What is the difference between saving page tree or page content?
If I understand right both are living in content/content.htm
--
Saku

cmb
Posts: 12882
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Page Administration tree empty

Post by cmb » Tue Jun 12, 2018 9:55 pm

OH1KH wrote:
Tue Jun 12, 2018 5:25 pm
Not proper error log. There is cpanel/errors that gets line:
File not found [/home/xxxxxxxx/public_html/403.shtml]
every time saving pompts "Forbidden".
That is rather a sequel to the actual problem: when saving the page structure, the server responds with “403 Forbidden”, what it should not do in the first place.
OH1KH wrote:
Tue Jun 12, 2018 5:25 pm
On the other hand. I can edit the content of any page and save it normally. What is the difference between saving page tree or page content?
If I understand right both are living in content/content.htm
Yes, both are saving to content/content.htm. However, they are using completely different requests, and I suppose that this is the problem. For instance, Pagemanager sends an “X-Requested-With: XMLHttpRequest” header which the server might not like. It is pretty hard to get to the actual root cause, unless there is access to comprehensive error logs.
Christoph M. Becker –Plugins for CMSimple_XH, but not for CMSimple 4+

Post Reply