Hilfe bei Forum_xh

Ein CMSimple Support Forum für deutsch sprechende Nutzer und Entwickler
Post Reply
parken
Posts: 44
Joined: Tue Aug 13, 2013 7:55 pm
Location: Hannover
Contact:

Hilfe bei Forum_xh

Post by parken » Thu May 12, 2016 2:59 am

Moin Leute, ich benötige mal wieder Hilfe.
ich möchte Forum_xh benutzen , soweit alles ok.
Aber, wenn ein user ein kommentar schreibt und in sichert wird der ganze text rechts aus dem bild geschrieben, sprich, man muss nach rechts scrollen wenn man den ganzen Text lesen möchte.
Wo kann ich die Breite einstellen damit dieses nicht passiert?
ich hab die website local auf meinem Server zum testen.
ich benutze dasTemplate Interior Design von OldNema.
Für eine Hilfe bedanke ich mich.
Gruss Parken

Tata
Posts: 3153
Joined: Tue May 20, 2008 5:34 am
Location: Slovakia
Contact:

Re: Hilfe bei Forum_xh

Post by Tata » Thu May 12, 2016 4:55 am

Welche "width"/"min-width"/"max-width" Werte hast Du in

Code: Select all

.forum_details{}
.forum_odd {}
.forum_even {}
.forum_topics {}
.forum_topics > li {}
.forum_topic {}
.forum_comment .forum_title input {}
.forum_comment textarea {}
Da düdrfen nur die Werte kleiner oder gleich zu width:100% oder max-width:100% stehen
CMSimple.sk
It's no shame to ask for an answer if all efforts failed.
But it's awful to ask without any effort to find the answer yourself.

parken
Posts: 44
Joined: Tue Aug 13, 2013 7:55 pm
Location: Hannover
Contact:

Re: Hilfe bei Forum_xh

Post by parken » Thu May 12, 2016 10:11 am

hallo Tata, ich hab die stylesheet mal kopiert.

Code: Select all

/*
 * General
 */
.forum_heading {
    font-weight: bold;
    font-size: 1.2em;
}
.forum_details {
    font-size: 85%;
    font-style: italic;
}
.forum_navlink {
    text-align: right;
    margin: 0.5em 0 0 0;
    font-weight: bold;
}

/*
 * Zebra look
 */
.forum_odd {}
.forum_even {}

/*
 * All topics
 */
.forum_topics {
    list-style: none;
    margin: 0;
    padding: 0;
}
.forum_topics > li {
    margin: 0 0 0.5em 0;
    padding: 0 0 0.5em 0;
    border-bottom: 1px solid #888;
}
.forum_topics .forum_title {
    font-weight: bold;
    margin: 0.5em 0;
}

/*
 * Single topic
 */
.forum_topic {
    list-style: none;
    margin: 0;
    padding: 0;
    width: 80%;
}
.forum_topic > li {
    margin: 0 0 0.5em 0;
    padding: 0 0 0.5em 0;
    border-bottom: 1px solid #888;
}
.forum_comment {
    margin-top: 0.5em;
}
.forum_edit {
    float: right;
}
.forum_edit img {
    border: none;
}
.forum_delete {
    float: right;
    margin-left: 0.5em;
}
.forum_quote {
    margin-left: 0;
    border-left: 3px solid #888;
    padding-left: 1em;
}
.forum_code {
    border: 1px solid #888;
    overflow-x: auto;
}

/*
 * Comment form
 */
.forum_comment {
    margin: 0em 0;
}
.forum_comment .forum_title {
    margin-bottom: 1em;
}
.forum_comment .forum_title label {
    padding-right: 1em;
}
.forum_comment .forum_title input {
    width: 5em;
}
.forum_comment textarea {
    width: 50%;
    padding: 0;
}
.forum_comment .forum_submit {
    text-align: center;
}
.forum_comment .forum_submit .submit {
    padding: 0.2em 1em;
}

/*
 * Back-end
 */
.forum_plugin_icon {
    display: block;
    float: left;
    margin: 0 10px 0 0;
}
.forum_license {
    clear: both;
    text-align: justify;
}
Vielleicht hab ich auch schon zu viel rumgespielt :roll: :roll:
es sollte schon irgendwie so ausschauen wie bei http://bsp-verein.keil-portal.de/?Forum

Gruss Parken
Last edited by cmb on Thu May 12, 2016 4:25 pm, edited 1 time in total.

Tata
Posts: 3153
Joined: Tue May 20, 2008 5:34 am
Location: Slovakia
Contact:

Re: Hilfe bei Forum_xh

Post by Tata » Thu May 12, 2016 3:32 pm

Nun, versuch mal in allen oben genannten Werte max-width: 80%; (oder wasimmer anderes zu stellen). Falls das nicht hiulft, kopier noch einmal original stylesheet rein and beginn vom Anfang mit Style zu spielen. Dann aber Save/View nach jeder Änderung.
CMSimple.sk
It's no shame to ask for an answer if all efforts failed.
But it's awful to ask without any effort to find the answer yourself.

Hartmut
Posts: 533
Joined: Sat Nov 05, 2011 6:13 pm
Location: Butzbach, Deutschland
Contact:

Re: Hilfe bei Forum_xh

Post by Hartmut » Thu May 12, 2016 3:56 pm

Hallo,

ich hatte damals (bei der Konfiguration vom Forum) auch etwas tüfteln müssen, da der Text bei mir zu sehr nach rechts aus dem Template herauslief.

Unter http://bsp-verein.keil-portal.de/?Forum sieht es wie folgt aus:
Verwendetes Template: n6200tbisGPL3
Das Forum ist im Content wie folgt eingebunden (HTML): <div>{{{forum('forum-sv-beispielstadt');}}}</div>
Meine Forum CSS Datei unterscheidet sich an den folgenden Stellen von deiner CSS-Datei:
.forum_topic {
list-style: none;
margin: 0;
padding: 0;
width: 100%;
}
.forum_comment {
margin: 1em 0;
}
.forum_comment .forum_title input {
width: 30em;
}
.forum_comment textarea {
width: 100%;
padding: 0;
}

Viele Grüße
Hartmut

parken
Posts: 44
Joined: Tue Aug 13, 2013 7:55 pm
Location: Hannover
Contact:

Re: Hilfe bei Forum_xh

Post by parken » Thu May 12, 2016 5:26 pm

Moin moin, hab noch mal alles neu gemacht .
Die Stylesheet sieht jetzt so aus:

Code: Select all

/*
 * General
 */
.forum_heading {
    font-weight: bold;
    font-size: 1.2em;
}
.forum_details {
    font-size: 85%;
    font-style: italic;
}
.forum_navlink {
    text-align: right;
    margin: 0.5em 0 0 0;
    font-weight: bold;
}

/*
 * Zebra look
 */
.forum_odd {}
.forum_even {}

/*
 * All topics
 */
.forum_topics {
    list-style: none;
    margin: 0;
    padding: 0;
}
.forum_topics > li {
    margin: 0 0 0.5em 0;
    padding: 0 0 0.5em 0;
    border-bottom: 1px solid #888;
}
.forum_topics .forum_title {
    font-weight: bold;
    margin: 0.5em 0;
}

/*
 * Single topic
 */
.forum_topic {
    list-style: none;
    margin: 0;
    padding: 0;
    width: 100%;
}
.forum_topic > li {
    margin: 0 0 0.5em 0;
    padding: 0 0 0.5em 0;
    border-bottom: 1px solid #888;
}
.forum_comment {
    margin-top: 0.5em;
}
.forum_edit {
    float: right;
}
.forum_edit img {
    border: none;
}
.forum_delete {
    float: right;
    margin-left: 0.5em;
}
.forum_quote {
    margin-left: 0;
    border-left: 3px solid #888;
    padding-left: 1em;
}
.forum_code {
    border: 1px solid #888;
    overflow-x: auto;
}

/*
 * Comment form
 */
.forum_comment {
    margin: 1em 0;
}
.forum_comment .forum_title {
    margin-bottom: 1em;
}
.forum_comment .forum_title label {
    padding-right: 1em;
}
.forum_comment .forum_title input {
    width: 30em;
}
.forum_comment textarea {
    width: 100%;
    padding: 0;
}
.forum_comment .forum_submit {
    text-align: center;
}
.forum_comment .forum_submit .submit {
    padding: 0.2em 1em;
}

/*
 * Back-end
 */
.forum_plugin_icon {
    display: block;
    float: left;
    margin: 0 10px 0 0;
}
.forum_license {
    clear: both;
    text-align: justify;
}
Denke sieht genau so aus wie bei Hartmut.
Text läuft immer noch nach rechts aus dem Bild :roll:

ich hab keine Ahnung, vielleicht brauch ich auch eine Brille, ich weis es nicht :ugeek:
Gruss parken
Last edited by cmb on Fri May 13, 2016 11:17 am, edited 1 time in total.
Reason: Stylesheet als [ code ] ausgezeichnet

lck
Posts: 1967
Joined: Wed Mar 23, 2011 11:43 am
Contact:

Re: Hilfe bei Forum_xh

Post by lck » Thu May 12, 2016 6:23 pm

Hallo parken,
parken wrote:Denke sieht genau so aus wie bei Hartmut.
Text läuft immer noch nach rechts aus dem Bild
wenn man die Seite einsehen könnte wäre es einfacher mit der Fehlersuche, gerne per PN, aber ich glaube wir können das auch so lösen.

Auch bei Hartmuts Forum floatet die horizontale Linie (Browser Chrome, Opera) und auch der Text (IE ,FF) über den content-Bereich.
Ursache hierfür scheint mir

Code: Select all

.forum_topic {
    list-style: none;
    margin: 0;
    padding: 0;
    width: 100%; /* Kommentier das aus oder lösche es (oder: statt 100% verwende inherit, oder verwende eine fixe Breite z.B. 500px) */
}
EDIT: Wenn das auch nichts ändert, dann versuch mal width: 90% !important;
„Bevor du den Pfeil der Wahrheit abschießt, tauche die Spitze in Honig!“   👉 Ludwig's XH-Templates for MultiPage & OnePage

parken
Posts: 44
Joined: Tue Aug 13, 2013 7:55 pm
Location: Hannover
Contact:

Re: Hilfe bei Forum_xh

Post by parken » Fri May 13, 2016 10:41 am

Hi Leute, danke für die Hilfe, problem gelöst dank Ludwig :lol: :lol:
word-wrap: break-word; ......dieses hinzu gefügt und funzt.
Ich weiss ja das ich nicht der schlaue bin in solchen sachen,aber ich bemühe mich schon auch zu lesen.
Das mit dem automatischem zeilenumbruch hab ich zwar irgendwie gegoogelt ,konnte es aber nicht umsetzen.
ich hoffe das ich nicht zu sehr nerven :lol:
Danke danke

Schöööööönes Wochenende
Gruss Parken

cmb
Posts: 13297
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Hilfe bei Forum_xh

Post by cmb » Wed May 18, 2016 6:36 pm

parken wrote:word-wrap: break-word; ......dieses hinzu gefügt und funzt.
Bin bisschen spät, aber Hautpsache, das Problem ist gelöst. Ich habe es für die nächste Version vermerkt.
Christoph M. Becker – Plugins for CMSimple_XH

Post Reply