Charset UTF-8

Questions about how to use the online - editors and suggestions how to improve them
kirekire
Posts: 8
Joined: Fri Nov 07, 2008 8:28 pm

Charset UTF-8

Post by kirekire » Fri Nov 07, 2008 8:42 pm

Hello,
please advise:
I use newly FCK222 with CMSimple 3.2.
Charset of my page is set to UTF-8.
In the Edit mode i write čšě, save and see Ä�Å¡Ä�.
In the Normal mode I again see čšě, after logout is everything fine: I see čšě.

But to edit the text it is not pleasant to see �š�.

"FCKConfig.ProcessHTMLEntities = false ;" does not help.

Please for an advice, thanks in advance.

Holger
Site Admin
Posts: 3098
Joined: Mon May 19, 2008 7:10 pm
Location: Hessen, Germany
Contact:

Re: Charset UTF-8

Post by Holger » Fri Nov 07, 2008 11:06 pm

It's a pity that there's no HowTo belong to that problem available until now.
There had been a lot of discussions at this board and always the same problem.

The work on the integration of FCKeditor took me so much time. But I think
that I'll not longer support that project with updates until this annoying problem is gone.
So Connie, please write a small compilation about your experience on that problem.
It's a good idea to write that ten sentences down in english and german language
and we put that into the readme1st and your documentation.

I'm not the expert in that UTF-8 hoblededu, but I'll try to help with the experience
I've made by reading all that topics:

1. Check the charset of your browser
2. Check your CMSimple language file and the charset setting in this file
3. Be sure that all files (template, css, language.php, content.htm ...) are saved in UTF-8.
If you're not sure, download this files and convert them to the correct charset: UTF-8 without BOM
4. IMHO "FCKConfig.ProcessHTMLEntities" should / can be set to "true" in the custom configuration

You can see some screenshots with a working installation in the german forum:
http://www.cmsimpleforum.com/viewtopic. ... sd=a#p1424

I hope this will help...

WBR

Holger

Connie
Posts: 282
Joined: Thu May 22, 2008 10:11 am
Location: Hamburg
Contact:

Re: Charset UTF-8

Post by Connie » Sat Nov 08, 2008 9:06 am

Holger,

you listed already the important info for this subject

I will try to find some time next week to put together the information for at least the 20th time and add it to the WIKI

I suggest until then do a SEARCH for FCKEDITOR AND UTF-8

I cannot understand why it is so difficult to search the forum :|
|---
Connie Müller-Gödecke, http://www.webdeerns.de

Holger
Site Admin
Posts: 3098
Joined: Mon May 19, 2008 7:10 pm
Location: Hessen, Germany
Contact:

Re: Charset UTF-8

Post by Holger » Sat Nov 08, 2008 1:01 pm

Hi Connie,
Connie wrote:I will try to find some time next week to put together the information for at least the 20th time and add it to the WIKI
Thanks!
Connie wrote:I suggest until then do a SEARCH for FCKEDITOR AND UTF-8

I cannot understand why it is so difficult to search the forum :|
Because most of the topics at this board, belong to this problem, are written in german :| .
I can understand the frustration of the users. But it's really annoing me to read that again and again.
It's not a problem of the editor. It seems to be a problem of the installation.
A short FAQ or "How to get UTF-8 in CMSimple with FCKeditor" may stop all that discussions.
As I said before, Im not the expert on that.
But you've set up some pages and you wrote the detailed manual.
So I wonder why there's no documentation on that big issue available.

Holger

PS: Nicht böse sein, Connie. Das ständige Gemeckere geht mir nur langsam ganz schön auf'n ... ;)

kirekire
Posts: 8
Joined: Fri Nov 07, 2008 8:28 pm

Re: Charset UTF-8

Post by kirekire » Sat Nov 08, 2008 5:56 pm

Wir können ruhig deutsch sprechen :D , danke für die Antworten, natürlich habe ich in diesem Forum gesucht (z. B. thema vom September http://www.cmsimpleforum.com/viewtopic.php?f=7&t=232 - keine Antwort), Räte versucht, aber kein Rat führte zu einem erfolgreichen Ergebnis.
Schade, FCKeditor habe ich sehr gerne, da bleibe ich also bei der Version 2.5.1 vom Dezember 2007, wo es diese Probleme (bei UTF-8, ISO-8859-2) nicht gibt, und hoffe in die Zukunft.
Danke nochmals für die Antworten 8-) .

Holger
Site Admin
Posts: 3098
Joined: Mon May 19, 2008 7:10 pm
Location: Hessen, Germany
Contact:

Re: Charset UTF-8

Post by Holger » Sat Nov 08, 2008 7:43 pm

kirekire wrote:Schade, FCKeditor habe ich sehr gerne, da bleibe ich also bei der Version 2.5.1 vom Dezember 2007, wo es diese Probleme (bei UTF-8, ISO-8859-2) nicht gibt, und hoffe in die Zukunft.
Danke nochmals für die Antworten 8-) .
Moment mal, Du verwendest die Version 2.5.1 vom Dezember 07, auch von http://www.webdeerns.de?
Und das klappt bei Dir ohne Probleme :?: :?: :?: (Kann ja eigentlich nicht sein. Probleme gab es ja schon damals)
Ich versteh' die Welt nicht mehr!
Klär' uns da bitte noch einmal genau auf!

LG

Holger

kirekire
Posts: 8
Joined: Fri Nov 07, 2008 8:28 pm

Re: Charset UTF-8

Post by kirekire » Sun Nov 09, 2008 5:14 pm

Holger wrote:
kirekire wrote:Schade, FCKeditor habe ich sehr gerne, da bleibe ich also bei der Version 2.5.1 vom Dezember 2007, wo es diese Probleme (bei UTF-8, ISO-8859-2) nicht gibt, und hoffe in die Zukunft.
Danke nochmals für die Antworten 8-) .
Moment mal, Du verwendest die Version 2.5.1 vom Dezember 07, auch von http://www.webdeerns.de?
Und das klappt bei Dir ohne Probleme :?: :?: :?: (Kann ja eigentlich nicht sein. Probleme gab es ja schon damals)
Ich versteh' die Welt nicht mehr!
Klär' uns da bitte noch einmal genau auf!

LG

Holger
In der fckeditor.php datei ist geschrieben:
Update: FCKEditor 2.5.1 by Connie Müller-Gödecke, December 2007.
Ich meine, ich habe die Dateien damals von cmsimple.org heruntergeladen.
Dieser Editor hat keine Probleme mit UTF-8, ISO-8859-2, die wir verwenden, dies betrifft auch mehrsprachige Seiten - CZ in ISO-8859-2, DE und EN in ISO-8859-1.

Holger
Site Admin
Posts: 3098
Joined: Mon May 19, 2008 7:10 pm
Location: Hessen, Germany
Contact:

Re: Charset UTF-8

Post by Holger » Sun Nov 09, 2008 5:37 pm

Hmm, never mind!

Erst'mal Danke für die Tipps.

Holger

Connie
Posts: 282
Joined: Thu May 22, 2008 10:11 am
Location: Hamburg
Contact:

Re: Charset UTF-8

Post by Connie » Sun Nov 09, 2008 7:47 pm

na, auf cmsimple.org habe ich nie Dateien zum Download gehabt ;=)

aber sag mir bitte mal:
du hast also mit der Version vom Dezember und genau dem gleichen Template mit den gleichen Charsets und im gleichen Format (ASCII, ANSII oder was auch immer) abgespeichert damals keine Probleme gehabt und jetzt hast du sie?

Und dein Server hat sich auch nicht verändert? Von wegen vom Server unterstützter Zeichensatz?
Und dein Browser hat auch keine andere default - Zeichensatz-Einstellung?

wirklich nicht?

Sorry, das kann ich mir nicht vorstellen.

ich werde in den nächsten Tagen nocheinmal alle UTF-8-Informationen zusammensammeln und hier und im Wiki und auf Webdeerns und wo sonst noch veröffentlichen

dann geh bitte mal alle Punkte Schritt für Schritt durch und gib zu jeder Info eine Auskunft, das würde uns sehr helfen
heute komme ich nur nicht dazu, ich möchte einfach jetzt mal Feierabend haben und die letzten Stunden zuhause genießen, bevor ich morgen wieder 6 Stunden im Bahn-ICE-Umfeld verbringen darf ;=(

bis dann,

Connie
|---
Connie Müller-Gödecke, http://www.webdeerns.de

kirekire
Posts: 8
Joined: Fri Nov 07, 2008 8:28 pm

Re: Charset UTF-8

Post by kirekire » Sun Nov 09, 2008 8:37 pm

1. Die Datei ist immer auf cmsimple.org angeboten (http://www.cmsimple.org/?download=fcked ... simple.zip), ist jedoch nicht verfügbar. :roll:
2. Ja, mit der Version vom Dezember habe ich keine Probleme. Ich habe vor ein Paar Tagen die neuste Version heruntergeladen und versucht. Da entstanden die o. g. Probleme.
3. Ich meine, mein Server hat sich nicht geändert. Die Fehler habe ich in FF 3.0.3 sowie in EI7 gehabt, beide haben als Standard UTF-8 eingestellt.

OK, bitte um Info in diesem Forum, wenn Du es zusammengeschrieben hast, ich leiste Dir dann die Resultate.

Besten Dank im voraus.

Post Reply