Error using 1.7.2

Questions about how to install and problems installing - please read the documentation first!
uwes
Posts: 41
Joined: Mon Oct 01, 2012 8:40 am

Re: Error using 1.7.2

Post by uwes » Sun Dec 31, 2017 1:16 pm

Interesting: I see a 500 http status in the access log when I access 1.7.x. This is "Internal Server Error".

cmb
Posts: 12893
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Error using 1.7.2

Post by cmb » Sun Dec 31, 2017 1:39 pm

uwes wrote:Interesting: I see a 500 http status in the access log when I access 1.7.x. This is "Internal Server Error".
If you just get a blank page for this Internal Server Error, debug mode is most likely not enabled. The filename has to be _XHdebug.txt, not XHdebug.txt (note the leading underscore).
Christoph M. Becker –Plugins for CMSimple_XH, but not for CMSimple 4+

uwes
Posts: 41
Joined: Mon Oct 01, 2012 8:40 am

Re: Error using 1.7.2

Post by uwes » Sun Dec 31, 2017 1:44 pm

Thanks, now we're getting there...

Code: Select all

Fatal error: Uncaught Error: Call to undefined function mb_substr() in /var/www/html/170/cmsimple/utf8.php:44 Stack trace: #0 /var/www/html/170/cmsimple/cms.php(804): utf8_substr('', 0, '200') #1 /var/www/html/170/index.php(6): include('/var/www/html/1...') #2 {main} thrown in /var/www/html/170/cmsimple/utf8.php on line 44

uwes
Posts: 41
Joined: Mon Oct 01, 2012 8:40 am

Re: Error using 1.7.2

Post by uwes » Sun Dec 31, 2017 1:52 pm

Ok, I installed php-mbstring and everything is fine now.

This requirement should be mentioned in the wiki.

cmb
Posts: 12893
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Error using 1.7.2

Post by cmb » Sun Dec 31, 2017 2:09 pm

uwes wrote:Ok, I installed php-mbstring and everything is fine now.

This requirement should be mentioned in the wiki.
Thanks. I've updated the requirements info.
Christoph M. Becker –Plugins for CMSimple_XH, but not for CMSimple 4+

Post Reply