A fatal error occurred. Enable debug mode for further inform

Questions about how to install and problems installing - please read the documentation first!
dsa
Posts: 24
Joined: Sun Dec 11, 2016 12:09 am

A fatal error occurred. Enable debug mode for further inform

Post by dsa » Sun Dec 11, 2016 12:18 am

I am installing cmsimple, last version, I was using old cmsimple "This installation was downloaded from CMSimple.org Saturday 26th of November 2011 03:00:43 AM"

I do everthing the readme file says

I login with test password

And I get
A fatal error occurred. Enable debug mode for further information.

I make the downloads directory and put the file with 6

nothings changes

Apache server do not say anything in error or access log

I am using PHP 7.0.8-0ubuntu0.16.04.3 (cli) ( NTS )

What can I do?

Thanks!

Tata
Posts: 2792
Joined: Tue May 20, 2008 5:34 am
Location: Slovakia
Contact:

Re: A fatal error occurred. Enable debug mode for further in

Post by Tata » Sun Dec 11, 2016 6:29 am

1. The most reliable thing is to upload the entire installation into an empty space (e.g. an empty folder) again. the uploaded structure shall be:
2lang
cmsimple
content
core
plugins
templates
userfiles / downloads folder is here
index.php
2. If this doesn't work -find the XHdebug.txt in ./userfles/downloads - dann lese mal http://cmsimpleforum.com/viewtopic.php? ... txt#p47251
Viel Glück.
CMSimple.sk
It's no shame to ask for an answer if all efforts failed.
But it's awful to ask without any effort to find the answer yourself.

cmb
Posts: 12790
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: A fatal error occurred. Enable debug mode for further in

Post by cmb » Sun Dec 11, 2016 10:56 am

dsa wrote:I make the downloads directory and put the file with 6
The download directory should already be there (by default it's userfiles/downloads/), and there is already a file named XHdebug.txt. You just have to rename this file to _XHdebug.txt.
dsa wrote:Apache server do not say anything in error or access log

I am using PHP 7.0.8-0ubuntu0.16.04.3 (cli) ( NTS )
It's unlikely that you're using a (cli) build with Apache. :)
Christoph M. Becker –Plugins for CMSimple_XH, but not for CMSimple 4+

dsa
Posts: 24
Joined: Sun Dec 11, 2016 12:09 am

Re: A fatal error occurred. Enable debug mode for further in

Post by dsa » Sun Dec 11, 2016 12:39 pm

Hi, thank you all

I will replay to all in one mail

1) " The most reliable thing is to upload the entire installation into an empty space "

I have done exactly that

2) "If this doesn't work -find the XHdebug.txt in ./userfles/downloads ....."
Ok, I do and everything is the same
Then I changed config.php download to /userfles/downloads and everything continues the same

3)" It's unlikely that you're using a (cli) build with Apache."

php --version

PHP 7.0.8-0ubuntu0.16.04.3 (cli) ( NTS )
Copyright (c) 1997-2016 The PHP Group
Zend Engine v3.0.0, Copyright (c) 1998-2016 Zend Technologies
with Zend OPcache v7.0.8-0ubuntu0.16.04.3, Copyright (c) 1999-2016, by Zend Technologies

dsa
Posts: 24
Joined: Sun Dec 11, 2016 12:09 am

Re: A fatal error occurred. Enable debug mode for further in

Post by dsa » Sun Dec 11, 2016 12:58 pm

Ok, Im sorry, you want exactly the apache version

its:
Current PHP version: 7.0.8-0ubuntu0.16.04.3

with
<?php
echo 'Current PHP version: ' . phpversion();
?>

in the same directory as cmsimple

dsa
Posts: 24
Joined: Sun Dec 11, 2016 12:09 am

Re: A fatal error occurred. Enable debug mode for further in

Post by dsa » Sun Dec 11, 2016 1:44 pm

I installed now in a home computer and worked perfectly.

I do the same

the version is almost the same, the apache configuration is similar, but is 32 bits.

php
7.0.13-0ubuntu0.16.04.1

The machine with problems is a virtual server in digital ocean
ubuntu-512mb-nyc2-01 512 MB Memory / 20 GB Disk / NYC2 - Ubuntu 16.04 x64

cmb
Posts: 12790
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: A fatal error occurred. Enable debug mode for further in

Post by cmb » Sun Dec 11, 2016 2:36 pm

dsa wrote:2) "If this doesn't work -find the XHdebug.txt in ./userfles/downloads ....."
Ok, I do and everything is the same
Then I changed config.php download to /userfles/downloads and everything continues the same
Hm, this is not supposed to happen. I suggest that you try to enable the debug mode on your home computer. In the administration mode (i.e. after login) you should see a read bar right below the admin menu, which says that debug mode is enabled. If you don't see this red bar, then you didn't properly enable debug mode.
Christoph M. Becker –Plugins for CMSimple_XH, but not for CMSimple 4+

dsa
Posts: 24
Joined: Sun Dec 11, 2016 12:09 am

Re: A fatal error occurred. Enable debug mode for further in

Post by dsa » Sun Dec 11, 2016 5:31 pm

perhaps you can send me the place in code where I can enable by hand the debug mode and get error messages

to see exactly where it fails

dsa
Posts: 24
Joined: Sun Dec 11, 2016 12:09 am

Re: A fatal error occurred. Enable debug mode for further in

Post by dsa » Sun Dec 11, 2016 7:07 pm

Ok

I copied the file, not renamed it

So, I now renamed the file , and I enabled the debug mode

the errors are:

Fatal error: Uncaught Error: Call to undefined function utf8_decode() in /var/www/simusol.org/public_html/Z/plugins/utf8/native/core.php:32 Stack trace: #0 /var/www/simusol.org/public_html/Z/plugins/meta_tags/Metatags_view.php(82): utf8_strlen('') #1 /var/www/simusol.org/public_html/Z/cmsimple/classes/PageDataView.php(127): Metatags_view(Array) #2 /var/www/simusol.org/public_html/Z/cmsimple/classes/PageDataView.php(155): XH_PageDataView->view('./plugins/meta_...') #3 /var/www/simusol.org/public_html/Z/cmsimple/classes/PageDataRouter.php(503): XH_PageDataView->views() #4 /var/www/simusol.org/public_html/Z/cmsimple/cms.php(1167): XH_PageDataRouter->create_tabs(0) #5 /var/www/simusol.org/public_html/Z/index.php(12): include('/var/www/simuso...') #6 {main} thrown in /var/www/simusol.org/public_html/Z/plugins/utf8/native/core.php on line 32

dsa
Posts: 24
Joined: Sun Dec 11, 2016 12:09 am

Re: A fatal error occurred. Enable debug mode for further in

Post by dsa » Sun Dec 11, 2016 8:15 pm

Solved
Thanks!!!

sudo apt-get install php7.0-xml
/etc/init.d/apache2 restart

perhaps is a good idea to tell people not to just copy the file, or change the program so by copying it its enough
and document that in some cases you will need that package installed


now i have, but reversing the move of the debug enabling file its ok

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; Filebrowser_Controller has a deprecated constructor in /var/www/simusol.org/public_html/Z/plugins/filebrowser/classes/Filebrowser_Controller.php on line 31

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; Filebrowser_View has a deprecated constructor in /var/www/simusol.org/public_html/Z/plugins/filebrowser/classes/Filebrowser_View.php on line 28

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; XH_Pages has a deprecated constructor in /var/www/simusol.org/public_html/Z/cmsimple/classes/Pages.php on line 28

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; Pagemanager_Controller has a deprecated constructor in /var/www/simusol.org/public_html/Z/plugins/pagemanager/classes/Controller.php on line 26
Debug-Mode is enabled!
View mode
Pages
Files
Settings
Plugins
Logout
-

Post Reply