Error after php-update

Questions about how to install and problems installing - please read the documentation first!
Post Reply
roze
Posts: 270
Joined: Tue Jun 03, 2008 7:13 am
Location: NL
Contact:

Error after php-update

Post by roze » Thu Dec 28, 2023 1:27 pm

I've made a php update in the admin-space of my web-hoster

now I get this:
Uncaught TypeError: Unsupported operand types: string - int in /home/sanjoy-arte.nl/perfectsound.org/cmsimple/classes/Li.php:77
Stack trace:
#0 /home/sanjoy-arte.nl/perfectsound.org/cmsimple/tplfuncs.php(191): XH\Li->render()
#1 /home/sanjoy-arte.nl/perfectsound.org/cmsimple/tplfuncs.php(460): li()
#2 /home/sanjoy-arte.nl/perfectsound.org/templates/fhs-whitespace/template.htm(65): submenu()
#3 /home/sanjoy-arte.nl/perfectsound.org/cmsimple/cms.php(1335): include('...')
#4 /home/sanjoy-arte.nl/perfectsound.org/index.php(6): include('...')
#5 {main}
thrown in /home/sanjoy-arte.nl/perfectsound.org/cmsimple/classes/Li.php on line 77
How can I solve this?


www.perfectsound.org
Rob Zeijen,

Valkenswaard (NL)

roze
Posts: 270
Joined: Tue Jun 03, 2008 7:13 am
Location: NL
Contact:

Re: Error after php-update

Post by roze » Thu Dec 28, 2023 1:38 pm

And this in the debug mode of another website of myself:

Code: Select all

Uncaught TypeError: Unsupported operand types: string - int in /home/sanjoy-arte.nl/public_html/podologiedommelen.nl/templates/slimmenu02/slimmenu/slimmenu.php:21
Stack trace:
#0 /home/sanjoy-arte.nl/public_html/podologiedommelen.nl/templates/slimmenu02/slimmenu/slimmenu.php(6): liSlimMenu()
#1 /home/sanjoy-arte.nl/public_html/podologiedommelen.nl/templates/slimmenu02/template.htm(124): tocSlimMenu()
#2 /home/sanjoy-arte.nl/public_html/podologiedommelen.nl/cmsimple/cms.php(1335): include('...')
#3 /home/sanjoy-arte.nl/public_html/podologiedommelen.nl/index.php(6): include('...')
#4 {main}
thrown in /home/sanjoy-arte.nl/public_html/podologiedommelen.nl/templates/slimmenu02/slimmenu/slimmenu.php on line 21

www.podologiedommelen.nl
Rob Zeijen,

Valkenswaard (NL)

olape
Posts: 2741
Joined: Fri Mar 13, 2015 8:47 am
Contact:

Re: Error after php-update

Post by olape » Thu Dec 28, 2023 2:47 pm

roze wrote:
Thu Dec 28, 2023 1:27 pm
I've made a php update in the admin-space of my web-hoster

now I get this:
Uncaught TypeError: Unsupported operand types: string - int in /home/sanjoy-arte.nl/perfectsound.org/cmsimple/classes/Li.php:77
Stack trace:
#0 /home/sanjoy-arte.nl/perfectsound.org/cmsimple/tplfuncs.php(191): XH\Li->render()
#1 /home/sanjoy-arte.nl/perfectsound.org/cmsimple/tplfuncs.php(460): li()
#2 /home/sanjoy-arte.nl/perfectsound.org/templates/fhs-whitespace/template.htm(65): submenu()
#3 /home/sanjoy-arte.nl/perfectsound.org/cmsimple/cms.php(1335): include('...')
#4 /home/sanjoy-arte.nl/perfectsound.org/index.php(6): include('...')
#5 {main}
thrown in /home/sanjoy-arte.nl/perfectsound.org/cmsimple/classes/Li.php on line 77
How can I solve this?


www.perfectsound.org
Which PHP versions? Before and after.

Let me guess:

The new PHP version is 8.xx ? Then update CMSimple_XH 1.7.3 --> 1.7.6 first.
Gruß Olaf, Plugins for CMSimple_XH

Ich habe schon lange den Verdacht, dass so viele so eifrig auf Gender, Trans und Queer machen:
Weil sie für das Fachliche ganz einfach zu doof sind.

roze
Posts: 270
Joined: Tue Jun 03, 2008 7:13 am
Location: NL
Contact:

Re: Error after php-update

Post by roze » Thu Dec 28, 2023 3:54 pm

Olaf:

for the website www.perfectsound.org: I updated to the version CMSimple_XH 1.7.6 and that works fine, Thanks!

But for the website www.podologiedommelen.nl I've also made the same update to CMSimple_XH 1.7.6 but again I get this error as before"
Uncaught TypeError: Unsupported operand types: string - int in /home/sanjoy-arte.nl/public_html/podologiedommelen.nl/templates/slimmenu02/slimmenu/slimmenu.php:21
Stack trace:
#0 /home/sanjoy-arte.nl/public_html/podologiedommelen.nl/templates/slimmenu02/slimmenu/slimmenu.php(6): liSlimMenu()
#1 /home/sanjoy-arte.nl/public_html/podologiedommelen.nl/templates/slimmenu02/template.htm(124): tocSlimMenu()
#2 /home/sanjoy-arte.nl/public_html/podologiedommelen.nl/cmsimple/cms.php(1344): include('...')
#3 /home/sanjoy-arte.nl/public_html/podologiedommelen.nl/index.php(6): include('...')
#4 {main}
thrown in /home/sanjoy-arte.nl/public_html/podologiedommelen.nl/templates/slimmenu02/slimmenu/slimmenu.php on line 21
What do I have to do?

Greetings Rob
Rob Zeijen,

Valkenswaard (NL)

Gert
Posts: 3078
Joined: Fri May 30, 2008 4:53 pm
Location: Berlin
Contact:

Re: Error after php-update

Post by Gert » Thu Dec 28, 2023 4:04 pm

Hello,

your template is from 2017, made for php 5 ...

Download this and unzip it:

https://www.ge-webdesign.de/downloadcou ... php?id=537

Take the slimmenu.php from one of the templates, you will find it here:

.../templatefuncs/scripts/slimmenu.php

and overwrite the slimmenu.php of your template, located here:

.../slimmenu/slimmenu.php

with the new slimmenu.php.

For the future, you should look for another template, because SlimMenu will not longer be supported anymore,

Gert
Gert Ebersbach | CMSimple | Templates - Plugins - Services

roze
Posts: 270
Joined: Tue Jun 03, 2008 7:13 am
Location: NL
Contact:

Re: Error after php-update

Post by roze » Thu Dec 28, 2023 4:15 pm

Gert,

Thank you for your help again.

It works fine now. I will go and look for another suitable template.

Greetz
Rob Zeijen,

Valkenswaard (NL)

Post Reply