Editing on iPad

General questions about CMSimple
johnrelphino
Posts: 1
Joined: Mon Mar 04, 2013 11:23 pm

Re: Editing on iPad

Post by johnrelphino » Tue Mar 05, 2013 6:45 am

What would kro23pw be advertising? But whatever his point was, I'd agree that the ipad is far from a content creator. Even light editing is torturous, if you are keen on using the ipad (although I see your problem has been fixed) find a Bluetooth keyboard/mouse combo and setup a workstation. Minor portability issues but overall a better experience in handling the CMS.

mrleejohn
Posts: 33
Joined: Mon Dec 26, 2011 1:54 pm

Re: Editing on iPad

Post by mrleejohn » Tue Mar 05, 2013 10:56 am

Yes, I can edit mrleejohn.nl (cmsimple xh 1.5.6) on my iPad2. As far as I can see I have one problem. I can not select text and add a url.

I find the use of an iPad very handy. I like to edit (minor editting) my site on my iPad. Often I only have an iPad with me.

cmb
Posts: 13272
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Editing on iPad

Post by cmb » Tue Mar 05, 2013 11:24 am

mrleejohn wrote:As far as I can see I have one problem. I can not select text and add a url.
Does this work in the tinyMCE demo (http://www.tinymce.com/tryit/full.php)? (XH 1.5.6 uses the same version of tinyMCE)
Christoph M. Becker – Plugins for CMSimple_XH

mrleejohn
Posts: 33
Joined: Mon Dec 26, 2011 1:54 pm

Re: Editing on iPad

Post by mrleejohn » Fri Mar 08, 2013 10:33 pm

No, when I select some text in ios, I think ios does not tell this to tinymce. I can not add a url at that time.

Recent version cmsimple xh. And an iPad2 with ios6.1.2.

cmb
Posts: 13272
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Editing on iPad

Post by cmb » Fri Mar 08, 2013 11:04 pm

Hmm, when it doesn't work in the tinyMCE demo, it's a general issue with tinyMCE and has to be fixed by the tinyMCE developers. The strange thing is, that I cannot find some bug reports or other information related to this issue. OTOH iOS 6.1 is brand new, and perhaps the bug was introduced only in this release.

I can file a bug report, but just for clarification beforehand:
  1. after you have selected text, the "insert/edit link" button is deactivated, as if no text was selected?
  2. which browser do you use? Safari? Which version?
Christoph M. Becker – Plugins for CMSimple_XH

mrleejohn
Posts: 33
Joined: Mon Dec 26, 2011 1:54 pm

Re: Editing on iPad

Post by mrleejohn » Sun Mar 10, 2013 9:57 am

I had this in iOS5, 6.0, 6.1 and now in 6.1.2. Selecting text on an iPad is different from selecting text with a mouse, I guess.

Also work with some Linux distributions (mouse). Have no probs with those.

bca
Posts: 293
Joined: Tue Sep 15, 2009 4:49 pm

Re: Editing on iPad

Post by bca » Sun Mar 10, 2013 11:11 am

The tinymce demo works ok on my iPad as does my site (after I upgraded).

I also upgraded my iPad to iOS 6.1 and it still works ok

B

cmb
Posts: 13272
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Editing on iPad

Post by cmb » Sun Mar 10, 2013 3:54 pm

mrleejohn wrote:I had this in iOS5, 6.0, 6.1 and now in 6.1.2.
bca wrote:I also upgraded my iPad to iOS 6.1 and it still works ok
Hmm, I guess we have to sort out the differences first, to have a chance to get a fix from the tinyMCE team. Otherwise they may not be able to reproduce the problem at all.

Another solution might be to use CKeditor. Perhaps selecting text works better there on iOS; you can check the online-demo, but note, that the version there is newer than the one available for CMSimple_XH. AFAIK Holger is working on an update.
Christoph M. Becker – Plugins for CMSimple_XH

mrleejohn
Posts: 33
Joined: Mon Dec 26, 2011 1:54 pm

Re: Editing on iPad

Post by mrleejohn » Tue Mar 12, 2013 7:19 am

I did some testing. IPad2 with iOS6.1.2.

On the demopage editting in a way in which I add a url is unstable. But in the end it works. First safari crashed adding the url. In a second attempt I could not add a link. The link-symbol stayed grey and could not be used. In my third attempt it worked.

On my website (fully pathed cmsimple xh 1.5.6) it looked okay. But it just did not add the url. I think that the versions of tinymce are not (exactly) the same. I'm talking specific about adding a url. For the rest seems to work fine.

So... adding url's on an iPad with cmsimple xh is a no-go.

cmb
Posts: 13272
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Editing on iPad

Post by cmb » Tue Mar 12, 2013 11:00 am

mrleejohn wrote:First safari crashed adding the url. In a second attempt I could not add a link. The link-symbol stayed grey and could not be used. In my third attempt it worked.
Seems to be pretty unstable, and probably particularly hard to debug. :(
mrleejohn wrote:On my website (fully pathed cmsimple xh 1.5.6) it looked okay. But it just did not add the url.
Are you referring to a manually entered URL, or a URL selected with the filebrowser. In the latter case, this is quite likely a CMSimple related problem (the filebrowser is not part of tinyMCE, and the filebrowser used in the tinyMCE website it quite different).

So, when exactly is the URL not added? When you close the insert/edit link dialogue, or when you select the URL from the filebrowser?
mrleejohn wrote:So... adding url's on an iPad with cmsimple xh is a no-go.
Have you tested CKEditor?
Christoph M. Becker – Plugins for CMSimple_XH

Post Reply