Page 1 of 1

Disable display a fatal error has occurred...

Posted: Mon Jan 16, 2023 7:48 am
by doczimut
Hello
I now have an alert message on a few sites: "A fatal error has occurred. Enable Debug Mode".
I haven't changed anything (no error locally for the same site in php 7.4). So while waiting for a more in-depth search, how can this alert no longer appear? Thanks.

Re: Disable display a fatal error has occurred...

Posted: Mon Jan 16, 2023 8:19 am
by olape
Have you activated the debug mode?

Re: Disable display a fatal error has occurred...

Posted: Mon Jan 16, 2023 2:10 pm
by doczimut
I had touched something, not on the sites, but the version of the server, PHP from 7.4 to 8.2. In 8.2, a problem is then present and fixed with the error messages displayed (debug mode).
I had in the template <?php echo onepage_toplink(TOP); ?>
The error disappears with (without the TOP) <?php echo onepage_toplink(); ?>
I don't know why, I added this top, non-existent in the original template (op-goaway).

Re: Disable display a fatal error has occurred...

Posted: Mon Jan 16, 2023 4:01 pm
by cmb
doczimut wrote:
Mon Jan 16, 2023 2:10 pm
I had in the template <?php echo onepage_toplink(TOP); ?>
That should be

Code: Select all

<?php echo onepage_toplink('TOP');?>
(note the single quotation marks)

Re: Disable display a fatal error has occurred...

Posted: Mon Jan 16, 2023 4:45 pm
by doczimut
Yes, that's fine, TOP enclosed in single quotes.
Thanks.