jquery giving no effect

General questions about CMSimple
Post Reply
bastingse
Posts: 253
Joined: Fri Jun 06, 2008 9:38 pm
Location: Netherlands
Contact:

jquery giving no effect

Post by bastingse » Sat Oct 01, 2016 7:21 am

Folks,
I'm using a jquery effect on a website but the result is zero.
As you can see here http://www.jqueryscript.net/demo/Create ... uery-CSS3/ the content blocks a jumping into the page from left and right while you are scrolling down.

Using this in a cmsimple template it does not work. What can cause the problem for this???
http://mosamprodukties.nl/index.php?Tijdlijn

Template Head:

Code: Select all

<head>
<link href='http://fonts.googleapis.com/css?family=Droid+Serif|Open+Sans:400,700' rel='stylesheet' type='text/css'>
<link rel="stylesheet" href="css/style.css"> <!-- Resource style -->
<script src="js/modernizr.js"></script> <!-- Modernizr -->
<?php echo head();?>
<style type="text/css">
body, html {margin:0; padding:0; border:0;} /* Re-sets IE to "zero" for these values */
</style>
</head>
Template Body:

Code: Select all

</div>

<script src="js/main.js"></script> <!-- Resource jQuery -->
</body>
</html>
Any help is much appreciated!

frase
Posts: 2023
Joined: Thu Apr 21, 2016 6:32 am
Location: Saxony
Contact:

Re: jquery giving no effect

Post by frase » Sat Oct 01, 2016 8:08 am

jQuery v1.11.3 -> jQuery v2.1.1 [edit] irrelevant

main.js ??? !!! not found

<!doctype html>

bastingse
Posts: 253
Joined: Fri Jun 06, 2008 9:38 pm
Location: Netherlands
Contact:

Re: jquery giving no effect

Post by bastingse » Sat Oct 01, 2016 10:35 am

frase wrote: main.js ??? !!! not found
http://mosamprodukties.nl/js/main.js

frase
Posts: 2023
Joined: Thu Apr 21, 2016 6:32 am
Location: Saxony
Contact:

Re: jquery giving no effect

Post by frase » Sat Oct 01, 2016 10:39 am

Yes, exist on the server.
In template?
---

Doubtful, inside a Table-based Layout ...?

bastingse
Posts: 253
Joined: Fri Jun 06, 2008 9:38 pm
Location: Netherlands
Contact:

Re: jquery giving no effect

Post by bastingse » Sat Oct 01, 2016 11:20 am

frase wrote:Yes, exist on the server.
In template?
Yes, also in template. It was in the body first , i replace it to the header but noting did change
frase wrote:Doubtful, inside a Table-based Layout ...?
I replace it outside the table now, nothing change :(

frase
Posts: 2023
Joined: Thu Apr 21, 2016 6:32 am
Location: Saxony
Contact:

Re: jquery giving no effect

Post by frase » Sat Oct 01, 2016 11:21 am

place the script inside the body-tag.

bastingse
Posts: 253
Joined: Fri Jun 06, 2008 9:38 pm
Location: Netherlands
Contact:

Re: jquery giving no effect

Post by bastingse » Sat Oct 01, 2016 11:30 am

frase wrote: <!doctype html>
I did forget this one... that did the trick :D
Thanks Frase !!!

frase
Posts: 2023
Joined: Thu Apr 21, 2016 6:32 am
Location: Saxony
Contact:

Re: jquery giving no effect

Post by frase » Sat Oct 01, 2016 11:33 am

looks good.

often is it helpful: F12

But, where is your menu? Home...
[edit] okay ... i see

Post Reply