Portable_XH 2 - development preview

A place for general not CMSimple related discussions
cmb
Posts: 13273
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Portable_XH 2 - development preview

Post by cmb » Wed Jul 01, 2015 1:40 am

Hi everybody!

This is all about "Seven" – and quite like the movie of the same name, it is not for the faint of heart!

I've decided to make available a development preview of Portable_XH, including the most recent PHP 7.0.0alpha2 and a very early development snapshot of CMSimple_XH 1.7 (I've called it 1.7.0dev1). This is all about killing three birds with one stone: early testing of CMSimple_XH 1.7, PHP 7 and minimal PHP build suitable for Portable_XH. Note, that you need a 64bit Windows system to run Portable_XH 2 (for details see README.txt).

As you may notice, Portable_XH 2.0dev1 is drastically reduced in size – that is because I've omitted a lot of extensions that are usually not necessary for CMSimple_XH. The chosen selection is not fixed; please report missing extensions, and I'll consider to include them in future releases.

Please report any problems you encounter – this is likely to help to improve CMSimple_XH, PHP and Portable_XH. The venturous may consider to enable debug mode, and to report respective messages.

And yes, I've already encountered a problem: uploading an image results in a fatal error – I'll try to investigate...
Christoph M. Becker – Plugins for CMSimple_XH

cmb
Posts: 13273
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Portable_XH 2 - development preview

Post by cmb » Wed Jul 01, 2015 11:38 am

cmb wrote:And yes, I've already encountered a problem: uploading an image results in a fatal error – I'll try to investigate...
I've filed a respective bug report.
Christoph M. Becker – Plugins for CMSimple_XH

lck
Posts: 1845
Joined: Wed Mar 23, 2011 11:43 am
Contact:

Re: Portable_XH 2 - development preview

Post by lck » Thu Jul 02, 2015 4:09 pm

cmb wrote:And yes, I've already encountered a problem: uploading an image results in a fatal error – I'll try to investigate...
Der gleiche Fehler tritt beim Anlegen eines Unterordners oder beim Hochladen einer Text-Datei auf
Fatal error: Uncaught TypeError: Argument 2 passed to Filebrowser\View::success() must be of the type array, string given, called in C:\...
Die Passwort vergessen-Funktion kann anscheinend nicht lokal getestet werden, bekomme da auch einen "Fatal error"
Fatal error: Uncaught Error: Call to undefined method XH\Mailform::sendMail() in C:\...
Für was ist eigentlich die Einstellung in der Konfiguration unter:
E-Mail-Formular
Lf only
„Bevor du den Pfeil der Wahrheit abschießt, tauche die Spitze in Honig!“   👉 Ludwig's XH-Templates for MultiPage & OnePage

cmb
Posts: 13273
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Portable_XH 2 - development preview

Post by cmb » Thu Jul 02, 2015 4:20 pm

Ludwig wrote:Der gleiche Fehler tritt beim Anlegen eines Unterordners oder beim Hochladen einer Text-Datei auf
Das dürfte die gleiche Ursache haben, und sollte mit dem nächsten Sprint behoben sein.
Ludwig wrote:Die Passwort vergessen-Funktion kann anscheinend nicht lokal getestet werden, bekomme da auch einen "Fatal error"
Danke für den Hinweis. Das schaue ich mir heute noch näher an.
Ludwig wrote:Für was ist eigentlich die Einstellung in der Konfiguration unter:
Das kann für einige Mailer unter Unix artigen Systemen erforderlich sein, die ohne diese Einstellung Teile der E-Mail-Header im Body ausgeben. Siehe auch den entsprechenden Abschnitt im Wiki. Also im Zweifel einfach mal eine Mail per Kontaktformular versenden, und wenn dann oberhalb von "Ihr Name: Max Mustermann" noch etwas steht, dann mal mit "Lf only" aktiviert probieren.
Christoph M. Becker – Plugins for CMSimple_XH

Tata
Posts: 3068
Joined: Tue May 20, 2008 5:34 am
Location: Slovakia
Contact:

Re: Portable_XH 2 - development preview

Post by Tata » Thu Jul 02, 2015 5:32 pm

I run iMAC with Yosemite and Parallels Desktop for running Windows 7. After launching Portable_XH the Error returns saying:
The program can't start VCRUNTIME140.dll is missing from your computer.
Try reinstalling the program to fix this problem.

Tried to reinstall VisualStudio and the VCRUNTIME140.dll. No progress. Still the same error.
CMSimple.sk
It's no shame to ask for an answer if all efforts failed.
But it's awful to ask without any effort to find the answer yourself.

cmb
Posts: 13273
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Portable_XH 2 - development preview

Post by cmb » Thu Jul 02, 2015 6:05 pm

Tata wrote:Tried to reinstall VisualStudio and the VCRUNTIME140.dll. No progress. Still the same error.
You don't have to install VisualStudio – that would be overkill. It should be sufficient to install the Visual C++ Redistributable for Visual Studio 2015 RC. It is important to install the x64 version (vc_redist.x64.exe).
Christoph M. Becker – Plugins for CMSimple_XH

Tata
Posts: 3068
Joined: Tue May 20, 2008 5:34 am
Location: Slovakia
Contact:

Re: Portable_XH 2 - development preview

Post by Tata » Thu Jul 02, 2015 8:10 pm

Hm...
This page can’t be displayed
•Make sure the web address http://localhost:8080 is correct.
•Look for the page with your search engine.
•Refresh the page in a few minutes.
CMSimple.sk
It's no shame to ask for an answer if all efforts failed.
But it's awful to ask without any effort to find the answer yourself.

cmb
Posts: 13273
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Portable_XH 2 - development preview

Post by cmb » Thu Jul 02, 2015 8:14 pm

Tata wrote:Make sure the web address http://localhost:8080 is correct.
Hm, maybe localhost is not recognized? Have you tried http://127.0.0.1:8080?

And of course have a look at the console window which should be opened after executing Portable_XH.bat.
Christoph M. Becker – Plugins for CMSimple_XH

cmb
Posts: 13273
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Portable_XH 2 - development preview

Post by cmb » Fri Jul 03, 2015 12:16 am

cmb wrote:
Ludwig wrote:Die Passwort vergessen-Funktion kann anscheinend nicht lokal getestet werden, bekomme da auch einen "Fatal error"
Danke für den Hinweis. Das schaue ich mir heute noch näher an.
Da hast Du einen dicken Bug gefunden, den ich gleich mal gefixt habe. Vielen Dank fürs Testen und Melden! Allein dafür hat sich der Aufwand von Portable_XH 2.0dev1 schon gelohnt. :) Leider haben wir noch viel zu viele Stellen, wo automatisierte Tests, um solche Probleme zu erkennen, zu aufwendig bis unmöglich sind.

Trotz der vorhandenen Fehler und Probleme bitte ich darum, dass Ihr weiter testet. Es dürfte bspw. so manches ältere Plugin geben, dass unter PHP 7.0.0 völlig versagt (Stichwort ereg). Vielleicht findet sich ja jemand, der diese Plugins zumindest notdürftig anpasst.
Christoph M. Becker – Plugins for CMSimple_XH

lck
Posts: 1845
Joined: Wed Mar 23, 2011 11:43 am
Contact:

Re: Portable_XH 2 - development preview

Post by lck » Fri Jul 03, 2015 9:38 am

cmb wrote:Das kann für einige Mailer unter Unix artigen Systemen erforderlich sein, die ohne diese Einstellung Teile der E-Mail-Header im Body ausgeben. Siehe auch den entsprechenden Abschnitt im Wiki. Also im Zweifel einfach mal eine Mail per Kontaktformular versenden, und wenn dann oberhalb von "Ihr Name: Max Mustermann" noch etwas steht, dann mal mit "Lf only" aktiviert probieren.
Besten Dank für die Erklärung.
Lokal passts, steht nichts oberhalb.
Hatte natürlich vorher im Wiki gesucht mit Google nach "Lf only" site:www.cmsimple-xh.org, kein Ergebnis. Mit "lf_only" site:www.cmsimple-xh.org hätte man es finden können :)

Könnte man bei dieser Option, nicht auch ein Fragezeichen mit einem kurzen Erklärungstext einbauen?
„Bevor du den Pfeil der Wahrheit abschießt, tauche die Spitze in Honig!“   👉 Ludwig's XH-Templates for MultiPage & OnePage

Post Reply