CMSimple_XH 1.6

A place for general not CMSimple related discussions
uwes
Posts: 41
Joined: Mon Oct 01, 2012 8:40 am

Re: CMSimple_XH 1.6

Post by uwes » Fri Jan 24, 2014 3:09 pm

I get a 404.

The folder was at 0755, but I also tried some other combinations. No .htaccess around.

uwes
Posts: 41
Joined: Mon Oct 01, 2012 8:40 am

Re: CMSimple_XH 1.6

Post by uwes » Fri Jan 24, 2014 3:13 pm

Okay, something seems to be weird. I tried to delete and re-upload the javascript folder, but the server refuses to delete both the folder and the file. I should contact the server administrator.

cmb
Posts: 13286
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: CMSimple_XH 1.6

Post by cmb » Fri Jan 24, 2014 3:19 pm

uwes wrote:I should contact the server administrator.
Indeed, that seems appropriate. :)
Christoph M. Becker – Plugins for CMSimple_XH

svasti
Posts: 1649
Joined: Wed Dec 17, 2008 5:08 pm

Re: CMSimple_XH 1.6

Post by svasti » Fri Jan 24, 2014 4:42 pm

In case strange things happen or rather don't I found it helpful to select in filezilla: Server -> Force showing hidden files.
Sometimes, when files cannot be deleted, renaming folder or file helps.

cmb
Posts: 13286
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: CMSimple_XH 1.6

Post by cmb » Fri Jan 24, 2014 5:16 pm

Bob wrote:I wanted just say that certain localized strings (title, meta markup, texts) had more their place in the content (as pagedata strings) than in the common translation file. I know that these modifications were complex and we'll do with that while waiting for better...
I've put "Improve updateability wrt. language strings/config" on the roadmap for XH 1.7 to not forget about it. :)
Christoph M. Becker – Plugins for CMSimple_XH

Bob
Posts: 120
Joined: Sat Jun 14, 2008 8:30 am
Location: France
Contact:

Re: CMSimple_XH 1.6

Post by Bob » Fri Jan 24, 2014 5:39 pm

CMSimple XH 1.6 looks fine, but I can't change my password. When I click the "Change password" button in Settings - CMS, nothing happens.
Hi
I have a problem which looks like that. The access to the admin on a distant server (not local) with the password "test" blocks the site. I have to erase cookies to reload the site. No .htaccess. CHMOD 604 on files. javascript/admin.js is accessible.
:?
Bob

EDIT : Found! It's a OVH server wich need an .htaccess (to execute PHP 5 for example). I added :

Code: Select all

#Suppression des ID de session sur OVH
SetEnv SESSION_USE_TRANS_SID 0
I think the problem was the sessions ID (i saw them in certain URL).

uwes
Posts: 41
Joined: Mon Oct 01, 2012 8:40 am

Re: CMSimple_XH 1.6

Post by uwes » Fri Jan 24, 2014 8:52 pm

I'm back with a diagnosis, but I don't have a cure yet.

Symptom: javascript/admin.js is not accessible (404) while file and folder are in place.

I found out that the server redirects the file request to /usr/share/javascript/admin.js The reason for this is still unknown - my webhosting provider's support staff needs to ask the technical department which will be back at work on monday. But, in fact, the reason is the folder name "javascript"; when I change the folder name to "javaskript" or "java", the file request works. This gives me some doubt if "javascript" is a wise choice for a folder name containing this single file.

While the technical staff might be coming up with a "real" backend solution on monday, is there a simple way to make CMSimple XH 1.6 work with a different folder name?

cmb
Posts: 13286
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: CMSimple_XH 1.6

Post by cmb » Fri Jan 24, 2014 9:04 pm

uwes wrote:But, in fact, the reason is the folder name "javascript"; when I change the folder name to "javaskript" or "java", the file request works. This gives me some doubt if "javascript" is a wise choice for a folder name containing this single file.
Indeed. :o We may have to rethink this decision. Originally I had js/ in mind, but back then this was not possible, because js/ would have been incorrectly recognized as second language folder.
uwes wrote:is there a simple way to make CMSimple XH 1.6 work with a different folder name?
Yes. Just change line 284 in cmsimple/cms.php as appropriate, e.g.

Code: Select all

$pth['file']['adminjs'] = $pth['folder']['base'] . 'javaskript/admin.js';
uwes wrote:While the technical staff might be coming up with a "real" backend solution on monday
It would be nice, if you'll give feedback then. I'm still somewhat puzzled why a provider would configure the server this way.

PS: Now I found http://serverfault.com/questions/274254 ... ipt-folder. Seems we have to rename the folder, because Ubuntu Apache has the mentioned redirect by default. :roll:
Last edited by cmb on Fri Jan 24, 2014 9:11 pm, edited 1 time in total.
Reason: added PS
Christoph M. Becker – Plugins for CMSimple_XH

uwes
Posts: 41
Joined: Mon Oct 01, 2012 8:40 am

Re: CMSimple_XH 1.6

Post by uwes » Fri Jan 24, 2014 9:13 pm

cmb wrote:
uwes wrote:While the technical staff might be coming up with a "real" backend solution on monday
It would be nice, if you'll give feedback then. I'm still somewhat puzzled why a provider would configure the server this way.
You'll get my report on monday. And, yes, I was puzzled, too.

cmb
Posts: 13286
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: CMSimple_XH 1.6

Post by cmb » Fri Jan 24, 2014 9:15 pm

I've just added a PS to my former post, which most likely explains the issue.
Christoph M. Becker – Plugins for CMSimple_XH

Post Reply