CMSimple_XH 1.7.0

A place for general not CMSimple related discussions
manu
Posts: 618
Joined: Wed Jun 04, 2008 12:05 pm
Location: St. Gallen - Schweiz
Contact:

Re: CMSimple_XH 1.7.0

Postby manu » Mon Jul 03, 2017 6:32 pm

ojay wrote:Für ein Update ist der Änderungsschritt ziemlich (zu) groß. Gerade, die sich nicht in ein CMS einarbeiten wollen, werden damit nicht froh.
Wer mit v.1.7.0 startet wird vermutlich zufriedener sein, als mit den Vorversionen.
Obwohl die Version 1.7.0 eine super Sache ist, finde ich die update Meldung, von 1.6.x auf 1.7.0 upzudaten schon ambitioniert. Könnten wir nicht mittels der version.nfo zuerst einmal im updatecheck die Version 1.6.10 (bis zum EOL) anbieten? Danach können wir ja die Version.nfo auf 1.7.0 setzen.
Gruss manu

Tata
Posts: 2531
Joined: Tue May 20, 2008 5:34 am
Location: Slovakia
Contact:

Re: CMSimple_XH 1.7.0

Postby Tata » Mon Jul 03, 2017 6:43 pm

Nun, ich muss zugeben, dass ich bisschen gefürchtet habe, von 1.6.9 zu 1.7.0 zu übergehen. Im Prinzip war es aber kein Problem. Die Kleinigkeiten, die ich hier gleich gemeldet habe, wurden fast alle von mir verursacht. Die http://cmsimple.sk läuft noch am 1.6.10. Die "1.7.0-Kopie" ist testweise am http://cmsimplexh170.cmsimple.sk.
Einige Plugins sind zwar ausgefallen. Aber das ist nur eine Zeitfrage, bis sie modernisiert werden.
CMSimple.sk
It's no shame to ask for an answer if all efforts failed.
But it's awful to ask without any effort to find the answer yourself.

Tata
Posts: 2531
Joined: Tue May 20, 2008 5:34 am
Location: Slovakia
Contact:

Re: CMSimple_XH 1.7.0

Postby Tata » Mon Jul 03, 2017 8:20 pm

Etwas habe ich falsch gemacht. Ich wollte jetzt die "1.7.0 Kopie" hochladen und es wirft "500" zurück. Sie läuft in Subdomain ohne Probleme. Lade die 1.6.10 wieder zurück.
EDIT:
1.6.10 zurück hochgeladen läuft gut.

CMSimple_XH 1.6.10 Released: 2017-06-18

Ckeditor 2.2.1
Dlcounter 1.0beta1
Downloadcontrol 1.7
Exchange 1.0
Expandcontract 0.7
Fa 1.1
Filebrowser for CMSimple_XH 1.6.10
Flexslider 0.5
Foldergallery 1.0beta1
Hi_fancybox v. 4.1
Hi_updatecheck 1.4
Imagescroller
Jquery 1.6.4
Meta_tags for CMSimple_XH 1.6.10
Onepage
Pagemanager 2.0.6
Page_params for CMSimple_XH 1.6.10
Realblog 3.0beta8
Slideshow 1beta3
Themeswitcher 1.0beta2
Tinymce for CMSimple_XH 1.6.10
Tinymce4
Translator 1.0beta8
Utf8 0.5.5

Webserver

Apache

PHP-verzia:

7.0.5
CMSimple.sk
It's no shame to ask for an answer if all efforts failed.
But it's awful to ask without any effort to find the answer yourself.

Holger
Site Admin
Posts: 2715
Joined: Mon May 19, 2008 7:10 pm
Location: Hessen, Germany
Contact:

Re: CMSimple_XH 1.7.0

Postby Holger » Mon Jul 03, 2017 9:07 pm

manu wrote:Obwohl die Version 1.7.0 eine super Sache ist, finde ich die update Meldung, von 1.6.x auf 1.7.0 upzudaten schon ambitioniert. Könnten wir nicht mittels der version.nfo zuerst einmal im updatecheck die Version 1.6.10 (bis zum EOL) anbieten? Danach können wir ja die Version.nfo auf 1.7.0 setzen.

Die Idee war schon da: https://github.com/TN03/hi_updatecheck/issues/3 , kam aber leider zu spät für 1.6. Aber insgesamt finde ich es eine gute Idee, verteilte Version-Infos für Minor-Versionen einzuführen.

Aber EOL von 1.6 ist ja schon erreicht:
02.07.2017 – EOL v1.6.x

After nearly three and a half year the CMSimple_XH 1.6 series has reached its end-of-life today. No bugfixes and security patches will be made available from this day on.
siehe http://www.cmsimple-xh.org/?History_and_Changelog

Tata
Posts: 2531
Joined: Tue May 20, 2008 5:34 am
Location: Slovakia
Contact:

Re: CMSimple_XH 1.7.0

Postby Tata » Mon Jul 03, 2017 9:15 pm

Noch habe ich es mit http://cmsimple.sk/sk170 versucht. Es liest, liest, liest und nichts :-(
Was verursacht das?
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator at support@exohosting.sk to inform them of the time this error occurred, and the actions you performed just before this error.
More information about this error may be available in the server error log.

Das sagen die letzte Zeilen in Server error log:
[Mon Jul 03 23:22:04.014592 2017] [-:error] cmsimple.sk [pid 6198:tid 34590511104] [client 164.132.161.55:46158] The Zend Engine API version 220131226 which is installed, is outdated.
[Mon Jul 03 23:22:04.015840 2017] [-:error] cmsimple.sk [pid 6198:tid 34590511104] [client 164.132.161.55:46158]
[Mon Jul 03 23:22:04.017314 2017] [-:error] cmsimple.sk [pid 6198:tid 34590511104] [client 164.132.161.55:46158] PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/php7/extension/mysqli.so' - /usr/local/php7/extension/mysqli.so: Undefined symbol "zend_ce_exception" in Unknown on line 0
[Mon Jul 03 23:22:04.018763 2017] [-:error] cmsimple.sk [pid 6198:tid 34590511104] [client 164.132.161.55:46158] PHP Warning: PHP Startup: openssl: Unable to initialize module
[Mon Jul 03 23:22:04.020100 2017] [-:error] cmsimple.sk [pid 6198:tid 34590511104] [client 164.132.161.55:46158] Module compiled with module API=20151012
[Mon Jul 03 23:22:04.021400 2017] [-:error] cmsimple.sk [pid 6198:tid 34590511104] [client 164.132.161.55:46158] PHP compiled with module API=20131226
[Mon Jul 03 23:22:04.022736 2017] [-:error] cmsimple.sk [pid 6198:tid 34590511104] [client 164.132.161.55:46158] These options need to match
[Mon Jul 03 23:22:04.024243 2017] [-:error] cmsimple.sk [pid 6198:tid 34590511104] [client 164.132.161.55:46158] in Unknown on line 0
[Mon Jul 03 23:22:04.026291 2017] [-:error] cmsimple.sk [pid 6198:tid 34590511104] [client 164.132.161.55:46158] PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/php7/extension/pdo.so' - /usr/local/php7/extension/pdo.so: Undefined symbol "zend_ce_exception" in Unknown on line 0
[Mon Jul 03 23:22:04.027636 2017] [-:error] cmsimple.sk [pid 6198:tid 34590511104] [client 164.132.161.55:46158] PHP Warning: PHP Startup: pdo_mysql: Unable to initialize module
[Mon Jul 03 23:22:04.028951 2017] [-:error] cmsimple.sk [pid 6198:tid 34590511104] [client 164.132.161.55:46158] Module compiled with module API=20151012
[Mon Jul 03 23:22:04.030284 2017] [-:error] cmsimple.sk [pid 6198:tid 34590511104] [client 164.132.161.55:46158] PHP compiled with module API=20131226
[Mon Jul 03 23:22:04.031571 2017] [-:error] cmsimple.sk [pid 6198:tid 34590511104] [client 164.132.161.55:46158] These options need to match
Das sagt mir aber gar nichts.
CMSimple.sk
It's no shame to ask for an answer if all efforts failed.
But it's awful to ask without any effort to find the answer yourself.

cmb
Posts: 12047
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: CMSimple_XH 1.7.0

Postby cmb » Mon Jul 03, 2017 9:31 pm

ojay wrote:Aber der Admin-Login funktioniert nicht. Auch die 'Passwort vergessen'-Funktion schickt keinen gültiges Passwort zu.
Wie komme ich wieder rein?

Du kannst den Password-Hash direkt in cmsimple/config.php ändern; was dort genau eingetragen werden muss, steht in README_DE.txt.

ojay wrote:Für ein Update ist der Änderungsschritt ziemlich (zu) groß. Gerade, die sich nicht in ein CMS einarbeiten wollen, werden damit nicht froh.

Von 1.6.x nach 1.7 ist schon ein ordentlicher Update-Aufwand, aber das war von 1.4.x auf 1.5 und von 1.5.x auf 1.6 auch so, und der 1.6er Zweig existierte immerhin 3 ½ Jahre – und wir sollten nicht auf der Stelle treten, denke ich.

manu wrote:Obwohl die Version 1.7.0 eine super Sache ist, finde ich die update Meldung, von 1.6.x auf 1.7.0 upzudaten schon ambitioniert. Könnten wir nicht mittels der version.nfo zuerst einmal im updatecheck die Version 1.6.10 (bis zum EOL) anbieten?

1.6 hat bereits sein Lebensende erreicht (wir hatten vor langer Zeit abgestimmt, dass das am 30.6.2016 sein soll, und aufgrund der Verzögerung hatte ich das vor Monaten kurzerhand um ein Jahr verlängert – mehr geht IMO nicht, einfach weil wir uns dann unter Umständen noch mit PHP 4.3 Problemen rumschlagen müssten – ich finde PHP 5.3 schon nicht mehr zeitgemäß). Und dann gibt es noch ein praktisches Problem, nämlich dass der Pfad zur serverseitigen version.nfo im UpdateCheck hard kodiert ist, so dass das Plugin selbst geändert werden müsste, aber User die aktuelle Version evtl. bereits unter XH 1.6.10 eingespielt haben. Es gibt bereits einen Feature-Request um das zu ändern.

Tata wrote:Etwas habe ich falsch gemacht. Ich wollte jetzt die "1.7.0 Kopie" hochladen und es wirft "500" zurück.

Zeigt der Debug-Modus nichts an?
Last edited by cmb on Mon Jul 03, 2017 9:43 pm, edited 1 time in total.
Reason: Quote korrigiert
Christoph M. Becker –Plugins for CMSimple_XH, but not for CMSimple 4+

Tata
Posts: 2531
Joined: Tue May 20, 2008 5:34 am
Location: Slovakia
Contact:

Re: CMSimple_XH 1.7.0

Postby Tata » Mon Jul 03, 2017 9:40 pm

cmb wrote:
Tata wrote:Obwohl die Version 1.7.0 eine super Sache ist, finde ich die update Meldung, von 1.6.x auf 1.7.0 upzudaten schon ambitioniert. Könnten wir nicht mittels der version.nfo zuerst einmal im updatecheck die Version 1.6.10 (bis zum EOL) anbieten?

Das schrieb ich nicht. :-)
CMSimple.sk
It's no shame to ask for an answer if all efforts failed.
But it's awful to ask without any effort to find the answer yourself.

Tata
Posts: 2531
Joined: Tue May 20, 2008 5:34 am
Location: Slovakia
Contact:

Re: CMSimple_XH 1.7.0

Postby Tata » Mon Jul 03, 2017 9:41 pm

cmb wrote:Zeigt der Debug-Modus nichts an?

Nein, es scheint als ob CMSimple_XHv1.7.0 absolut nicht geladen ist.
CMSimple.sk
It's no shame to ask for an answer if all efforts failed.
But it's awful to ask without any effort to find the answer yourself.

cmb
Posts: 12047
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: CMSimple_XH 1.7.0

Postby cmb » Mon Jul 03, 2017 9:49 pm

Tata wrote:Das schrieb ich nicht. :-)

Sorry, korrigiert.

Tata wrote:Das sagen die letzte Zeilen in Server error log:

Ui! Das hat nichts mit CMSimple_XH zu tun, sondern da stimmt was mit der PHP-Installation nicht:
The Zend Engine API version 220131226 which is installed, is outdated.

Das deutet auf PHP 5.6 hin.
Module compiled with module API=20151012

Aber das auf eine Extension, die für PHP 7.0 kompiliert wurde.
Christoph M. Becker –Plugins for CMSimple_XH, but not for CMSimple 4+

Tata
Posts: 2531
Joined: Tue May 20, 2008 5:34 am
Location: Slovakia
Contact:

Re: CMSimple_XH 1.7.0

Postby Tata » Mon Jul 03, 2017 9:59 pm

Jetzt habe ich eine saubere Installayion hochgeladen auf http://novavolba.info. Es ist eigentlich ein unterordner von cmsimple.sk mit eigener URL. Da läuft es. Komisch, oder?
EDIT:
Schritt-nach-Schritt lade ich jetzt alles von v1.7.0 hoch und soweit, kein Problem.
Alles hochgeladen und ausser tpl_funcs.php scheint alles zu laufen. Morgen abends schaue ich näher an.
Last edited by Tata on Mon Jul 03, 2017 10:29 pm, edited 3 times in total.
CMSimple.sk
It's no shame to ask for an answer if all efforts failed.
But it's awful to ask without any effort to find the answer yourself.


Return to “General Discussions & Announcements”

Who is online

Users browsing this forum: No registered users and 2 guests