Upgrade to PHP 7

A place for general not CMSimple related discussions
Tata
Posts: 2790
Joined: Tue May 20, 2008 5:34 am
Location: Slovakia
Contact:

Upgrade to PHP 7

Post by Tata » Thu Feb 09, 2017 10:24 pm

Nachdem ich am Server (testweise) zu PHP7 upgegradet habe, auf einige der Seiten kann ich entweder nicht einloggen, oder nachdem ich etwas im Adminmenu ankclicke, bekomme ich weise Seite. Die Konsole zeigt auch nicht, oder bekomme ich
Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; XH_CSRFProtection has a deprecated constructor in /www/c/m/u13296/public_html/_sub/dddlan/cmsimple/classes/CSRFProtection.php on line 28

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; PasswordHash has a deprecated constructor in /www/c/m/u13296/public_html/_sub/dddlan/cmsimple/classes/PasswordHash.php on line 27

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; XH_PageDataRouter has a deprecated constructor in /www/c/m/u13296/public_html/_sub/dddlan/cmsimple/classes/PageDataRouter.php on line 29

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; XH_PageDataModel has a deprecated constructor in /www/c/m/u13296/public_html/_sub/dddlan/cmsimple/classes/PageDataModel.php on line 31

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; XH_PageDataView has a deprecated constructor in /www/c/m/u13296/public_html/_sub/dddlan/cmsimple/classes/PageDataView.php on line 28

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; XH_PluginMenu has a deprecated constructor in /www/c/m/u13296/public_html/_sub/dddlan/cmsimple/classes/PluginMenu.php on line 30

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; XH_ClassicPluginMenu has a deprecated constructor in /www/c/m/u13296/public_html/_sub/dddlan/cmsimple/classes/PluginMenu.php on line 256
als ob XHdebug eingeschaltetwäre. Die Konsole zeigt auch gar nichts.
Z.B. auf http://cmsimple.sk kann ich gar nicht einloggen. Die läuft nur noch am 1.5.3 (upgrade ist noch nicht fertig).
Einige der Seiten laufen schon, nachdem ich E_NOTICE und E_DEPRECATED in php.ini ausgeschaltet habe.
CMSimple.sk
It's no shame to ask for an answer if all efforts failed.
But it's awful to ask without any effort to find the answer yourself.

Tata
Posts: 2790
Joined: Tue May 20, 2008 5:34 am
Location: Slovakia
Contact:

Re: Upgrade to PHP 7

Post by Tata » Fri Feb 10, 2017 6:51 am

Ich habe folgendes gegoogelt, sagt mir aber sehr wenig:
http://php.net/manual/en/migration70.incompatible.php
Was ich aber nicht verstehen kann ist, dass am Localhost (PHP 7.0.8) alles Seiten laufen ohne Fehler, sogar die "uralte" - v1.5.x). Am Host aber nicht. Und wieder:
1. Einige öffnen sich gar nicht.
2. Einige öffnen sich, aber erlauber kein Loggin.
3. Einige laufen, erlauben Login, lassen aber Adminmenu nicht nutzen (entw. reagieren nicht, oder werfen leere Seiten)
4. Fast alle aber werfen die "DEPRECATED" Notizen (obwohl XHdebug nicht aktiviert ist).
CMSimple.sk
It's no shame to ask for an answer if all efforts failed.
But it's awful to ask without any effort to find the answer yourself.

cmb
Posts: 12770
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Upgrade to PHP 7

Post by cmb » Fri Feb 10, 2017 10:15 am

Tata wrote:Was ich aber nicht verstehen kann ist, dass am Localhost (PHP 7.0.8) alles Seiten laufen ohne Fehler, sogar die "uralte" - v1.5.x). Am Host aber nicht.
Das liegt wahrscheinlich an unterschiedlichen Einstellungen von error_reporting und display_errors. display_errors sollte auf Produktionssystemen deaktiviert sein, und dann werden die Deprecation-Warnings nur noch im Debug-Modus angezeigt, und verursachen keine weiteren Störungen.

Weiterhin kann es sein, dass auf dem Server bestimmte Extensions nicht verfügbar sind, die auf Deiner lokalen Umgebung aber verfügbar sind. Einige (ältere) Plugins brauchen zum Beispiel die ereg Extension.
Christoph M. Becker –Plugins for CMSimple_XH, but not for CMSimple 4+

Tata
Posts: 2790
Joined: Tue May 20, 2008 5:34 am
Location: Slovakia
Contact:

Re: Upgrade to PHP 7

Post by Tata » Fri Feb 10, 2017 11:22 am

Jetzt (nach 2 Stunden) habe ich es noch mal versucht.
Die Hauptdomaine http://cmsimple.sk läuft und hat PHP5.6 eigestellt.
unter "_sub" Folder am Server habe ich PHP7.0.5 eingestellt (Info auf allen Subdomains zeigt PHP7.0.5.
Die http://dddlan.cmsimple.sk (v1.6.9)
http://cmsimplexh169.cmsimple.sk
http://funnytree-2016.cmsimple.sk (v1.6.7) und noch einige scheinen auch gut zu laufen, nur manchmal ist Adminfunktionenaufruf unheimlich langsam.
Die http://cmsimple_xh_plugins.cmsimple.sk läuft auch, aber zeight die DEPRECATED NOTIZEN ohne einzuloggen und dann auch mit mehreren Plugins unter Hi_updatecheck.
CMSimple.sk
It's no shame to ask for an answer if all efforts failed.
But it's awful to ask without any effort to find the answer yourself.

cmb
Posts: 12770
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Upgrade to PHP 7

Post by cmb » Fri Feb 10, 2017 11:54 am

Tata wrote:http://funnytree-2016.cmsimple.sk (v1.6.7) und noch einige scheinen auch gut zu laufen, nur manchmal ist Adminfunktionenaufruf unheimlich langsam.
Das liegt vermutlich am Update-Check, und sollte mit XH 1.6.9 behoben sein.
Tata wrote:Die http://cmsimple_xh_plugins.cmsimple.sk läuft auch, aber zeight die DEPRECATED NOTIZEN ohne einzuloggen und dann auch mit mehreren Plugins unter Hi_updatecheck.
Da ist anscheinend display_errors aktiviert.
Christoph M. Becker –Plugins for CMSimple_XH, but not for CMSimple 4+

Tata
Posts: 2790
Joined: Tue May 20, 2008 5:34 am
Location: Slovakia
Contact:

Re: Upgrade to PHP 7

Post by Tata » Fri Feb 10, 2017 12:05 pm

cmb wrote:
Tata wrote:Die http://cmsimple_xh_plugins.cmsimple.sk läuft auch, aber zeight die DEPRECATED NOTIZEN ohne einzuloggen und dann auch mit mehreren Plugins unter Hi_updatecheck.
Da ist anscheinend display_errors aktiviert.
Naja, alle subdomains liegen unter "_sub" und da ist generell PHP7.0.5 aktiviert. Darum verstehe ich nicht, dass die Notizen auf einigen Seiten da sind, auf anderen nicht.
CMSimple.sk
It's no shame to ask for an answer if all efforts failed.
But it's awful to ask without any effort to find the answer yourself.

lck
Posts: 1306
Joined: Wed Mar 23, 2011 11:43 am
Contact:

Re: Upgrade to PHP 7

Post by lck » Fri Feb 10, 2017 12:36 pm

cmb wrote:
Tata wrote:http://funnytree-2016.cmsimple.sk (v1.6.7) und noch einige scheinen auch gut zu laufen, nur manchmal ist Adminfunktionenaufruf unheimlich langsam.
Das liegt vermutlich am Update-Check, und sollte mit XH 1.6.9 behoben sein.
Mit CMSimple_XH 1.6.7 wurde noch hi_updateckeck 1.3 ausgeliefert, da gab es Probleme. Mit Version 1.4 sollte das Problem erledigt sein.
Last edited by lck on Fri Feb 10, 2017 12:46 pm, edited 1 time in total.
„Bevor du den Pfeil der Wahrheit abschießt, tauche die Spitze in Honig!“   👉 Ludwig's XH-Templates for MultiPage & OnePage

cmb
Posts: 12770
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Upgrade to PHP 7

Post by cmb » Fri Feb 10, 2017 12:43 pm

Tata wrote:Naja, alle subdomains liegen unter "_sub" und da ist generell PHP7.0.5 aktiviert. Darum verstehe ich nicht, dass die Notizen auf einigen Seiten da sind, auf anderen nicht.
Anscheinend verwenden aber die verschiedenen Subdomains unterschiedliche PHP-Konfigurationen. Ein Fix, damit es erst gar nicht zu diesen Deprecated-Warnings kommen kann, liegt übrigens vor.
Christoph M. Becker –Plugins for CMSimple_XH, but not for CMSimple 4+

Tata
Posts: 2790
Joined: Tue May 20, 2008 5:34 am
Location: Slovakia
Contact:

Re: Upgrade to PHP 7

Post by Tata » Fri Feb 10, 2017 1:38 pm

lck wrote:Das liegt vMit CMSimple_XH 1.6.7 wurde noch hi_updateckeck 1.3 ausgeliefert, da gab es Probleme. Mit Version 1.4 sollte das Problem erledigt sein.
Diese Seite läuft problemlos :(
CMSimple.sk
It's no shame to ask for an answer if all efforts failed.
But it's awful to ask without any effort to find the answer yourself.

Tata
Posts: 2790
Joined: Tue May 20, 2008 5:34 am
Location: Slovakia
Contact:

Re: Upgrade to PHP 7

Post by Tata » Fri Feb 10, 2017 1:41 pm

cmb wrote:Anscheinend verwenden aber die verschiedenen Subdomains unterschiedliche PHP-Konfigurationen.
Ich meine, dass solange für "_sub" die selbe einstellung gibt, damit logisch nur eine PHP-Konfiguratzuion, alle "_sub"-Unterseiten sollten gleich laufen.
Last edited by Tata on Fri Feb 10, 2017 2:12 pm, edited 1 time in total.
CMSimple.sk
It's no shame to ask for an answer if all efforts failed.
But it's awful to ask without any effort to find the answer yourself.

Post Reply