Page 1 of 1

probleme installation ? plugin Register

Posted: Tue Oct 10, 2017 8:25 pm
by spiclub
Bonjour,
J'ai préparé en local un site avec _XH 1.7, sur le template Fhs-simple, avec divers pluggins (version actuelle) dont ccalendar_XH_1-2-10, Realblog_XH-3.0beta9 et Register_XH-1.6 (car memberpages_XH_3-6-1 ne fonctionnait pas bien).

Lors de l'installation sur un hebergement OVH existant, le site est inaccessible et j'obtiens une erreur en debug :

Code: Select all

Parse error: syntax error, unexpected T_OBJECT_OPERATOR in /home/spiclub/www/new/plugins/register/index.php on line 55


j'ai upgradé la version PHP d'OVH de 5.6 à 7.1 => pareil.
J'ai retiré le pluggin "register", le site redevient accessible, avec plein d'alertes "deprecated" et bien sur des erreurs sur tous les appels de fonction de "register".

Ce site doit venir remplacer le vieux site de mon association sportive. Je l'ai installé sur un sous-répertoire de l'hebergement OVH : www/new/ pour le faire tester par d'autres membres.
En local sur mon ordi, il fonctionne, avec quelques défauts mineurs pas génants.

Comment régler ce problème ?
Merci
Philippe

Re: probleme installation ? plugin Register

Posted: Tue Oct 10, 2017 8:45 pm
by cmb
Bonjour!

spiclub wrote:Lors de l'installation sur un hebergement OVH existant, le site est inaccessible et j'obtiens une erreur en debug :

Code: Select all

Parse error: syntax error, unexpected T_OBJECT_OPERATOR in /home/spiclub/www/new/plugins/register/index.php on line 55


j'ai upgradé la version PHP d'OVH de 5.6 à 7.1 => pareil.

La syntaxe de la ligne 55 est compatible avec toutes les versions PHP à partir de PHP 5.4.0. Avez-vous vérifié que vous utilisez PHP 5.6 / 7.1? Voir Paramètres → Infos → PHP-Info (Ceci a été traduit via Google translate; en particulier, les noms des éléments de menu peuvent ne pas correspondre à votre version.)

spiclub wrote:avec plein d'alertes "deprecated"

Veuillez lister les messages ici.

spiclub wrote:calendar_XH_1-2-10

Calendar 1.2.10 est très ancien et n'est pas censé être compatible avec PHP 7 ou CMSimple_XH 1.7. Mettez à niveau vers Calendar 1.4.8, ou jetez un coup d'oeil à ma fourchette de Calendar 1.2.10 (aucune date de sortie n'est encore programmée).

Re: probleme installation ? plugin Register

Posted: Wed Oct 11, 2017 1:35 pm
by spiclub
Bonjour, viele danke

J'ai configuré l'hebergement en 7.1, mais un fichier .ovhconfig à la racine du site force la version de php à 5.3 pour le site actuel.
Si je le change, _XH fonctionne mais l'ancien site ne fonctionne pas.
Je vais devoir trouver un autre hébergement.
Actuellement, je teste avec PHP 7.0, register semble OK mais calendar ne fonctionne effectivement pas

Les messages de debug semblent aussi reliés à Calendar. Je vais tester les autres versions comme vous l'indiquez.

Merci
Viele grusse
Philippe

Code: Select all

WARNING: preg_match(): Unknown modifier 'n'
/home/spiclub/www/new/plugins/calendar/index.php:113
NOTICE: Undefined index: memberpages
/home/spiclub/www/new/cmsimple/classes/PluginConfig.php:84
XH-DEPRECATED: Function initvar() is deprecated
/home/spiclub/www/new/plugins/memberpages/index.php:131
XH-DEPRECATED: Function initvar() is deprecated
/home/spiclub/www/new/plugins/memberpages/index.php:136
XH-DEPRECATED: Function initvar() is deprecated
/home/spiclub/www/new/plugins/calendar/admin.php:14
XH-DEPRECATED: Function initvar() is deprecated
/home/spiclub/www/new/plugins/flexslider/admin.php:19
XH-DEPRECATED: Function initvar() is deprecated
/home/spiclub/www/new/plugins/memberpages/admin.php:26
NOTICE: Undefined offset: 2
/home/spiclub/www/new/plugins/calendar/index.php:745
NOTICE: Undefined offset: 1
/home/spiclub/www/new/plugins/calendar/index.php:745
NOTICE: Undefined offset: 4
/home/spiclub/www/new/plugins/calendar/index.php:744
NOTICE: Undefined offset: 2
/home/spiclub/www/new/plugins/calendar/index.php:744
NOTICE: Undefined offset: 1
/home/spiclub/www/new/plugins/calendar/index.php:744
NOTICE: Undefined offset: 2
/home/spiclub/www/new/plugins/calendar/index.php:765
NOTICE: Undefined offset: 1
/home/spiclub/www/new/plugins/calendar/index.php:765

Re: probleme installation ? plugin Register

Posted: Wed Oct 11, 2017 3:13 pm
by cmb
Bonjour!

spiclub wrote:

Code: Select all

NOTICE: Undefined index: memberpages
/home/spiclub/www/new/cmsimple/classes/PluginConfig.php:84

S'il vous plaît essayez ceci: https://github.com/cmsimple-xh/memberpa ... /tag/3.6.5

spiclub wrote:

Code: Select all

XH-DEPRECATED: Function initvar() is deprecated
/home/spiclub/www/new/plugins/flexslider/admin.php:19

S'il vous plaît essayez ceci: https://github.com/cmsimple-xh/flexslid ... /tag/0.5.4

Re: probleme installation ? plugin Register

Posted: Thu Oct 12, 2017 10:59 am
by spiclub
Hallo,
Test hosting : PHP 5.6.31
flexslider/0.5.4 = OK
register = OK => root cause : PHP version.
Merci jusqu'à présent.

pas de succes avec calendar XH-master ou 1.4.8 (pas de back end affiché) - je peux recommencer et continuer les essais (j'ai peut être mal téléchargé les fichiers github).
Calendar 1.2.10 fonctionne presque mieux, mais il affiche des messages en _debug => je préfèrerai installer un calendrier "durable".

Danke

Re: probleme installation ? plugin Register

Posted: Thu Oct 12, 2017 11:42 am
by cmb
Bonjour!

spiclub wrote:pas de succes avec calendar XH-master

Avez-vous renommé le répertoire calendar_xh-master en calendar?

spiclub wrote:je préfèrerai installer un calendrier "durable".

Actuellement, je suis le seul responsable des deux variantes (https://github.com/cmb69/calendar_xh et https://github.com/cmsimple-xh/calendar). Je vais probablement investir plus de temps dans ma propre fourchette. Cependant, je ne peux rien promettre.