Portable_XH

Ein CMSimple Support Forum für deutsch sprechende Nutzer und Entwickler
regedit
Posts: 4
Joined: Thu Mar 26, 2020 8:04 am
Location: Stmk/Ö

Re: Portable_XH

Post by regedit » Wed Aug 12, 2020 1:43 pm

Hallo Leute,
kann es sein das ein Windows-update den localhost-Zugriff von Portable_XH unterbindet?
Bekomme nach einem Win10-Home update mit verschiedenen Browsern seit heute diese oder ähnliche Fehlermeldungen:
"Vergewissern Sie sich, dass die Webadresse https://www.localhost stimmt."
aus http://localhost:8080/ wird im Browser nämlich immer obiges...
Habe jetzt diese Win10-Home: Version 2004 Betriebssystembuild: 19041.450
Gestern, vor dem Update lief alles noch normal.
regedit

lck
Posts: 2088
Joined: Wed Mar 23, 2011 11:43 am
Contact:

Re: Portable_XH

Post by lck » Wed Aug 12, 2020 5:54 pm

regedit wrote:
Wed Aug 12, 2020 1:43 pm
"Vergewissern Sie sich, dass die Webadresse https://www.localhost stimmt."
aus http://localhost:8080/ wird im Browser nämlich immer obiges...
1.) Einen Grund dafür weiß ich jetzt nicht, aber du kannst mal folgende Adressen testen:
Portable_XH/Liesmich.htm wrote:Manche Browser (z.B. Opera 12.16) können aus welchen Gründen auch immer möglicherweise http://localhost:8080/ nicht anzeigen. Sie können das vermutlich aber umgehen, wenn Sie http://[::1]:8080/ oder http://127.0.0.1:8080/ manuell aufrufen.
2.) Öffne die Datei C:\Windows\System32\drivers\etc\hosts mit Notepad++
Steht da am Ende

Code: Select all

# localhost name resolution is handled within DNS itself.
127.0.0.1	localhost
#	::1             localhost
3.) Ist Portable_XH eventuell in der Firewall geblockt?

4.) DNS-Cache leeren
- "Ausführen"-Fenster öffnen, die Tasten [Windows] + [R] drücken.
- Eingeben "cmd" (ohne Anführungszeichen)
- Links oben "Eingabeaufforderung" per Rechtsklick "als Administrator ausführen" auswählen
- Eingeben "ipconfig /flushdns" (ohne Anführungszeichen")

Code: Select all

C:\WINDOWS\system32>ipconfig /flushdns

Windows-IP-Konfiguration

Der DNS-Auflösungscache wurde geleert.

C:\WINDOWS\system32>
„Bevor du den Pfeil der Wahrheit abschießt, tauche die Spitze in Honig!“   👉 Ludwig's XH-Templates for MultiPage & OnePage

cmb
Posts: 13404
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Portable_XH

Post by cmb » Wed Aug 12, 2020 9:22 pm

regedit wrote:
Wed Aug 12, 2020 1:43 pm
"Vergewissern Sie sich, dass die Webadresse https://www.localhost stimmt."
aus http://localhost:8080/ wird im Browser nämlich immer obiges...
Das klingt arg. Auf jeden Fall mal Ludwigs Tipps aus dem vorherigen Post durchprobieren. Und ich würde auch mal nach dem Datum der letzten Änderung von C:\Windows\System32\drivers\etc\hosts schauen; wurde diese Datei beim Update möglicherweise modifiziert?
Christoph M. Becker – Plugins for CMSimple_XH

regedit
Posts: 4
Joined: Thu Mar 26, 2020 8:04 am
Location: Stmk/Ö

Re: Portable_XH

Post by regedit » Thu Aug 13, 2020 10:51 am

Danke für die Tipps, einiges konnte ich schon ausschließen wie z.b. die Hosts-Datei.
Die ist vom März diesen Jahres da ich dort einige Umleitungen eingetragen habe.
Browser habe ich verschiedene probiert, alle lenken nach 2-3 Sekunden eben auf "https://www.localhost/" um brechen dann mit einer Fehlermeldung ab. Webseite nicht gefunden, was logisch klingt mit "https" am Anfang. Ich habe aber noch nicht herausgefunden warum umgelenkt wird. Firewall hab ich, und auch ausgeschalten getestet. Das gilt übrigens für Portable_XH 2.0, 1.4 und 1.3
Ich habe jedenfalls noch immer das gleiche Problem, bin aber draufgekommen das ich mit:
"http://[::1]:8080/" (mit der ipV6 Adresse) Portable_XH zum laufen bringe.
ein "http://127.0.0.1:8080/" in der Adresszeile wir NICHT umgelenkt ergibt aber ebenfalls angesprochenen Fehler Webseite nicht erreichbar.
ein Ping auf "localhost" ist ok und gibt "Antwort von ::1: Zeit <1ms" aus
ein Ping auf "127.0.0.1" ist auch ok und gibt "Antwort von 127.0.0.1: Bytes=32 Zeit<1ms TTL=128" aus
ein Ping auf ::1 ist ebenfalls ok und gibt "Antwort von ::1: Zeit <1ms" aus
Es sieht so aus das localhost nur im ipV6 Bereich aufrufbar ist.
wie gesagt habe nichts am System geändert, bis auf das Win10-update, sehr merkwürdig das ganze...
trotzdem erstmal Danke für die Tipps, wenn mich Goo... weiterbringt werde ich das hier kund tun.
Da ich nichts anderes als Portable_XH über einen lokalen Server nutze dachte ich frag ich mal hier nach obwohl es ja ein Windows-Problem zu sein scheint.
Nachtrag: Habe als workaround in der Portable_XH.bat
"start http://localhost:8080/" auf "start http://[::1]:8080/"
geändert, das läuft soweit. Suche aber weiter nach der Ursache...

lck
Posts: 2088
Joined: Wed Mar 23, 2011 11:43 am
Contact:

Re: Portable_XH

Post by lck » Thu Aug 13, 2020 1:53 pm

regedit wrote:
Thu Aug 13, 2020 10:51 am
Die ist vom März diesen Jahres da ich dort einige Umleitungen eingetragen habe.
Und da ist keine Umleitung auf https://www.localhost/ drin, ok.
regedit wrote:
Thu Aug 13, 2020 10:51 am
Browser habe ich verschiedene probiert, alle lenken nach 2-3 Sekunden eben auf "https://www.localhost/" um brechen dann mit einer Fehlermeldung ab.
Kann mir zwar nicht vorstellen, dass alle Browser eine Umleitung drin haben, aber einen Versuch ist's Wert.
https://stackoverflow.com/questions/252 ... 3#28586593
https://kimsereyblog.blogspot.com/2018/ ... https.html
„Bevor du den Pfeil der Wahrheit abschießt, tauche die Spitze in Honig!“   👉 Ludwig's XH-Templates for MultiPage & OnePage

Post Reply