Problem mit Bildpositionierung

Ein CMSimple Support Forum für deutsch sprechende Nutzer und Entwickler
lck
Posts: 2279
Joined: Wed Mar 23, 2011 11:43 am
Contact:

Re: Problem mit Bildpositionierung

Post by lck » Tue Dec 01, 2020 6:22 pm

Eliquas wrote:
Tue Dec 01, 2020 6:10 pm
Jetzt sind die Flächen auf der Startseite. Nur das Logo und das Foto, die auch auf die Startseite sollen, sind jetzt auf die erste Seite "gerutscht".
Du hast das stylesheet.css noch nicht angepasst, wie oben beschrieben. Wenn doch, dann müsstest du mal xhstyles.css unter ./assets/css/ löschen und die Seite neu laden
„Bevor du den Pfeil der Wahrheit abschießt, tauche die Spitze in Honig!“   👉 Ludwig's XH-Templates for MultiPage & OnePage

Eliquas
Posts: 137
Joined: Mon Dec 13, 2010 10:23 am

Re: Problem mit Bildpositionierung

Post by Eliquas » Tue Dec 01, 2020 6:29 pm

O.k. werde übermorgen das stylesheet anpassen. Vorher klappt es nicht mehr.

Vielen Dank für Deine Hilfe

Eliquas
CMSimple_XH 1.7.1

Advancedform 1.1
Fa 1.2
Filebrowser for CMSimple_XH 1.7.1
Hi_updatecheck 1.4
Jquery 1.6.4
Meta_tags for CMSimple_XH 1.7.1
Pagemanager 3.1
Page_params for CMSimple_XH 1.7.1
Tinymce4

PHP 5.6.32

Eliquas
Posts: 137
Joined: Mon Dec 13, 2010 10:23 am

Re: Problem mit Bildpositionierung

Post by Eliquas » Sun Dec 06, 2020 6:00 pm

Hallo Ick.

Danke bisher für Deine Hilfe. Es gibt aber noch weitere Fragen.

1. Die Positionierung der Boxen klappt nicht. Egal, was ich unter "left", "right" und "top" eingebe.

2. Die Höhe der Boxen läßt sich auch nicht ändern. Egal, was ich unter "height" eintrage.

3. Der Text für Box Mitte steht zwar an der richtigen Position, nur die Box(orange) nicht.

Was mache ich falsch?

Danke im voraus

Eliquas
CMSimple_XH 1.7.1

Advancedform 1.1
Fa 1.2
Filebrowser for CMSimple_XH 1.7.1
Hi_updatecheck 1.4
Jquery 1.6.4
Meta_tags for CMSimple_XH 1.7.1
Pagemanager 3.1
Page_params for CMSimple_XH 1.7.1
Tinymce4

PHP 5.6.32

lck
Posts: 2279
Joined: Wed Mar 23, 2011 11:43 am
Contact:

Re: Problem mit Bildpositionierung

Post by lck » Sun Dec 06, 2020 6:36 pm

Eliquas wrote:
Sun Dec 06, 2020 6:00 pm
1. Die Positionierung der Boxen klappt nicht. Egal, was ich unter "left", "right" und "top" eingebe.

2. Die Höhe der Boxen läßt sich auch nicht ändern. Egal, was ich unter "height" eintrage.
Hm, gerade mal auf deiner Seite mit den Browsertools geändert, da ändert sich schon etwas.
Bei "left", "right" und "top" die Prozent-Angaben ändern 10%, 50% ...

Aber, das beste hierfür wäre natürlich ein Grid-System oder zumindest eine Anordnung per display: table oder inline-block. Ansonsten sieht das auf kleineren Bildschirmen gestapelt aus, ist nicht responsive.
„Bevor du den Pfeil der Wahrheit abschießt, tauche die Spitze in Honig!“   👉 Ludwig's XH-Templates for MultiPage & OnePage

Eliquas
Posts: 137
Joined: Mon Dec 13, 2010 10:23 am

Re: Problem mit Bildpositionierung

Post by Eliquas » Mon Dec 07, 2020 6:20 am

Hallo Ick.

Du hast recht. Wennich mit dem Inspector unter Webentwickler arbeite, kann ich alles so ändern, wie ich will.

Viele Grüße

Eliquas
CMSimple_XH 1.7.1

Advancedform 1.1
Fa 1.2
Filebrowser for CMSimple_XH 1.7.1
Hi_updatecheck 1.4
Jquery 1.6.4
Meta_tags for CMSimple_XH 1.7.1
Pagemanager 3.1
Page_params for CMSimple_XH 1.7.1
Tinymce4

PHP 5.6.32

olape
Posts: 1646
Joined: Fri Mar 13, 2015 8:47 am
Contact:

Re: Problem mit Bildpositionierung

Post by olape » Mon Dec 07, 2020 6:36 am

Eliquas wrote:
Mon Dec 07, 2020 6:20 am
Wieso werden die Änderungen nicht übernommen?

Ich habe die stylesheet.css überschrieben, alternativ die alte umbenannt und die geänderte css komplett neu hoch geladen. Es bleibt immer alles, wie es vorher war. Ein neues Browserfenster geöffnen und die Seite darin geladen - auch hier keine Änderung der alten Daten.
Browser-Cache?

Eliquas
Posts: 137
Joined: Mon Dec 13, 2010 10:23 am

Re: Problem mit Bildpositionierung

Post by Eliquas » Mon Dec 07, 2020 7:01 am

Hallo Ick.

Wo kann ich dieHintergrundfarben der Seiten ändern. Ich denke, im admintemplate.css. Aber da finde ich nur die Farbangabe für die Titelseite. Wo sind die Farben für die restlichen Seiten zu finden?
CMSimple_XH 1.7.1

Advancedform 1.1
Fa 1.2
Filebrowser for CMSimple_XH 1.7.1
Hi_updatecheck 1.4
Jquery 1.6.4
Meta_tags for CMSimple_XH 1.7.1
Pagemanager 3.1
Page_params for CMSimple_XH 1.7.1
Tinymce4

PHP 5.6.32

lck
Posts: 2279
Joined: Wed Mar 23, 2011 11:43 am
Contact:

Re: Problem mit Bildpositionierung

Post by lck » Mon Dec 07, 2020 10:12 am

stylesheet.css, ab Zeile 381 im Original

Code: Select all

div.onepage_page:nth-child(odd) {
	background-color: #CDE8FF;
}
div.onepage_page:nth-child(even) {
	background-color: #E3F2FF;
}
„Bevor du den Pfeil der Wahrheit abschießt, tauche die Spitze in Honig!“   👉 Ludwig's XH-Templates for MultiPage & OnePage

Eliquas
Posts: 137
Joined: Mon Dec 13, 2010 10:23 am

Re: Problem mit Bildpositionierung

Post by Eliquas » Mon Dec 14, 2020 10:05 am

Hallo Ick.

Da bin ich wieder. Bin schon ein Stück weiter gekommen, aber es "klemmt" noch ein Wenig. Vielleicht kannst Du mir janoch den einen oder anderenTiippp geben.
Wie Du vorgeschlagen hast, habe ich mich mittlerweile etwas in die Grids "eingelesen" und für die Startseite ein Raster erstellt. Dieses Grid habe ich dann in Template und stylesheet.css eingefügt. Mit dem Ergebnis, dass, wenn ich die Seitebreite verändere, die Teile des Grigs neu sortiert werden und auch für Smartphones eine Darstellung möglich ist. Leider werden jetzt meine zwei Boxen nicht mehr angezeigt.

Das Ergebnis siehst Du hier: http://www.elias-webdesign.de/Flamme_Test

Auf meiner Testseite waren die Boxen zwar vorhanden, aber Bilder und Boxen"schoben" sich übereinander. Siehe hier"http://www.elias-webdesign.de/Test/Flam ... icher.html

Ich finde den Fehler nicht. Kannst Du helfen?

Noch eine Frage: Zur Zeit ist der Hintergrund der Startseite dunkelblau. Er soll aber Gelb sein. Wo stelle ich das ein? Die unterseiten konnte ich ändern. Und wieso ist zwischen Der Startseite und der ersten Unterseite ein weißer Balken? Krigt man den noch weg?

Danke für die Unterstützung.
CMSimple_XH 1.7.1

Advancedform 1.1
Fa 1.2
Filebrowser for CMSimple_XH 1.7.1
Hi_updatecheck 1.4
Jquery 1.6.4
Meta_tags for CMSimple_XH 1.7.1
Pagemanager 3.1
Page_params for CMSimple_XH 1.7.1
Tinymce4

PHP 5.6.32

lck
Posts: 2279
Joined: Wed Mar 23, 2011 11:43 am
Contact:

Re: Problem mit Bildpositionierung

Post by lck » Mon Dec 14, 2020 11:37 am

Eliquas wrote:
Mon Dec 14, 2020 10:05 am
Noch eine Frage: Zur Zeit ist der Hintergrund der Startseite dunkelblau. Er soll aber Gelb sein. Wo stelle ich das ein?
In der stylesheet.css unter .tpllck_nav {...}, Zeile 210 im Original CSS.
Eliquas wrote:
Mon Dec 14, 2020 10:05 am
Und wieso ist zwischen Der Startseite und der ersten Unterseite ein weißer Balken?
Hm, ich sehe da keinen weißen Balken.

Tipp
Um die entsprechenden Stellen zu finden, verwende die Entwickler-Tools des Browser. Am einfachsten geht das per Rechtsklick auf die betreffende Stelle und dann auf "Untersuchen" (in Chrome) oder "Element untersuchen" in Firefox. Dann siehst du unter "Elements" bzw. "Inspektor" den dazugehörigen Bereich und rechts die CSS-Styles und in welcher Zeile diese in der stylesheet.css festgelegt sind.
Eliquas wrote:
Mon Dec 14, 2020 10:05 am
Ich finde den Fehler nicht. Kannst Du helfen?
Soll die Startseite so aussehen wie hier, nur mit gelben Hintergrund? Und wie sollte die mobile Ansicht aussehen, können hier bestimmte Boxen wegfallen oder sollen auch hier alle sichtbar sein?
Wenn nicht, kannst du mir das mal grafisch etwas darstellen, dann versuche ich in den nächsten Tagen das Template dementsprechend für dich anzupassen.
„Bevor du den Pfeil der Wahrheit abschießt, tauche die Spitze in Honig!“   👉 Ludwig's XH-Templates for MultiPage & OnePage

Post Reply