Page 4 of 7

Re: XH-Forum

Posted: Tue Nov 06, 2018 11:35 am
by olape
cmb wrote:
Wed Oct 31, 2018 2:10 pm
Zusammenfassend kann man wohl sagen, dass es Probleme mit der Session-ID gibt, und eigentlich existierende Sessions nicht als solche erkannt werden (das Board erzeugt dann immer wieder neue sid=xyz in der URL).
Aktuell 06.11.2018, 12:22 genau wieder das von cmb beschriebene Problem.

Hat denn allinkl eine Aussage dazu?

Re: XH-Forum

Posted: Tue Nov 06, 2018 11:40 am
by Holger
olape wrote:
Tue Nov 06, 2018 11:35 am
Hat denn allinkl eine Aussage dazu?
Noch nicht gefragt. Dummerweise habe ich auch, wegen der DSVGO, das Logging komplett ausgeschaltet :oops: . Das wäre jetzt vermutlich sehr hilfreich gewesen.

Ich hab' jetzt im Board nochmal was umgestellt. Eventuell läuft es jetzt besser...

Re: XH-Forum

Posted: Tue Nov 06, 2018 11:46 am
by olape
Holger wrote:
Tue Nov 06, 2018 11:40 am
Dummerweise habe ich auch, wegen der DSVGO, das Logging komplett ausgeschaltet :oops: . Das wäre jetzt vermutlich sehr hilfreich gewesen.
Verständlich. Man kann aber auch das letzte, oder auch die beiden letzten Oktetts anonymisieren lassen.
Di IP wäre ja für die Fehlerdiagnose nicht wirklich relevant. Solange nicht alle vom gleichen Provider/Einwahlknoten kommen, sollte man das immer noch auseinanderhalten können.
Aber, allinkl hätte die Logs für 7 Tage trotz allem.

Re: XH-Forum

Posted: Tue Nov 06, 2018 11:55 am
by frase
forum.png
Wer sind denn diese CSB...?
Eben gerade geschossen.

Re: XH-Forum

Posted: Tue Nov 06, 2018 12:32 pm
by Holger
frase wrote:
Tue Nov 06, 2018 11:55 am
Wer sind denn diese CSB...?
Meine Kreation ;)

Das sind Besucher in den IP-Bereichen, die für die große Anzahl von Gästen zuständig sind (allesamt chinesische IPs mit einem Mobile-UA). Diese IPs werden jetzt als BOT angesehen. Dadurch bekommen sie nicht mehr die komplette Funktionalität, sehen das Board aber noch. Komplett sperren wollte ich die IPs (vorerst) nicht. Jedenfalls sollten Bots keine Session erzeugen können, was dann die Last des Boards senkt.
Nach meinen Beobachtungen kamen die Login-Probleme in der Tat während / nach den Besuchen dieser IPs. Nach max. 1 Stunde läuft dann der Cron-Job, der die Session-Tabelle bereinigt. Danach ging das Login wieder (wenn ich alles richtig schlussfolgere).
Aber ohne die Logs stochert man halt doch im Dunkeln...

Re: XH-Forum

Posted: Tue Nov 06, 2018 1:37 pm
by cmb
Holger wrote:
Tue Nov 06, 2018 12:32 pm
Das sind Besucher in den IP-Bereichen, die für die große Anzahl von Gästen zuständig sind (allesamt chinesische IPs mit einem Mobile-UA).
Aha!

Re: XH-Forum

Posted: Tue Nov 06, 2018 2:29 pm
by Holger
Okay, die CSB* - User sind noch da und verschwenden Ressourcen :roll: . Da sie nun als Bots erkannt werden, können Sie nun Aktionen wie Register oder Login (hoffentlich) nicht finden bzw. aufrufen.
Die Anzahl der Online-User ist jetzt drastisch geringer, weil dem Bot-Zugang ganze IP-Bereiche zugeordnet sind (zur Zeit xxx.xxx.).
Jetzt habe ich mich über drei Stunden lang ständig mit Erfolg an- und abmelden können. Das war die letzten Tage nicht so.

Wenn wieder Probleme kommen: bitte melden!

Re: XH-Forum

Posted: Tue Nov 06, 2018 2:40 pm
by frase
Das können wir nur in den nächsten Tagen feststellen.
Aber: Erstmal vielen Dank für deine Mühe und Zeit!

Re: XH-Forum

Posted: Tue Nov 06, 2018 4:21 pm
by cmb
frase wrote:
Tue Nov 06, 2018 2:40 pm
Aber: Erstmal vielen Dank für deine Mühe und Zeit!
+1

Re: XH-Forum

Posted: Wed Nov 07, 2018 8:55 am
by Holger
So, die lieben CSB's sind wieder da :roll: .
Bisher aber keine Probleme beim Login etc.