Letzte Bearbeitung

Ein CMSimple Support Forum für deutsch sprechende Nutzer und Entwickler
Post Reply
mhz
Posts: 546
Joined: Tue Jun 25, 2013 8:46 pm
Location: Heusenstamm, Hessen
Contact:

Letzte Bearbeitung

Post by mhz » Tue Jan 16, 2018 8:56 pm

Hallo zusammen,
was muss ich ändern, dass vor dem Datum bei "Bearbeitungsdatum anzeigen - unten", also bei aktiviertem "Letzte Bearbeitung" ein nur ca. 5 cm langer Strich erscheint, ähnlich dem Strich in Büchern vor Fußnoten?
Danke für eure Ideen.
Michael
Michael Zajusch (mhz)-- Mein Tutorial für CMSimple_XH. Früher

Holger
Site Admin
Posts: 2942
Joined: Mon May 19, 2008 7:10 pm
Location: Hessen, Germany
Contact:

Re: Letzte Bearbeitung

Post by Holger » Tue Jan 16, 2018 10:28 pm

Hi,

du meinst das Datum der letzten Bearbeitung einer Seite? Dann vielleicht so:

Code: Select all

#pp_last_update::before {
	border-top: 1px solid #000;
	display: block;
	position: relative;
	top: -5px;
	width: 50%;
	content: "";
}
Width und eventuell margin noch anpassen.

mhz
Posts: 546
Joined: Tue Jun 25, 2013 8:46 pm
Location: Heusenstamm, Hessen
Contact:

Re: Letzte Bearbeitung

Post by mhz » Tue Jan 16, 2018 10:45 pm

Danke, Holger!
Der Code ist in die CSS-Datei des Templates einzutragen.
Bei mir passt die width: 25%; ganz gut.
Gruß
Michael
Michael Zajusch (mhz)-- Mein Tutorial für CMSimple_XH. Früher

Holger
Site Admin
Posts: 2942
Joined: Mon May 19, 2008 7:10 pm
Location: Hessen, Germany
Contact:

Re: Letzte Bearbeitung

Post by Holger » Tue Jan 16, 2018 11:15 pm

Prima :)

Berni
Posts: 50
Joined: Wed Feb 12, 2014 4:38 pm
Contact:

Re: Letzte Bearbeitung

Post by Berni » Wed Jan 02, 2019 5:49 pm

Ich habe bei der Datums-Darstellung auf einigen Seiten auf einmal ein Problem.

Obwohl ich nichts geändert habe, wird bei einigen Seiten das Datum in English
und "falsch" formatiert ausgebeben.

Also nicht wie ich es möchte:
Letzte Änderung: 30.12.2018, 17:11

Sondern:
Letzte Änderung: December 30, 2018 at 05:11 PM

Die Sprachdateien sind korrekt eingestellt, keine Unterschiede.
Bei beiden Installationen verwenden die gleiche php.ini
PHP läuft mit 7.0.32

Ich bin irritiert - hat jemand von Euch noch einen Ansatz?

lck
Posts: 1544
Joined: Wed Mar 23, 2011 11:43 am
Contact:

Re: Letzte Bearbeitung

Post by lck » Wed Jan 02, 2019 6:17 pm

Berni wrote:
Wed Jan 02, 2019 5:49 pm
Die Sprachdateien sind korrekt eingestellt, keine Unterschiede.
Bei beiden Installationen verwenden die gleiche php.ini
PHP läuft mit 7.0.32
PHP könnte die Ursache sein. Schau mal hier viewtopic.php?t=13246&start=10#p64437
Infoseite zu den Zeitzonen http://www.php.net/manual/de/timezones.europe.php
„Bevor du den Pfeil der Wahrheit abschießt, tauche die Spitze in Honig!“   👉 Ludwig's XH-Templates for MultiPage & OnePage

olape
Posts: 836
Joined: Fri Mar 13, 2015 8:47 am
Contact:

Re: Letzte Bearbeitung

Post by olape » Wed Jan 02, 2019 6:33 pm

Berni wrote:
Wed Jan 02, 2019 5:49 pm
Ich habe bei der Datums-Darstellung auf einigen Seiten auf einmal ein Problem.

Obwohl ich nichts geändert habe, wird bei einigen Seiten das Datum in English
und "falsch" formatiert ausgebeben.

Also nicht wie ich es möchte:
Letzte Änderung: 30.12.2018, 17:11

Sondern:
Letzte Änderung: December 30, 2018 at 05:11 PM

Die Sprachdateien sind korrekt eingestellt, keine Unterschiede.
Bei beiden Installationen verwenden die gleiche php.ini
PHP läuft mit 7.0.32

Ich bin irritiert - hat jemand von Euch noch einen Ansatz?
Ich habe da nicht wirklich eine Idee, wenn es wirklich der gleiche Server ist (das habe ich nun nicht geprüft) und die entsprechenden Einstellungen auch identisch sind.
Ich habe nur https://barleber-see.de gefunden, wo es entsprechend deinem Wunsch angezeigt wird.
http://bernutz.net, https://kajen-montagen.de, http://www.bbs-nema.de passen nicht.
Vielleicht schaust du doch nochmal in die Sprachdateien! —> Locale: de_DE und Lastupdate -> Dateformat:

Berni
Posts: 50
Joined: Wed Feb 12, 2014 4:38 pm
Contact:

Re: Letzte Bearbeitung

Post by Berni » Wed Jan 02, 2019 7:45 pm

Ich glaube ich habe den Verursacher!
Die PHP.ini waren doch nicht 100% gleich.

Bei den "fehlerhaften" Anzeigen war die
php Erweiterung extension = "intl.so" aktiviert.

Jetzt meckert meine Nextcloud zwar wieder, denn die braucht die Erweiterung angeblich,
aber das Datum in meinen Projekten schaut erst einmal wieder korrekt aus.

cmb
Posts: 13169
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Letzte Bearbeitung

Post by cmb » Wed Jan 02, 2019 7:56 pm

Siehe https://wiki.cmsimple-xh.org/doku.php/s ... ate_format.

Also ext/intl wieder aktivieren (immer gut, wenn diese verfügbar ist), und in der Sprachdatei (Locale → All) das gewünschte Locale eintragen, also de_DE. Und in der Konfiguration (Format → Date) das kurze Format (short) wählen.
Christoph M. Becker – Plugins for CMSimple_XH

Berni
Posts: 50
Joined: Wed Feb 12, 2014 4:38 pm
Contact:

Re: Letzte Bearbeitung

Post by Berni » Wed Jan 02, 2019 8:20 pm

cmb wrote:
Wed Jan 02, 2019 7:56 pm
Siehe https://wiki.cmsimple-xh.org/doku.php/s ... ate_format.

Also ext/intl wieder aktivieren (immer gut, wenn diese verfügbar ist), und in der Sprachdatei (Locale → All) das gewünschte Locale eintragen, also de_DE. Und in der Konfiguration (Format → Date) das kurze Format (short) wählen.
SUUPER - Danke!
Jetzt kann das Jahr 2019 kommen :)

Post Reply