Warning: The type attribute is unnecessary for JavaScript resources

Ein CMSimple Support Forum für deutsch sprechende Nutzer und Entwickler
Post Reply
lck
Posts: 1254
Joined: Wed Mar 23, 2011 11:43 am
Contact:

Warning: The type attribute is unnecessary for JavaScript resources

Post by lck » Fri Jan 05, 2018 7:37 pm

Seit Kurzem moniert der W3 Html Checker das type="text/javascript" im script-Tag. Da sollten die Plugin- und Template-Entwickler in Zukunft ein Auge darauf haben. Nötig ist es anscheinend schon einige Jahre nicht mehr (es wurde hier im Forum auch schon mal angesprochen).
„Bevor du den Pfeil der Wahrheit abschießt, tauche die Spitze in Honig!“      XH-Templates for MultiPage & OnePage

olape
Posts: 578
Joined: Fri Mar 13, 2015 8:47 am
Contact:

Re: Warning: The type attribute is unnecessary for JavaScript resources

Post by olape » Fri Jan 05, 2018 9:24 pm

So lange Templates nicht zwingend html5 sein müssen, müsste es theoretisch erhalten bleiben.
Denn nur bei 5 kann man es weglassen. (Glaube ich)

Bleibt die Frage, lassen, so lange es nur Warnungen sind?
Oder weglassen und alle zwingen auf html5 umzustellen?

cmb
Posts: 12663
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Warning: The type attribute is unnecessary for JavaScript resources

Post by cmb » Sat Jan 06, 2018 11:15 am

lck wrote:Seit Kurzem moniert der W3 Html Checker das type="text/javascript" im script-Tag.
Siehe https://github.com/cmsimple-xh/cmsimple-xh/issues/351.
olape wrote:So lange Templates nicht zwingend html5 sein müssen, müsste es theoretisch erhalten bleiben.
Denn nur bei 5 kann man es weglassen. (Glaube ich)
Da gilt es zu beachten, dass für Browser irrelevant ist, welcher Doctype angegeben wird – entscheidend ist nur, ob der Doctype als gültig anerkannt wird. Welcher Doctype angegeben wird, ist also nur für Validatoren und andere Tools relevant. Und auch wenn der Doctype im Template angegeben wird, so scheren sich der Core und Plugins nicht mehr wirklich darum, und man muss davon ausgehen, dass in Zukunft immer mehr HTML5 Features verwendet werden, so dass der HTML5 Doctype im Template immer wichtiger werden wird, zumindest wenn man die Site validieren lassen möchte.

Daher finde ich, dass wir Templates, die noch einen HTML 4 oder gar XHTML Doctype verwenden (oder überhaupt keinen), ignorieren können.
Christoph M. Becker –Plugins for CMSimple_XH, but not for CMSimple 4+

richukunst
Posts: 48
Joined: Tue Feb 12, 2013 3:00 pm
Location: Schweiz / Steffisburg
Contact:

Warnung: Das type-Attribut ist für JavaScript-Ressourcen nicht erforderlich.

Post by richukunst » Sat Jan 20, 2018 9:42 am

Seit einiger Zeit gibt der Nu Html Checker folgende Fehler an.
type_attribute.jpg
Meine Templates habe ich korrigiert.
<script src="<?php echo $pth['folder']['template']?>js/scripts.min.js"></script>

Die zwei Fehler in plugins/jquery werden jedoch noch angezeigt. Habe ich den Fehler korrekt geändert oder habe ich negative Folgen nicht berücksichtigt?
Habe in den /plugins/jquery die Datei jquery.inc.php Folgendes geändert.
Zeile 40 Original
$js = '<script type="text/javascript" src="' . $path . '"></script>';
Neu
$js = '<script src="' . $path . '"></script>';
Zeile 44 Original
$js .= "\n" . '<script type="text/javascript" src="' . $migrate . '"></script>';
Neu
$js .= "\n" . '<script src="' . $migrate . '"></script>';
You do not have the required permissions to view the files attached to this post.
Last edited by cmb on Sat Jan 20, 2018 12:29 pm, edited 1 time in total.
Reason: Aus eigenem Thread hierher verschoben
Webdesign, Templates, Kunst
richukunst
Richard Kircher
http://www.richukunst.ch

cmb
Posts: 12663
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Warning: The type attribute is unnecessary for JavaScript resources

Post by cmb » Sat Jan 20, 2018 12:31 pm

richukunst wrote:
Sat Jan 20, 2018 9:42 am
Die zwei Fehler in plugins/jquery werden jedoch noch angezeigt. Habe ich den Fehler korrekt geändert oder habe ich negative Folgen nicht berücksichtigt?
Sieht richtig aus.
Christoph M. Becker –Plugins for CMSimple_XH, but not for CMSimple 4+

olape
Posts: 578
Joined: Fri Mar 13, 2015 8:47 am
Contact:

Re: Warning: The type attribute is unnecessary for JavaScript resources

Post by olape » Mon Feb 26, 2018 4:57 pm

richukunst wrote:
Sat Jan 20, 2018 9:42 am
Zeile 40 Original
$js = '<script type="text/javascript" src="' . $path . '"></script>';
Neu
$js = '<script src="' . $path . '"></script>';
Zeile 44 Original
$js .= "\n" . '<script type="text/javascript" src="' . $migrate . '"></script>';
Neu
$js .= "\n" . '<script src="' . $migrate . '"></script>';
in Zeile 67 und 104 gibt es noch mehr davon, wenn auch nicht wirklich relevant für den normalen Anwendungsfall.

Post Reply