Page 1 of 6

fhs-op2 mit CMSimple_XH 1.7

Posted: Fri Jul 21, 2017 8:11 am
by graf_ikea
Hallo, habe das gerade mal getestet und es kommt diese Meldung

Fatal error: Call to undefined function onepage_toc() in /mnt/web208/d0/35/51565135/htdocs/gsp-170/templates/fhs-op2/template.htm on line 95

Kann man da was machen das es funktioniert ?

Danke ...

Re: fhs-op2 mit CMSimple_XH 1.7

Posted: Fri Jul 21, 2017 8:32 am
by frase
Zunächst mal, es hat hier schon einige Rückmeldungen zu diesem Template gegeben, in denen das Zusammenspiel mit XH 1.7 als problemlos gemeldet wurde.

Deine Fehlermeldung für function onepage_toc() in Zeile 95 deutet darauf hin, dass du schon einige Veränderungen am Template vorgenommen hast.
Oder täusche ich mich da?

Hast du die Möglichkeit, das Template nochmal im Originalzustand ohne Veränderungen unter 1.7 zu testen?
Kommt dann auch der Error?

Re: fhs-op2 mit CMSimple_XH 1.7

Posted: Fri Jul 21, 2017 8:58 am
by cmb
graf_ikea wrote:Fatal error: Call to undefined function onepage_toc() in /mnt/web208/d0/35/51565135/htdocs/gsp-170/templates/fhs-op2/template.htm on line 95

Ist Onepage_XH installiert?

Re: fhs-op2 mit CMSimple_XH 1.7

Posted: Fri Jul 21, 2017 9:03 am
by frase
Ich habe jetzt (endlich mal) fhs-op2 mit XH 1.7 selbst und persönlich getestet ;-)

Also: Unter 1.69 allles wie im Download beschrieben installiert. Läuft.
Dann mit Exchange den Content exportiert.

Eine neue Installation 1.7 angelegt.
Dort alle Dateien und das Onepage-Plugin aus dem Download hineinkopiert.
jQuery auf autoload.
content.xml aus der 1.69 rüberkopiert.
Exchange in 1.7 installiert.
Content importiert.
Template auf "fhs-op2".
Läuft.

Bist du ebenso vorgegangen?

Re: fhs-op2 mit CMSimple_XH 1.7

Posted: Fri Jul 21, 2017 11:49 am
by graf_ikea
Danke für die Hilfe, ich hatte natürlich ein bestehendes, verändertes Template geladen.

Habe nun eine neue 170 Version hochgeladen und das fhs-op2 dazu gemacht und es Funktioniert.

Danke ...

Re: fhs-op2 mit CMSimple_XH 1.7

Posted: Sat Sep 02, 2017 8:08 am
by johnjdoe
Ich starte quasi bei Null mit einer frischen CMSimple_XH-Installation und dem fhs-op2 aus dem Download.

Anscheinend sieht es so aus, als sei die im ZIP-File enthaltene Beispieldatei "content.htm" für < 1.7.

Wäre es vielleicht möglich, auch eine Beispieldatei für >= 1.7 dem Download beizulegen? Das wäre fein und würde mir und allen Nachfolgern, die mit dem Template und der neuesten Version des CMS starten möchten, einiges an Arbeit und Einstiegshürden nehmen.

Dank dir im Voraus! :-)

Re: fhs-op2 mit CMSimple_XH 1.7

Posted: Sat Sep 02, 2017 9:21 am
by frase
johnjdoe wrote:Anscheinend sieht es so aus, als sei die im ZIP-File enthaltene Beispieldatei "content.htm" für < 1.7.

Da hast du völlig recht. Zitat:
„fhs-op2“ ist ein Template für CMSimple_XH (Version 1.6.7).

Zwei Posts über deinem habe ich beschrieben, wie das mit dem Übertragen zu XH 1.7 geht.
Vorläufig werde ich das alles so lassen - bis ich mal Zeit finde, das gesamte Template zu überarbeiten und zu aktualisieren.
Nicht umsonst habe ich es unter dem Titel "For Nerds" veröffentlicht ;-)

Re: fhs-op2 mit CMSimple_XH 1.7

Posted: Sat Sep 02, 2017 9:33 am
by johnjdoe
frase wrote:Zwei Posts über deinem habe ich beschrieben, wie das mit dem Übertragen zu XH 1.7 geht.


Vielen Dank, das hatte ich gesehen.

frase wrote:Vorläufig werde ich das alles so lassen - bis ich mal Zeit finde, das gesamte Template zu überarbeiten und zu aktualisieren.
Nicht umsonst habe ich es unter dem Titel "For Nerds" veröffentlicht ;-)


Was genau würdest du denn (vom Content mal abgesehen) überarbeiten bzw. was gäbe es zu aktualisieren?

Re: fhs-op2 mit CMSimple_XH 1.7

Posted: Sat Sep 02, 2017 11:39 am
by frase
johnjdoe wrote:Was genau würdest du denn (vom Content mal abgesehen) überarbeiten bzw. was gäbe es zu aktualisieren?

Wenn ich das jetzt schon wüsste ... ;-)

Fakt ist, dass das Template unter heftigsten Diskussionen entstanden ist, mit ständigen Tipps und Änderungen. Also mit Sicherheit mindestens etwas chaotisch. Dazu kommt, dass ich herzlich wenig von PHP verstehe und alles mehr oder weniger "nach Bauchgefühl" gemacht habe.
Da gibt es bestimmt Verbesserungsmöglichkeiten.
(Tiny4 ist extra, Bootstrap ist extra, ...onepage.js ist extra ...)

Re: fhs-op2 mit CMSimple_XH 1.7

Posted: Sat Sep 02, 2017 7:40 pm
by Der Zwerch
Hallo zusammen,
Ich nutze dieses Paket mittlerweile bei 5 Homepages. Es läuft problemlos.
Ob nun alle Plugins laufen, kann ich nicht sagen. Es ist aber die Wucht in Tüten :mrgreen: