Plugin-Kompatibilität zu CMSimple_XH 1.7

Ein CMSimple Support Forum für deutsch sprechende Nutzer und Entwickler
Hartmut
Posts: 507
Joined: Sat Nov 05, 2011 6:13 pm
Location: Butzbach, Deutschland
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Post by Hartmut » Sat Dec 23, 2017 8:07 pm

Test Plugin Handheld Version: 1.0 mit dem XH 1.7 Workaround

Getestet lokal unter
Xampp
PHP-Version 7.1.1
CMSimple_XH 1.7.1
Template fhs-simple

Plugin in der Sytem-Info sichtbar? => Ja, Handheld 1.0
Plugin im Admin-Menü sichtbar? => Ja
Plugin im Admin-Menü aufrufbar? => Ja
Plugin Stylesheet / Konfiguration / Sprache änderbar und speicherbar? => Ja
Plugin Aufruf auf der Seite: Nicht getestet
Plugin Aufruf im Template: Nicht getestet

Xampp-Fehlermeldungen: Nein
Debug-Meldung: Nein

Ergebnis:
CMSimple_XH 1.6 Kompatibilität: Ja
CMSimple_XH 1.7 Kompatibilität: Nein* (Ja mit dem XH 1.7 Workaround, aber noch keine Plugin Version mit dem Bugfix vorhanden.)
PHP 7.0 Kompatibilität: Ja
PHP 7.1 Kompatibilität: Ja
Weitere Anmerkungen:
Die original Datei admin.php (0 KB) der Plugin Version wurde durch eine minimalistische admin.php (1,26 KB) ersetzt.

Hartmut
Posts: 507
Joined: Sat Nov 05, 2011 6:13 pm
Location: Butzbach, Deutschland
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Post by Hartmut » Sat Dec 23, 2017 8:18 pm

Test Plugin Handheld Version: 1.0 mit dem XH 1.7 Workaround

Getestet lokal unter
Xampp
PHP-Version 7.1.1
CMSimple_XH 1.7.1
Template fhs-simple

Plugin in der Sytem-Info sichtbar? => Ja, Handheld 1.0
Plugin im Admin-Menü sichtbar? => Ja
Plugin im Admin-Menü aufrufbar? => Ja
Plugin Stylesheet / Konfiguration / Sprache änderbar und speicherbar? => Ja
Plugin Aufruf auf der Seite: Nicht getestet
Plugin Aufruf im Template: Nicht getestet

Xampp-Fehlermeldungen: Nein
Debug-Meldung: Nein

Ergebnis:
CMSimple_XH 1.6 Kompatibilität: Ja
CMSimple_XH 1.7 Kompatibilität: Nein* (Ja mit dem XH 1.7 Workaround, aber noch keine Plugin Version mit dem Bugfix vorhanden.)
PHP 7.0 Kompatibilität: Ja
PHP 7.1 Kompatibilität: Ja
Weitere Anmerkungen:
Die original Datei admin.php (0 KB) der Plugin Version wurde durch eine minimalistische admin.php (1,26 KB) ersetzt.
Eine korrigierte (gefixte) Version vom Monorder Plugin mit einem funktionierenden Workaround für XH 1.7 ist im Downloadbereich verfügbar.

Michael_G
Posts: 57
Joined: Thu Feb 18, 2016 11:01 pm

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Post by Michael_G » Mon Dec 25, 2017 1:11 am

Hallo allerseits,

bevor noch jemand wie ich stundenlang den Fehler sucht, warum CMSimple_XH 1.7.2 nicht zum Laufen zu bringen ist (Update-Version):
Sitemapper funktioniert (bei mir) auch in der neuesten Beta-Version nicht.

Dummerweise habe ich nicht zuerst alle Plugins deaktiviert und nach und nach wieder aktiviert.
Als ich nach Stunden eine Neuinstallation versuchte und dieser nach Erfolg meine Plugins hinzufügte, war die Präsenz schlagartig wieder offline (Fehler 500).
Habe mich erinnert, dass Du, Christoph hier erwähnt hattest, dass CMSimple seit 1.7 nur mit dem neuesten Sitemapper funktioniert (ging bei mir auch noch nit der älteren Version) und deshalb zuerst das Sitemapper-Plugin gelöscht.
Seite neu geladen und schon war sie wieder online.

Nur fehlt nun der Sitemapper. Wann ist mit Update zu rechnen?
Sitemapper_XH-3.0beta1.zip von Deiner Website habe ich, die bringt meine Website offline. :(

Aber ich möchte nicht drängen, es ist Weihnachten!
Daher wünsche ich allen hier im Forum erstmal besinnliche Feiertage!
Ciao,
Michael

Hartmut
Posts: 507
Joined: Sat Nov 05, 2011 6:13 pm
Location: Butzbach, Deutschland
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Post by Hartmut » Mon Dec 25, 2017 7:03 am

Hallo Michael,

ich konnte das Problem unter Xampp nachstellen und hier kommen noch ein paar weiterführende informationen.

Getestet lokal unter
Xampp
PHP-Version 7.1.1
CMSimple_XH 1.7.2
Sitemapper 3.0beta1
Template fhs-simple

Ist das Plugin Sitemapper in der CMSimple_XH Installation vorhanden, erhalte ich ohne den Plugin Aufruf (<?php sitemapper();?>) im Template, folgenden Inhalt beim Aufruf von http://127.0.0.1/?sitemapper_index angezeigt:

Code: Select all

<!-- Sitemapper_XH: sitemap index -->
<sitemapindex xsi:schemaLocation="http://www.sitemaps.org/schemas/sitemap/0.9 http://www.sitemaps.org/schemas/sitemap/0.9/siteindex.xsd">
	<sitemap>
		<loc>http://127.0.0.1/?sitemapper_sitemap</loc>
		<lastmod>2017-12-24T21:12:02Z</lastmod>
	</sitemap>
</sitemapindex>
Wenn ich mich (bezogen auf eine frühere Sitemapper Version) recht entsinne, sollten hier auch noch die einzelnen Seiten mit einer Priorität und Besuchszyklus aufgelistet werden, was allerdings nicht gemacht wird.
Meldungen im Debug-Modus und im PHP Logfile erscheinen bei dem oben aufgeführten Fall bei mir nicht.

Wird im Template der Plugin Aufruf (<?php sitemapper();?>) hinzugefügt, ist im Browserfenster eine weiße Seite mit folgenden Meldungen zu sehen:

Code: Select all

Uncaught Error: Call to undefined function sitemapper() in C:\xampp\htdocs\templates\fhs-simple\template.htm:2
Stack trace:
#0 C:\xampp\htdocs\cmsimple\cms.php(1344): include()
#1 C:\xampp\htdocs\index.php(6): include('C:\\xampp\\htdocs...')
#2 {main}
thrown in C:\xampp\htdocs\templates\fhs-simple\template.htm on line 2
Im PHP Logfile steht:

Code: Select all

[25-Dec-2017 07:46:41 Europe/Berlin] PHP Fatal error:  Uncaught Error: Call to undefined function sitemapper() in C:\xampp\htdocs\templates\fhs-simple\template.htm:2
Stack trace:
#0 C:\xampp\htdocs\cmsimple\cms.php(1344): include()
#1 C:\xampp\htdocs\index.php(6): include('C:\\xampp\\htdocs...')
#2 {main}
  thrown in C:\xampp\htdocs\templates\fhs-simple\template.htm on line 2
Laut Sitemapper Handbuch ist der Templateaufruf (<?php sitemapper();?>) für CMSimple_XH Version kleiner 1.6 gedacht. Wenn dem so ist, könnte/sollte vielleicht darauf etwas deutlicher hingewiesen werden, dass es bei aktuellenren XH Versionen zu "Problemen" kommt.

Dieses Thema wurde unter "Suchmaschinenfreundliche Links und mehr" (viewtopic.php?f=16&t=13203&hilit=Sitemapper_XH) schon einmal behandelt.

Viele Grüße und ein schönes Weihnachtsfest

Hartmut

olape
Posts: 571
Joined: Fri Mar 13, 2015 8:47 am
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Post by olape » Mon Dec 25, 2017 9:04 am

Hartmut wrote:

Code: Select all

<!-- Sitemapper_XH: sitemap index -->
<sitemapindex xsi:schemaLocation="http://www.sitemaps.org/schemas/sitemap/0.9 http://www.sitemaps.org/schemas/sitemap/0.9/siteindex.xsd">
	<sitemap>
		<loc>http://127.0.0.1/?sitemapper_sitemap</loc>
		<lastmod>2017-12-24T21:12:02Z</lastmod>
	</sitemap>
</sitemapindex>
Wenn ich mich (bezogen auf eine frühere Sitemapper Version) recht entsinne, sollten hier auch noch die einzelnen Seiten mit einer Priorität und Besuchszyklus aufgelistet werden, was allerdings nicht gemacht wird
Das ist schon korrekt so.
Die eigentliche Sitemap ist dann jeweils unter ?sitemapper_sitemap zu finden.
Oder eben unter /en/?sitemapper_sitemap. Je nachdem welche und wie viele Sprachen aktiviert sind.
--> Eintrag <loc>

cmb
Posts: 12651
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Post by cmb » Mon Dec 25, 2017 12:00 pm

Hartmut wrote:Laut Sitemapper Handbuch ist der Templateaufruf (<?php sitemapper();?>) für CMSimple_XH Version kleiner 1.6 gedacht. Wenn dem so ist, könnte/sollte vielleicht darauf etwas deutlicher hingewiesen werden, dass es bei aktuellenren XH Versionen zu "Problemen" kommt.
Diese Information stammt wohl aus dem Handbuch von Sitemapper 2, und ist für die 2er Versionen auch richtig. Bei Sitemapper 3 ist der Aufruf dieser Funktion nicht mehr nötig, da Sitemapper 3 sowieso XH ≥ 1.6.3 benötigt, so dass ich die Funktion einfach entfernt hatte. Wird sie dennoch aufgerufen, dann resultiert dies in einem fatalen Fehler. Da sollte ich in der Doku nachbessern.
Michael_G wrote:Sitemapper_XH-3.0beta1.zip von Deiner Website habe ich, die bringt meine Website offline. :(
Wenn das auch passiert, falls du sitemapper() nicht im Template aufrufst, dann prüfe mal deine PHP-Version: Sitemapper 3 braucht PHP 5.4.0 oder höher. Wenn auch das gegeben ist, dann wäre die konkrete PHP-Fehlermeldung hilfreich. Vielleicht bietet dein Provider Zugang zum PHP error log; dann dort nach dem entsprechenden Fehler suchen. Ansonsten Debug-Modus temporär aktivieren; dann sollte XH 1.7.2 die Fehlermeldung im Browser anzeigen (vermutlich musst du auch temporär den 500-Fehlerhandler des Webservers deaktivieren).
Christoph M. Becker –Plugins for CMSimple_XH, but not for CMSimple 4+

Michael_G
Posts: 57
Joined: Thu Feb 18, 2016 11:01 pm

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Post by Michael_G » Mon Dec 25, 2017 7:09 pm

Hallo Hartmut und Christoph,

danke für eure Antworten, aber ich erwähnte nichts von einem Templateaufruf - und wozu sollte man das tun, wenn es sich um ein Plugin handelt, welches nicht durch eine Funktionserweiterung in userfuncs.php "installiert" und per Befehlsaufruf auf beliebiger Seite oder fest im Template aufgerufen werden muss, sondern per ZIP-Datei vom Programmierer besorgt und per FTP hochgeladen wird? ;)

Da ich die Sitemapper-Funktonalität benötige bzw. als festen Bestandteil eines CMS betrachte, habe ich vorhin nach weiteren Tests mein Voll-Backup CMSimple_XH 1.7.1 vom 24.12. wieder eingespielt und danach aus Neugierde nur die Plugins pagemanager und sitemapper auf die allerneuesten Versionen aktualisiert.
Ich wollte damit nebenbei auch testen, ob allein eines der beiden Updates ebenfalls die Website "killt", also unerreichbar macht.
Fazit: nein, ohne CMSimple_XH 1.7.2 alles fein. :mrgreen:

Damit nicht weiter nach falschen Ursachen geforscht wird:

Code: Select all

System-Info

Installierte CMSimple-Version CMSimple_XH 1.7.1  Released: 2017-10-14
Installierte Plugins

Ckeditor 2.2.1
Downloadcontrol 1.7
Exchange 1.0
Fa 1.2
Filebrowser for CMSimple_XH 1.7.1
Hi_updatecheck 1.4
Jquery 1.6.4
Meta_tags for CMSimple_XH 1.7.1
Morepagedata 1.2.2
Moved 1.0beta4
Pagemanager 3.2
Page_params for CMSimple_XH 1.7.1
Pfw 0.2.0
Polyglott 1.0beta2
Quoteoftheday 1.1.1
Seocheck 1.0.b3
Sitemapper 3.0beta1
Webserver Apache
PHP-Version 7.1.12
cmb wrote:Wenn auch das gegeben ist, dann wäre die konkrete PHP-Fehlermeldung hilfreich. Vielleicht bietet dein Provider Zugang zum PHP error log; dann dort nach dem entsprechenden Fehler suchen.
Habe gerade im Hilfecenter von 1&1 gelesen, dass ich mir das PHP-Errorlog selbst aktivieren kann und das mal getan.
cmb wrote:Ansonsten Debug-Modus temporär aktivieren; dann sollte XH 1.7.2 die Fehlermeldung im Browser anzeigen (vermutlich musst du auch temporär den 500-Fehlerhandler des Webservers deaktivieren).
Debug-Mode ist bei mir immer aktiv. Ist so eingestellt, dass er nur bei ernsten Sachen meckert.

Letzter Versuch, es jedem klar verständlich zu machen:
Sobald bei mir auf dem Webspace von 1&1 CMSimple_XH Version 1.7.2 installiert ist und die Website läuft ohne das Plugin "Sitemapper", kann ich meine Webpräsenz durch einfaches Hochladen des Plugin-Verzeichnisses "sitemapper" abschießen! Sie zeigt dann nichts mehr, nada, keinerlei Fehlermeldung! Weiße Seite!
Da hilft auch kein Debug-Mode von CMSimple_XH mehr, weil die Website gar nicht mehr geladen wrden kann!
Ist browserabhängig, mit einem von beiden, Firefox Portable oder SRWare Iron Portable erhielt ich eine sehr knappe Fehler-500-Meldung.
Auf dem iPhone zeigte Safari auch nur eine leere Seite ohne jede Meldung.

Nun probiere ich das Update erneut und melde mich gleich wieder ...

Hurra, jetzt funktioniert es! Habe es aber sicherheitshalber nicht direkt auf das "originale" laufende System eingespielt, sondern zuerst per Web-Explorer auf dem Webspace eine Kopie angelegt, das Speicherziel der Domain dorthin verlegt und auch das Sitemapper-Plugin diesmal nicht per FTP, sondern Webspace-Explorer eingespielt.
Nachdem das funktioniert hat, stellte ich das Speicherziel der Domain wieder zurück und wiederholte die Prozedur mit dem Produktivsystem.

Fazit (auch für Verträglichkeiten informativ):

Code: Select all

System-Info

Installierte CMSimple-Version CMSimple_XH 1.7.2  Released: 2017-12-21
Installierte Plugins

Ckeditor 2.2.1
Downloadcontrol 1.7
Exchange 1.0
Fa 1.2
Filebrowser for CMSimple_XH 1.7.2
Hi_updatecheck 1.4
Jquery 1.6.4
Meta_tags for CMSimple_XH 1.7.2
Morepagedata 1.2.2
Moved 1.0beta4
Pagemanager 3.2
Page_params for CMSimple_XH 1.7.2
Pfw 0.2.0
Polyglott 1.0beta2
Quoteoftheday 1.1.1
Seocheck 1.0.b3
Sitemapper 3.0beta1
Webserver Apache
PHP-Version 7.1.12
Da es reibungslos klappte, wurde auch kein PHP-Errorlog angelegt ...
Vielleicht hat eine "neue Fehlfunktion" im FileZilla das Softwareupdate bei mir erst gründlich vergeigt (ist so eingestellt, dass er ältere Dateien überschreibt. Schon immer).
ZIP-Files beziehe ich immer von der Downloadseite http://www.cmsimple-xh.org/de/, nicht von GitHub.
Plugins lade ich ebenfalls am liebsten von der Website des jeweiligen Entwicklers herunter.
Diese Fehler fallen bei mir also schonmal weg. :lol:
Ciao,
Michael

cmb
Posts: 12651
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Post by cmb » Mon Dec 25, 2017 10:11 pm

Michael_G wrote:Vielleicht hat eine "neue Fehlfunktion" im FileZilla das Softwareupdate bei mir erst gründlich vergeigt (ist so eingestellt, dass er ältere Dateien überschreibt. Schon immer).
Ist nicht undenkbar. Aber egal: die Hauptsache ist, dass es nun funktioniert – sollte dieses oder ein ähnliches Problem noch einmal auftreten, kann man immer noch genauer nachforschen. :)
Christoph M. Becker –Plugins for CMSimple_XH, but not for CMSimple 4+

Hartmut
Posts: 507
Joined: Sat Nov 05, 2011 6:13 pm
Location: Butzbach, Deutschland
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Post by Hartmut » Tue Dec 26, 2017 10:29 am

cmb wrote:
Berni wrote:das Plugin läuft zwar unter XH 1.7, aber nicht mit PHP 7.0.13 !!
Bei mir ist es so, dass das Plugin wohl die Seitenaufrufe erfasst, und in plugins/crazystat/stat/usr/logs/stat0.log protokolliert, aber die Statistik bleibt leer. Da ich keine relevanten Debug-Ausgaben bekam, habe ich alle @-Operatoren in den PHP Dateien entfernt, und überraschenderweise funktionierte danach bereits die Anzeige wieder. :?

Jedenfalls benötigt Crazystat dringend sehr viel Zuwendung, sonst sind seine Tage gezählt, fürchte ich.
Hier ein kleines Update zum Plugin crazystat_XH V1.0.5:

Bei der Umstellung einer Website von CMSimple_XH XH 1.6.10 auf XH 1.7.2 in der Xampp Umgebung (Apache/2.4.29 (Win32) OpenSSL/1.0.2l PHP/7.1.11) funktioniert das Plugin crazystat_XH V1.0.5 ohne funktionale Einschränkungen (Seitenaufrufe und user spezifische Informationen (Betriebssystem, Browser, ...) werden im Logfile erfasst und in der Browserstatistik angezeigt).

Das einzigste was mich etwas stört ist die folgende Meldung im Xampp-Logfile und auf der Crazystat-Seite:
Notice: A non well formed numeric value encountered in C:\xampp\htdocs\plugins\crazystat\stat\src\analyze.php on line 859

Viele Grüße
Hartmut

cmb
Posts: 12651
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Post by cmb » Tue Dec 26, 2017 11:23 am

Hartmut wrote:Das einzigste was mich etwas stört ist die folgende Meldung im Xampp-Logfile und auf der Crazystat-Seite:
Notice: A non well formed numeric value encountered in C:\xampp\htdocs\plugins\crazystat\stat\src\analyze.php on line 859
Da wird versucht ein Datum zu einer Zahl zu addieren; in meinem Fall 12+"26.12.2017". Das ist ein Programmfehler, aber ich kann nicht sagen, ob dieser tatsächlich zu falschen Ergebnissen führt (sprich, ob das Ergebnis der Berechnung irgendwo verwendet wird).
Christoph M. Becker –Plugins for CMSimple_XH, but not for CMSimple 4+

Post Reply