Plugin-Kompatibilität zu CMSimple_XH 1.7

Ein CMSimple Support Forum für deutsch sprechende Nutzer und Entwickler
albert
Posts: 415
Joined: Sun Mar 07, 2010 8:01 pm
Location: Germany
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Post by albert » Fri Aug 18, 2017 12:24 pm

cmb wrote:albert wrote:
ich verwende noch das alte "comments 4.1" von ge (modifiz. von svasti 2015)
[…]
Kann das so bleiben oder spricht was dagegen?

Ich weiß nicht, ob das lizenzrechtlich okay ist.
comments 4.2 wird da als freeware angeboten

was ich eigentlich wissen wollte ist, ob das mit den globalen so bleiben kann
dass er im Moment keine Zeit für deren Pflege hat
gut verstehe ich, aber nicht mal für einen kurzen Hinweis und Link?

Hartmut
Posts: 490
Joined: Sat Nov 05, 2011 6:13 pm
Location: Butzbach, Deutschland
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Post by Hartmut » Fri Aug 18, 2017 8:28 pm

Hallo,
frase wrote:
albert wrote:wo hat denn webdesign-keil die morepagedata 1.21 her?
https://cmsimpleforum.com/viewtopic.php ... ata#p61143
https://github.com/cmsimple-xh/morepage ... /tag/1.2.1
frase hat eine meiner Quellen (dieses Forum) für die Plugin Kompabilitätsliste aufgeführt. Weiterhin kommen die Infos aus der Wiki Kompabilitäsliste und den Kommentaren von Euch in meiner Plugin Kompabilitätsliste.
Da mir selbst die Zeit für Kompabilitäts Tests fehlt, bin ich über alle Informationen (Pluginname + Version, PHP Version, CMSimple_XH Version und Status (OK / Fehler XY)) froh, die ich beispielsweise hier im Forum finde.
Der Downloadlink für morepagedata 1.2.1 befindet sich auch hier.

Viele Grüße
Hartmut

olape
Posts: 371
Joined: Fri Mar 13, 2015 8:47 am
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Post by olape » Fri Aug 18, 2017 9:12 pm

Hallo Hartmut,

dann werde ich gleich mal ein paar Infos zugeben

Shariff_XH läuft offensichtlich unter 1.70 (https://cmsimpleforum.com/viewtopic.php ... 464#p61464), noch keine eigenen Tests.
Bis auf remotecontent_xh laufen alle meine Plugins auf jeden Fall bis zur 1.6.10.
remotecontent_XH habe ich noch nicht unter 1.6.10 getestet, ich gehe aber davon aus, es läuft bei dir unter 1.6.10.

cmb
Posts: 12223
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Post by cmb » Fri Aug 18, 2017 9:52 pm

albert wrote:comments 4.2 wird da als freeware angeboten
Was auch immer das heißt. IANAL :)
albert wrote:gut verstehe ich, aber nicht mal für einen kurzen Hinweis und Link?
Manchmal muss das Hobby eben ganz zurückstehen. :) Aber dafür gibt es ja das Forum: im Zweifel kurz nachfragen, und die Chancen stehen gut, dass man relativ zeitnah eine hilfreiche Antwort erhält.
Hartmut wrote:Da mir selbst die Zeit für Kompabilitäts Tests fehlt, bin ich über alle Informationen (Pluginname + Version, PHP Version, CMSimple_XH Version und Status (OK / Fehler XY)) froh, die ich beispielsweise hier im Forum finde.
Ich finde die Kompatibilitätsliste klasse (danke für die viele Arbeit!), finde allerdings, dass die Versionsangaben vom Entwickler kommen sollten. Durch Tests kann man nur Inkompatibilität sicher feststellen, aber leider nicht die Kompatibilität. Daher sollte der Entwickler vorgeben, für welche PHP- und XH-Versionen das Plugin gedacht ist; wenn es dann unter angedachten Versionen Probleme gibt, ist das halt ein Bug (oder der Entwickler ändert die Versionsangaben). Solange ein solches Problem nicht behoben ist, kann das dann auch in die Kompatibilitätsliste aufgenommen werden.

Bei den (hoffentlich) meisten meiner Plugins gebe ich explizit an, welche PHP- und welche CMSimple_XH-Version mindestens benötigt werden. Funktionieren sollten die Plugins unter diesen Versionen bis hin zu aktuellen stable releases (GA) – was leider bei vielen noch nicht der Fall ist.
Christoph M. Becker –Plugins for CMSimple_XH, but not for CMSimple 4+

olape
Posts: 371
Joined: Fri Mar 13, 2015 8:47 am
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Post by olape » Sat Aug 19, 2017 6:25 am

Ich finde die Liste auch super.

Trotzdem hätte ich da einen Vorschlag.
Nicht zum Inhalt, sondern zur Nutzbarkeit.
Es wäre aus meiner Sicht ein riesen Vorteil, wenn die Kopfzeile der Tabelle stehenbleiben würde.
Etwa so http://www.imaputz.com/cssStuff/bigFourVersion.html

albert
Posts: 415
Joined: Sun Mar 07, 2010 8:01 pm
Location: Germany
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Post by albert » Sat Aug 19, 2017 7:14 am

ja die Liste ist sehr hilfreich, danke dafür!
Ich fänd fixierte Kopfzeile auch besser (wär gespannt ob das geht)
Was ich unübersichtlich finde, ist, die verschiedeben Versionen von Plugins alle aufzuführen
Flexslider_XH 0.5
Flexslider_XH 0.5.1
Flexslider_XH 0.5.2
Flexslider_XH 0.5.3
hier würde wohl das aktuellste reichen - es ist mir jetzt schon ein paarmal passiert, dass ich nur den jeweils ersten Eintrag gesehen habe (aha, nicht kompatibel) und den nächsten Eintrag glatt übersehen...

albert
Posts: 415
Joined: Sun Mar 07, 2010 8:01 pm
Location: Germany
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Post by albert » Sat Aug 19, 2017 7:35 am

cmb wrote:Durch Tests kann man nur Inkompatibilität sicher feststellen,
Was heißt hier "nur"? Ist das nicht der Sinn dieser Liste? Und dass hier gepostet wird, was man machen kann?
Nur was nützt die Liste wenn sie nicht stimmt?
Z.B. Shariff_XH (s.o.). Oder poll_XH hatte ich einen Codeschnipsel gepostet, in der Liste steht aber weiter schlicht "Nein"- nicht kompatibel.
cmb wrote:Ja, die Umstellung ist etwas problematisch, wegen der vielen inkompatiblen Plugins
Bitte Christoph nimm mir das nicht übel wenn ich bei aller Anerkennung deiner lobenswerten Arbeit hier finde, dass "etwas problematisch" mir zu beschönigend klingt. Unser schönes CMSimple_XH 1.7 ist leider nicht abwärtskompatibel, und das ist nicht schön. Ging das denn nicht anders?

frase
Posts: 1669
Joined: Thu Apr 21, 2016 6:32 am
Location: Saxony
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Post by frase » Sat Aug 19, 2017 8:23 am

albert wrote:Unser schönes CMSimple_XH 1.7 ist leider nicht abwärtskompatibel, und das ist nicht schön. Ging das denn nicht anders?
Ich weiß ja, wie du diesen Satz meinst ... ;-)
Stimmt aber trotzdem nicht so ganz.
Das Problem ist, dass viele Plugins nicht an die neuen Gegebenheiten angepasst wurden.
Und das hat wenig mit CMSimple_XH 1.7 zu tun.
XH 1.7 musste neuer werden, weil sich viele Dinge verändern. Zum Beispiel die PHP-Versionen (7, 7.1, 7.2 ...).
Außerdem sind die Ansprüche an Websites gestiegen (SEO ...).
Daran können wir nicht vorbei.

Ein Vergleich:
Ich bin leidenschaftlicher (und gewohnheitsmäßiger) Firefox-Nutzer.
Über die Jahre habe ich mir 'ne ganze Menge AddOns zugelegt, die mir viele Dinge mit wenigen Klicks erledigen.
Im November mit Version 57 wird das von einem Tag auf den anderen vorbei sein. Die AddOns werden nicht mehr funktionieren.
Und du kannst mir glauben: Die Mozilla-Leute machen das nicht, um die Nutzer zu ärgern, sondern um "UpToDate" zu sein - um den gegebenen Ansprüchen gerecht zu werden.
Falls die AddOn-Entwickler mitzögen und ihre AddOns aktualisierten, wäre das kein Problem - tun aber leider nur die wenigsten.
Ebenso ist es bei den Plugin-Entwicklern bei XH.

olape
Posts: 371
Joined: Fri Mar 13, 2015 8:47 am
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Post by olape » Sat Aug 19, 2017 8:27 am

albert wrote: Nur was nützt die Liste wenn sie nicht stimmt?
Auch die Pflege ist sicher mit viel Arbeit verbunden und dadurch wahrscheinlich nicht immer zeitnah zu ralisieren.
Vor allem wenn man sich entsprechende Infos aus dem Forum zusammensammeln muss.
Von daher etwas Nachsicht ...
albert wrote:Unser schönes CMSimple_XH 1.7 ist leider nicht abwärtskompatibel, und das ist nicht schön. Ging das denn nicht anders?
Das wäre sicher schön, aber immer nur mit sehr viel Aufwand zu realisieren und dieser wird von Version zu Version grösser.
Irgenwann muss man dann auch mal paar alte Zöpfe abschneiden.
Es soll doch auch zeitgemäss sein.

Ich habe den Umstieg auch noch nicht realisiert.
I.M. ist mir das einfach zu viel Aufwand. Zu viel Dinge, die noch nicht so ganz kompatibel sind.
Aber das legt sich. Ist ja nun auch nicht immer so.
Und für ein neues Projekt würde ich fraglos auf jeden Fall 1.7.0 nutzen.

albert
Posts: 415
Joined: Sun Mar 07, 2010 8:01 pm
Location: Germany
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Post by albert » Sat Aug 19, 2017 9:33 am

ich kann bestätigen, dass Shariff_XH unter 1.7 und php 5.6 läuft. Schönes Plugin, danke!

Eine kleine Überraschung gab es mit dem Aufruf { { { op_shariff(); } } } . Ich hatte laut Anweisung nur die Leerzeichen zwischen den Klammern entfernt, es gab fatalen Error: Abhilfe: Die Leerzeichen vor und hinter op_shariff(); entfernen. Ich würde empfehlen, das auf der Downloadseite zu ändern in: { {{op_shariff();}}} (ein Leerzeichen reicht) oder {x{{op_shariff();}}}

Post Reply