Plugin-Kompatibilität zu CMSimple_XH 1.7

Ein CMSimple Support Forum für deutsch sprechende Nutzer und Entwickler
cmb
Posts: 12763
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Post by cmb » Mon Jul 24, 2017 3:40 pm

Berni wrote:das Plugin läuft zwar unter XH 1.7, aber nicht mit PHP 7.0.13 !!
Bei mir ist es so, dass das Plugin wohl die Seitenaufrufe erfasst, und in plugins/crazystat/stat/usr/logs/stat0.log protokolliert, aber die Statistik bleibt leer. Da ich keine relevanten Debug-Ausgaben bekam, habe ich alle @-Operatoren in den PHP Dateien entfernt, und überraschenderweise funktionierte danach bereits die Anzeige wieder. :?

Jedenfalls benötigt Crazystat dringend sehr viel Zuwendung, sonst sind seine Tage gezählt, fürchte ich.
Christoph M. Becker –Plugins for CMSimple_XH, but not for CMSimple 4+

albert
Posts: 471
Joined: Sun Mar 07, 2010 8:01 pm
Location: Germany
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Post by albert » Thu Aug 17, 2017 8:48 pm

cmb wrote:
Berni wrote:Jedenfalls benötigt Crazystat dringend sehr viel Zuwendung.
Stimmt wohl - nur wer machts?

Was sind denn "@-Operatoren" ? Sind das viele Änderungen und soll ich die in den Download einbauen?

albert
Posts: 471
Joined: Sun Mar 07, 2010 8:01 pm
Location: Germany
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Post by albert » Thu Aug 17, 2017 8:57 pm

für die Kompat.Liste:

Boilerplate_XH läuft unter 1.7 , getestet mit php 5.6
Socialshareprivacy_XH 1.1 läuft unter 1.7 , getestet mit php 5.6

Poll_XH 1beta2 läuft zwar, aber nix im Backend

zu beheben mit:
admin.php, Zeile 116

entfernen

Code: Select all

if (!empty($poll)) {
einfügen

Code: Select all

if (function_exists('XH_wantsPluginAdministration') && XH_wantsPluginAdministration('poll')
 || !empty($poll)) {

cmb
Posts: 12763
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Post by cmb » Thu Aug 17, 2017 9:56 pm

albert wrote:Was sind denn "@-Operatoren" ? Sind das viele Änderungen und soll ich die in den Download einbauen?
@-Operatoren unterdrücken PHP-Fehlermeldungen. Wieso das Plugin ohne die @s bei mir funktioniert hat, ist mir ein großes Rätsel. Gut möglich, dass etwas ganz anderes für das plötzliche Funktionieren verantwortlich war.
albert wrote:Stimmt wohl - nur wer machts?
Gute Frage! :)
albert wrote:Socialshareprivacy_XH 1.1 läuft unter 1.7 , getestet mit php 5.6
Erfreulich. :) Trotzdem würde ich empfehlen auf Shariff_XH umzustellen. Das Konzept ist einfach wesentlich durchdachter, und wird wohl weiterentwickelt, im Gegensatz zu Socialshareprivacy.
albert wrote:Poll_XH 1beta2 läuft zwar, aber nix im Backend
Danke. Habe ich als Inkompatibilität und als Bug vermerkt.
Christoph M. Becker –Plugins for CMSimple_XH, but not for CMSimple 4+

albert
Posts: 471
Joined: Sun Mar 07, 2010 8:01 pm
Location: Germany
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Post by albert » Fri Aug 18, 2017 6:35 am

Trotzdem würde ich empfehlen auf Shariff_XH umzustellen
ja denke ich auch - nur solange Shariff_XH in o.g. Liste http://cmsimplexh.webdesign-keil.de/?CM ... pabilitaet mit "??" steht ... ging erstmal schneller so

albert
Posts: 471
Joined: Sun Mar 07, 2010 8:01 pm
Location: Germany
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Post by albert » Fri Aug 18, 2017 10:31 am

ich verwende noch das alte "comments 4.1" von ge (modifiz. von svasti 2015)
das funzt, aber kein backend
habe jetzt in admin.php ganz am Anfang
gelöscht

Code: Select all

initvar('comments');

if ($comments) 
{
	global $action, $admin, $pth, $ts, $tx, $plugin_cf, $show_entry, $blog_file, $co_author_folder;
	...
	
stattdessen

Code: Select all

if (function_exists('XH_wantsPluginAdministration') && XH_wantsPluginAdministration('comments')
){
	global $action, $admin, $pth, $ts, $tx, $plugin_cf, $show_entry;
	...
	
funktioniert!
Kann das so bleiben oder spricht was dagegen?

albert
Posts: 471
Joined: Sun Mar 07, 2010 8:01 pm
Location: Germany
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Post by albert » Fri Aug 18, 2017 11:59 am

wo hat denn webdesign-keil die morepagedata 1.21 her?
Im download bei svasti gibt es nur morepagedata 1.2 - und bei der geht das backend nicht
Obwohl in der Hilfe steht:
Neu in Version 1.2
Bereit für PHP 7 und XH 1.7.

habe geändert

Code: Select all

if (function_exists('XH_wantsPluginAdministration') && XH_wantsPluginAdministration('morepagedata')
 || isset($morepagedata)
) {
//    initvar('admin'); entfernen
//    initvar('action'); entfernen
    include 'funcs.php';
    ...
PS svasti: Im Backend von vers. 1.2 steht noch vers. 1.1

PS: ziemliches Kuddelmuddel die ganze Umstellung auf 1.7 - not amused - aber wenn ich bald XH-Shop verwenden will ... ;)

frase
Posts: 2150
Joined: Thu Apr 21, 2016 6:32 am
Location: Saxony
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Post by frase » Fri Aug 18, 2017 12:04 pm


cmb
Posts: 12763
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Post by cmb » Fri Aug 18, 2017 12:15 pm

albert wrote:ich verwende noch das alte "comments 4.1" von ge (modifiz. von svasti 2015)
[…]
Kann das so bleiben oder spricht was dagegen?
Ich weiß nicht, ob das lizenzrechtlich okay ist.
albert wrote:ziemliches Kuddelmuddel die ganze Umstellung auf 1.7 - not amused - aber wenn ich bald XH-Shop verwenden will ...
Ja, die Umstellung ist etwas problematisch, wegen der vielen inkompatiblen Plugins. Ich hatte gerade bzgl. "issue #21" (Pluginadministration kann nicht aufgerufen werden) erheblich weniger Probleme erwartet, da XH_wantsPluginAdministration() bereits seit 3 ½ Jahren verfügbar war – aber selbst ich hatte bei vielen Plugins auch noch nicht nachgebessert. Immerhin aber auch eine Gelegenheit, alte Plugins insgesamt mal zu prüfen (gibt bzw. gab ja auch einige Probleme bezüglich PHP 7.0/7.1).

Bei svastis Plugins kommt dummerweise noch hinzu, dass er im Moment keine Zeit für deren Pflege hat, so dass fast alle auf https://github.com/cmsimple-xh/ zu finden sind; soweit ich es überblicke sind sie mittlerweile alle XH 1.7 und PHP 7 kompatibel.

Der XH-Shop sollte mit XH ≥ 1.6.3 kompatibel sein. Daher drängt das Upgrade auf XH 1.7 nicht so sehr – allerdings würden auch keine Sicherheitslücken bei XH 1.6 mehr gefixt (derzeit sind keine bekannt), so dass man sich auch nicht ewig Zeit lassen sollte.
Christoph M. Becker –Plugins for CMSimple_XH, but not for CMSimple 4+

albert
Posts: 471
Joined: Sun Mar 07, 2010 8:01 pm
Location: Germany
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Post by albert » Fri Aug 18, 2017 12:19 pm

@frase danke dir

PS: "Kuddelmuddel" sollte keine Kritik sein an all jenen, die hier dankenswert unschätzbare Arbeit leisten.
Ich wollte nur anmerken, dass das auf "Neue" wohl weniger animierend wirkt...

Post Reply