Plugin-Kompatibilität zu CMSimple_XH 1.7

Ein CMSimple Support Forum für deutsch sprechende Nutzer und Entwickler
Hartmut
Posts: 465
Joined: Sat Nov 05, 2011 6:13 pm
Location: Butzbach, Deutschland
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Postby Hartmut » Mon Nov 20, 2017 8:47 pm

Test Plugin ge_canonical Version: 1.2

Getestet lokal unter
Xampp
PHP-Version 7.1.1
CMSimple_XH 1.7.1
Template fhs-simple

  • Nach der Installation im Plugin Verzeichnis wird im Debus-Modus gemeldet:
    XH-DEPRECATED: Function initvar() is deprecated
    C:\xampp\htdocs\plugins\ge_canonical\admin.php:14
  • Plugin im Admin-Menü sichtbar? => Nein
Ergebnis:
CMSimple_XH 1.6 Kompatibilität: Ja
CMSimple_XH 1.7 Kompatibilität: Nein (XH-DEPRECATED: Function initvar() is deprecated ...)
PHP 7.0: ?? (Keine xampp-Fehlermeldungen, nur eingeschränkt verwertbar wegen XH-DEPRECATED)
PHP 7.1: ?? (Keine xampp-Fehlermeldungen, nur eingeschränkt verwertbar wegen XH-DEPRECATED)

Hartmut
Posts: 465
Joined: Sat Nov 05, 2011 6:13 pm
Location: Butzbach, Deutschland
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Postby Hartmut » Mon Nov 20, 2017 8:48 pm

Test Plugin Cryptographp_XH Version: 1.0beta6

Getestet lokal unter
Xampp
PHP-Version 7.1.1
CMSimple_XH 1.7.1
Template fhs-simple

  • Plugin im Admin-Menü sichtbar? => Ja
  • Plugin im Plugin-Menu aufrufbar? => Ja, Startseite und Unterseiten (Konfiguration, css, ...) aufrufbar? => Ja
  • Config änderbar und speicherbar? => Ja
  • Dieses Utility-Plugin wurde nicht in Verbindung mit anderen Plugins getestet.

Ergebnis:
CMSimple_XH 1.7 Kompatibilität: Ja
PHP 7.0: Ja (Keine xampp-Fehlermeldungen)
PHP 7.1: Ja (Keine xampp-Fehlermeldungen)

Berni
Posts: 40
Joined: Wed Feb 12, 2014 4:38 pm

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Postby Berni » Tue Nov 21, 2017 11:23 am

Ich hätte da noch eine kleine Anmerkung zu Twocents_XH 1.0beta3

Das Plugin läuft zwar unter CMSimple_XH 1.7.1
aber die Formatierungen fehlen alle.

Bislang hat Twocents doch die Formatierung des blockquote übernommen - oder irre ich mich?
Das macht es aktuell auf meinen Seiten nun aber nicht mehr.

Man muss jetzt in der css des Plugins unter

Code: Select all

.twocents_comment

die Einstellungen manuell eintragen.

PS: wie muss der Eintrag eigentlich lauten, damit die css klasse blockqoute
1:1 übernommen wird ohne alle Einzelteile dort reinzukopieren?
Das habe ich nämlich noch nicht hinbekommen ;-)

frase
Posts: 1594
Joined: Thu Apr 21, 2016 6:32 am
Location: Saxony
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Postby frase » Tue Nov 21, 2017 11:40 am

Berni wrote:Bislang hat Twocents doch die Formatierung des blockquote übernommen - oder irre ich mich?

Da bin ich mir gar nicht so sicher. Das ist aber für deinen Fall auch egal.

Ich nehme mal an, dass du in deinem Template eine Regel für <blockquote> hast.
Du möchtest, dass der Kommentar-Text diese Regel annimmt?
Du könntest im Seiten-Template einfach zu dieser Regel, den Selektor für die Kommentare hinzufügen.
Ich würde das nicht im Plugin-Template machen, weil das mit einer neuen Version möglicherweise überschrieben würde.

bisher:

Code: Select all

blockquote {
    ... /* deine bisherigen Regeln */

ändern zu:

Code: Select all

blockquote, .twocents_message {
    ... /* deine bisherigen Regeln */


twocents_message betrifft den reinen Text des Kommentars.
Mit den Entwicklertools des Browsers [F12] findest du die anderen Bereiche heraus, falls du diese auch noch stylen möchtest.

cmb
Posts: 12047
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Postby cmb » Tue Nov 21, 2017 12:04 pm

Berni wrote:Bislang hat Twocents doch die Formatierung des blockquote übernommen - oder irre ich mich?

Das war ursprünglich mal so, wurde aber geändert.
Christoph M. Becker –Plugins for CMSimple_XH, but not for CMSimple 4+

Berni
Posts: 40
Joined: Wed Feb 12, 2014 4:38 pm

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Postby Berni » Tue Nov 21, 2017 5:25 pm

frase wrote:Da bin ich mir gar nicht so sicher. Das ist aber für deinen Fall auch egal.

Ich nehme mal an, dass du in deinem Template eine Regel für <blockquote> hast.
Du möchtest, dass der Kommentar-Text diese Regel annimmt?
Du könntest im Seiten-Template einfach zu dieser Regel, den Selektor für die Kommentare hinzufügen.
Ich würde das nicht im Plugin-Template machen, weil das mit einer neuen Version möglicherweise überschrieben würde.

bisher:

Code: Select all

blockquote {
    ... /* deine bisherigen Regeln */

ändern zu:

Code: Select all

blockquote, .twocents_message {
    ... /* deine bisherigen Regeln */


twocents_message betrifft den reinen Text des Kommentars.
Mit den Entwicklertools des Browsers [F12] findest du die anderen Bereiche heraus, falls du diese auch noch stylen möchtest.


Danke, das hilft mir sehr.
Auf einigen Seiten möchte ich die Kommentare nämlich auch in der Optik der News.
Ich finde es schaut so gefälliger aus - aber jeder nach seiner Façon :-)

Hartmut
Posts: 465
Joined: Sat Nov 05, 2011 6:13 pm
Location: Butzbach, Deutschland
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Postby Hartmut » Sat Nov 25, 2017 9:28 pm

Test Plugin Monorder_XH Version: 1.0

Getestet lokal unter
Xampp
PHP-Version 7.1.1
CMSimple_XH 1.7.1
Template fhs-simple

Plugin in der Sytem-Info sichtbar? => Ja (Monorder 1.0)
Plugin im Admin-Menü sichtbar? => Ja
Plugin im Admin-Menü aufrufbar? => Nein (leere Seite)
Keine Debug-Modus Meldungen
Keine xampp-Fehlermeldungen

Ergebnis:
CMSimple_XH 1.6 Kompatibilität: Ja
CMSimple_XH 1.7 Kompatibilität: Nein (Plugin im Admin-Menü nicht aufrufbar.)

Hartmut
Posts: 465
Joined: Sat Nov 05, 2011 6:13 pm
Location: Butzbach, Deutschland
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Postby Hartmut » Sat Nov 25, 2017 9:28 pm

Test Plugin Recaptcha_XH Version: 1 beta1

Getestet lokal unter
Xampp
PHP-Version 7.1.1
CMSimple_XH 1.7.1
Template fhs-simple

Plugin in der Sytem-Info sichtbar? => Ja (Recaptcha)
Plugin im Admin-Menü sichtbar? => Ja
Plugin im Admin-Menü aufrufbar? => Nein (leere Seite)
Keine Debug-Modus Meldungen
Keine xampp-Fehlermeldungen

Ergebnis:
CMSimple_XH 1.6 Kompatibilität: Ja
CMSimple_XH 1.7 Kompatibilität: Nein (Plugin im Admin-Menü nicht aufrufbar.)

Hartmut
Posts: 465
Joined: Sat Nov 05, 2011 6:13 pm
Location: Butzbach, Deutschland
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Postby Hartmut » Sat Nov 25, 2017 9:29 pm

Test Plugin Schedule_XH Version: 1 .0

Getestet lokal unter
Xampp
PHP-Version 7.1.1
CMSimple_XH 1.7.1
Template fhs-simple

Plugin in der Sytem-Info sichtbar? => Ja (Schedule 1.0 )
Plugin im Admin-Menü sichtbar? => Ja
Plugin im Admin-Menü aufrufbar? => Ja
Plugin Konfiguration änderbar und speicherbar? => Ja
Abstimmung (in Verbindung mit Memberpages 3.6.5) durchführbar (eintragen + speichern)? => Ja
Keine Debug-Modus Meldungen
Keine xampp-Fehlermeldungen

Ergebnis:
CMSimple_XH 1.6 Kompatibilität: Ja
CMSimple_XH 1.7 Kompatibilität: Ja
Kompatibilität PHP 7.1: Ja

Hartmut
Posts: 465
Joined: Sat Nov 05, 2011 6:13 pm
Location: Butzbach, Deutschland
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Postby Hartmut » Sat Nov 25, 2017 9:30 pm

Test Plugin filter Version: 1.0dev2

Getestet lokal unter
Xampp
PHP-Version 7.1.1
CMSimple_XH 1.7.1
Template fhs-simple

Plugin in der Sytem-Info sichtbar? => Ja (Filter 1.0dev1 (vermutl. falsche version.nfo)
Plugin im Admin-Menü sichtbar? => Ja
Plugin im Admin-Menü aufrufbar? => Nein (leere Seite)
Keine Debug-Modus Meldungen
Keine xampp-Fehlermeldungen

Ergebnis:
CMSimple_XH 1.6 Kompatibilität: Ja
CMSimple_XH 1.7 Kompatibilität: Nein (Plugin im Admin-Menü nicht aufrufbar.)


Return to “Deutsch”

Who is online

Users browsing this forum: No registered users and 2 guests