Plugin-Kompatibilität zu CMSimple_XH 1.7

Ein CMSimple Support Forum für deutsch sprechende Nutzer und Entwickler
Hartmut
Posts: 508
Joined: Sat Nov 05, 2011 6:13 pm
Location: Butzbach, Deutschland
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Post by Hartmut » Sat Dec 09, 2017 4:27 pm

cmb wrote:
Hartmut wrote:Test Plugin Ipban_XH Version: 1 beta2
Uff, das gibt's ja auch noch! Ich persönlich fand das Plugin schon immer fraglich, und stelle daher auch aus Zeitgründen die Entwicklung ein (habe ich auf der Projektseite bereits vermerkt).
Die Plugin Dokumentation auf http://cmsimplexh.webdesign-keil.de wurde ergänzt.

Hartmut
Posts: 508
Joined: Sat Nov 05, 2011 6:13 pm
Location: Butzbach, Deutschland
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Post by Hartmut » Sat Dec 09, 2017 4:28 pm

Test Plugin shariff_XH_light Version: 1.0beta5

Getestet lokal unter
Xampp
PHP-Version 7.1.1
CMSimple_XH 1.7.1
Template fhs-simple

Plugin in der Sytem-Info sichtbar? => Ja, Shariff_light 1.0.b5
Plugin im Admin-Menü sichtbar? => Ja
Plugin im Admin-Menü aufrufbar? => Ja
Plugin Stylesheet / Konfiguration / Sprache änderbar und speicherbar? => Ja
Plugin Aufruf auf der Seite: Funktioniert fehlerfrei
Plugin Aufruf im Template: Nicht getestet

Xampp-Fehlermeldungen: Nein
Debug-Meldung: Nein

Ergebnis:
CMSimple_XH 1.6 Kompatibilität: Ja
CMSimple_XH 1.7 Kompatibilität: Ja
PHP 7.0 Kompatibilität: Ja
PHP 7.1 Kompatibilität: Ja

lck
Posts: 1254
Joined: Wed Mar 23, 2011 11:43 am
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Post by lck » Sat Dec 09, 2017 4:57 pm

Hartmut wrote:Test Plugin hi_Shutter_Reloaded Version: 1.0
...
Plugin im Admin-Menü aufrufbar? => Nein, leere Seite
Plugin Konfiguration / Sprache änderbar und speicherbar? => Nein (Plugin Konfigurationsseiten nicht sichtbar)
Plugin Aufruf auf der Seite: Nicht getestet
Plugin Aufruf im Template: Nicht getestet

Xampp-Fehlermeldungen: Nein
Debug-Meldung: Ja, dauerhafte Anzeige:
XH-DEPRECATED: Function initvar() is deprecated
C:\xampp\htdocs\plugins\hi_shutter_reloaded\admin.php:34
...
Quick-FIX, admin.php ab Zeile 34 ändern:

Code: Select all

//initvar('hi_shutter_reloaded');

    //if($hi_shutter_reloaded){
    if (XH_wantsPluginAdministration('hi_shutter_reloaded')) { 
help_de.htm wrote:Einbau

Um das Plugin auf jeder Seite automatisch zu aktivieren, setzen Sie in der Konfiguration die Einstellung
"autoinclude" auf "1".
Um das Plugin auf einer einzelnen Seite zu aktivieren, nutzen Sie CMSimple-Scripting im Seiten-Inhalt:
#CMSimple $output.=hi_shutter();#

Unter CMSimple_XH kann auch ein alternativer Aufruf verwendet werden:
{{{plugin:hi_shutter();}}}
Mit diesem Plugin-Aufruf bekommt man einen "HTTP ERROR 500", er sollte so lauten (wichtig sind die einfachen Anführungszeichen in der Klammer!):

Code: Select all

{{{hi_shutter('');}}} 
„Bevor du den Pfeil der Wahrheit abschießt, tauche die Spitze in Honig!“      XH-Templates for MultiPage & OnePage

Hartmut
Posts: 508
Joined: Sat Nov 05, 2011 6:13 pm
Location: Butzbach, Deutschland
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Post by Hartmut » Sat Dec 09, 2017 5:11 pm

Test Plugin Recaptcha_XH Version: 2beta1 (von http://cmsimple-jp.org)

Getestet lokal unter
Xampp
PHP-Version 7.1.1
CMSimple_XH 1.7.1
Template fhs-simple

Plugin in der Sytem-Info sichtbar? => Ja, Recaptcha_xh 1beta1
Plugin im Admin-Menü sichtbar? => Ja
Plugin im Admin-Menü aufrufbar? => Nein (leere Seite)
Plugin Konfiguration / Sprache änderbar und speicherbar? => Nein
Plugin Aufruf auf der Seite: Nicht getestet
Plugin Aufruf im Template: Nicht getestet

Xampp-Fehlermeldungen: Nein
Debug-Meldung: Nein

Ergebnis:
CMSimple_XH 1.6 Kompatibilität: Ja
CMSimple_XH 1.7 Kompatibilität: Nein
PHP 7.0 Kompatibilität: ?? (vermutl. Ja, aber nicht testbar da o.g. Fehler)
PHP 7.1 Kompatibilität: ?? (vermutl. Ja, aber nicht testbar da o.g. Fehler)
Weitere Anmerkungen:
Die Datei "version.nfo" sollte auf "2beta1" aktualisiert werden?

cmb
Posts: 12663
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Post by cmb » Sat Dec 09, 2017 5:12 pm

lck wrote:
help_de.htm wrote:Einbau

Um das Plugin auf jeder Seite automatisch zu aktivieren, setzen Sie in der Konfiguration die Einstellung
"autoinclude" auf "1".
Um das Plugin auf einer einzelnen Seite zu aktivieren, nutzen Sie CMSimple-Scripting im Seiten-Inhalt:
#CMSimple $output.=hi_shutter();#

Unter CMSimple_XH kann auch ein alternativer Aufruf verwendet werden:
{{{plugin:hi_shutter();}}}
Mit diesem Plugin-Aufruf bekommt man einen "HTTP ERROR 500", er sollte so lauten (wichtig sind die einfachen Anführungszeichen in der Klammer!):

Code: Select all

{{{hi_shutter('');}}}
Das dürfte nur unter PHP 7.1 und höher passieren. Die sauberste Lösung wäre die Funktionsdefinition in index.php Zeile 19 anzupassen:

Code: Select all

    function hi_shutter($mode = ''){ 
Dann sollten die Pluginaufrufe wie dokumentiert funktionieren.
Christoph M. Becker –Plugins for CMSimple_XH, but not for CMSimple 4+

lck
Posts: 1254
Joined: Wed Mar 23, 2011 11:43 am
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Post by lck » Sat Dec 09, 2017 5:58 pm

cmb wrote:Dann sollten die Pluginaufrufe wie dokumentiert funktionieren.
Ja, so geht's!
„Bevor du den Pfeil der Wahrheit abschießt, tauche die Spitze in Honig!“      XH-Templates for MultiPage & OnePage

Hartmut
Posts: 508
Joined: Sat Nov 05, 2011 6:13 pm
Location: Butzbach, Deutschland
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Post by Hartmut » Sat Dec 09, 2017 7:36 pm

lck wrote:
cmb wrote:Dann sollten die Pluginaufrufe wie dokumentiert funktionieren.
Ja, so geht's!
Bestätigt. :)

2. Test Plugin hi_shutter_reloaded Version: 1.0 mit dem XH 1.7 Workaround

Getestet lokal unter
Xampp
PHP-Version 7.1.1
CMSimple_XH 1.7.1
Template fhs-simple

Plugin in der Sytem-Info sichtbar? => Ja, Hi_shutter_reloaded v. 1.0
Plugin im Admin-Menü sichtbar? => Ja
Plugin im Admin-Menü aufrufbar? => Ja
Plugin Konfiguration / Sprache änderbar und speicherbar? => Ja
Plugin Aufruf auf der Seite: Funktioniert fehlerfrei
Plugin Aufruf im Template: Nicht getestet

Xampp-Fehlermeldungen: Nein
Debug-Meldung: Nein

Ergebnis:
CMSimple_XH 1.6 Kompatibilität: Ja
CMSimple_XH 1.7 Kompatibilität: Nein* (Ja mit dem XH 1.7 Workaround, aber noch keine Plugin Version mit dem Bugfix vorhanden.)
PHP 7.0 Kompatibilität: Ja
PHP 7.1 Kompatibilität: Ja

Hartmut
Posts: 508
Joined: Sat Nov 05, 2011 6:13 pm
Location: Butzbach, Deutschland
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Post by Hartmut » Sat Dec 09, 2017 8:00 pm

Test Plugin Speedmon Version: 1alpha2

Getestet lokal unter
Xampp
PHP-Version 7.1.1
CMSimple_XH 1.7.1
Template fhs-simple

Plugin in der Sytem-Info sichtbar? => Ja, Speedmon 1alpha2
Plugin im Admin-Menü sichtbar? => Ja
Plugin im Admin-Menü aufrufbar? => Nein
Plugin Konfiguration / Sprache änderbar und speicherbar? => Nein
Plugin Aufruf auf der Seite: Nicht getestet
Plugin Aufruf im Template: Nicht getestet
Xampp-Fehlermeldungen: Nein
Debug-Meldung: Nein

Ergebnis:
CMSimple_XH 1.6 Kompatibilität: Ja
CMSimple_XH 1.7 Kompatibilität: Nein
PHP 7.0 Kompatibilität: ?? (vermutl. Ja, aber nicht testbar da o.g. Fehler)
PHP 7.1 Kompatibilität: ?? (vermutl. Ja, aber nicht testbar da o.g. Fehler)
Weitere Anmerkungen:
Kein Plugin Dokumentation vorhanden

Hartmut
Posts: 508
Joined: Sat Nov 05, 2011 6:13 pm
Location: Butzbach, Deutschland
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Post by Hartmut » Sat Dec 09, 2017 8:21 pm

Test Plugin Utf8migrator Version: 1 beta2

Getestet lokal unter
Xampp
PHP-Version 7.1.1
CMSimple_XH 1.7.1
Template fhs-simple

Plugin in der Sytem-Info sichtbar? => Ja, Utf8migrator
Plugin im Admin-Menü sichtbar? => Ja
Plugin im Admin-Menü aufrufbar? => Nein (leere Seite)
Plugin Konfiguration / Sprache änderbar und speicherbar? => Nein (Plugin Konfigurationsseiten nicht sichtbar)
Plugin Aufruf auf der Seite: Nicht getestet
Plugin Aufruf im Template: Nicht getestet

Xampp-Fehlermeldungen: Nein
Debug-Meldung: Nein

Ergebnis:
CMSimple_XH 1.6 Kompatibilität: Ja
CMSimple_XH 1.7 Kompatibilität: Nein
PHP 7.0 Kompatibilität: ?? (vermutl. Ja, aber nicht testbar da o.g. Fehler)
PHP 7.1 Kompatibilität: ?? (vermutl. Ja, aber nicht testbar da o.g. Fehler)

Hartmut
Posts: 508
Joined: Sat Nov 05, 2011 6:13 pm
Location: Butzbach, Deutschland
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Post by Hartmut » Sat Dec 09, 2017 9:18 pm

Test Plugin Webcamviewer Version: 1.0

Getestet lokal unter
Xampp
PHP-Version 7.1.1
CMSimple_XH 1.7.1
Template fhs-simple

Plugin in der Sytem-Info sichtbar? => Ja, Webcamviewer 1.0
Plugin im Admin-Menü sichtbar? => Ja
Plugin im Admin-Menü aufrufbar? => Ja
Plugin Stylesheet / Konfiguration / Sprache änderbar und speicherbar? => Ja
Plugin Aufruf auf der Seite: Nicht getestet (aus der Dokumentation nicht ersichtlich wie das Plugin in der Seite eingebunden wird und in welchen Verzeichnis die Bilder liegen müssen.)
Plugin Aufruf im Template: Nicht getestet (aus der Dokumentation nicht ersichtlich wie das Plugin im Template eingebunden wird und in welchen Verzeichnis die Bilder liegen müssen.)

Xampp-Fehlermeldungen: Nein
Debug-Meldung: Nein

Ergebnis:
CMSimple_XH 1.6 Kompatibilität: Ja
CMSimple_XH 1.7 Kompatibilität: Ja*
PHP 7.0 Kompatibilität: Ja
PHP 7.1 Kompatibilität: Ja
Weitere Anmerkungen:
Unvollständige Plugin Dokumentation

Post Reply