Plugin-Kompatibilität zu CMSimple_XH 1.7

Ein CMSimple Support Forum für deutsch sprechende Nutzer und Entwickler
Tata
Posts: 2474
Joined: Tue May 20, 2008 5:34 am
Location: Slovakia
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Postby Tata » Mon Sep 18, 2017 7:21 pm

Ich teste es jetzt am Localhost mit PHP 7.0.8. Soweit keine Probleme.
CMSimple.sk
It's no shame to ask for an answer if all efforts failed.
But it's awful to ask without any effort to find the answer yourself.

cmb
Posts: 11886
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Postby cmb » Mon Sep 18, 2017 8:40 pm

Hartmut wrote:Unter CMSimple_XH 1.7.0 und PHP 5.3 / 5.6 funktioniert das Plugin Xhshop 1.0 bei mir fehlerfrei. Gibt es unter PHP 7.x für Xhshop 1.0 schon Erfahrungswerte?

Ich entwickle seit einer Weile meist unter PHP 7.0 und 7.1, und da sind mir bei XH-Shop noch keine Probleme aufgefallen.

Hartmut wrote:Gibt es für eine funktionierende Kombination CMSimple_XH 1.7.0 und Sitemapper schon ein Zeitziel?

Ich versuche, es diese Woche fertig zu machen. (Olaf wartet auch schon sehnlich darauf. :))
Christoph M. Becker –Plugins for CMSimple_XH, but not for CMSimple 4+

Hartmut
Posts: 406
Joined: Sat Nov 05, 2011 6:13 pm
Location: Butzbach, Deutschland
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Postby Hartmut » Mon Oct 02, 2017 8:30 am

Hallo,
hier kommt ein kurzer Kompabilittätstest von Plugins unter CMSimple_XH 1.7.0:

Rahmenbedingungen:
Installierte CMSimple Version
CMSimple_XH 1.7.0 Released: 2017-07-02
Installierte Plugins
Fa 1.1
Filebrowser for CMSimple_XH 1.7.0
Hi_updatecheck 1.4
Jquery 1.6.4
Meta_tags for CMSimple_XH 1.7.0
Pagemanager 3.0
Page_params for CMSimple_XH 1.7.0
Tinymce4
Webserver
Apache/2.2.31 (Unix)
PHP-Version
5.6.31
Template
richu 172

Systemprüfung der o.g. Installation:
Bis auf die Meldung "Prüfe, dass die Erweiterung 'intl' geladen ist … Warnung" alles OK.
Die FF Web Console und der CMSimple_XH Debug Modus sind aktiviert.

Ergebnis:
Testergebnis nach der Installation im Plugin Verzeichnis in der oben aufgeführten Testinstallation (FF Webconsole und Debug Modus sind aktiviert):

Adventcalendar 1beta5:
Im Pluginmenü sichtbar, beim Anklicken erscheint anstelle der Plugin Startseite mit "Konfiguration", "Sprache", ... eine leere Seite.
CMSimple_XH 1.7 Kompabilität: Nein

Audio_XH-1beta4:
Im Pluginmenü NICHT sichtbar
CMSimple_XH 1.7 Kompabilität: Nein

Cryptographp_XH-1.0beta6:
Im Pluginmenü sichtbar, aufrufbar und eine geänderte Konfiguration speicherbar.
Cryptographp_XH wurde nicht in Kombination mit einem anderen Plugin getestet.
CMSimple_XH 1.7 Kompabilität: Ja

encmailXH2.0rc5
Im Pluginmenü sichtbar, aufrufbar und eine geänderte Konfiguration speicherbar.
Die Mailadresse wird nicht beim überfahren mit der Maus angezeigt.
CMSimple_XH 1.7 Kompabilität: Ja

Ocal_XH-1.0beta4
Im Pluginmenü sichtbar, aufrufbar und eine geänderte Konfiguration speicherbar.
Status der Tage ist änderbar und werden in der Kalender- und der Listenansicht angezeigt.
CMSimple_XH 1.7 Kompabilität: Ja?
Debug Modus:
WARNING: Cannot redeclare class Ocal_Occupancy
/.../plugins/ocal/index.php:25
WARNING: Cannot redeclare class Ocal_HourlyOccupancy
/.../plugins/ocal/index.php:26

Viele Grüße
Hartmut

cmb
Posts: 11886
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Postby cmb » Mon Oct 02, 2017 9:17 am

Danke für die Tests, Hartmut! Adventcalendar_XH und Audio_XH habe ich als inkompatibel vermerkt. Die beiden Warnungen bei Ocal_XH können getrost ignoriert werden, da sie die Funktionalität nicht beeinflussen. Werde ich bei Gelegenheit aber dennoch beheben.
Christoph M. Becker –Plugins for CMSimple_XH, but not for CMSimple 4+

cmb
Posts: 11886
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Postby cmb » Mon Oct 02, 2017 11:45 am

cmb wrote:[…] Audio_XH habe ich als inkompatibel vermerkt.

Upps! Bei Audio_XH gibt es bisher überhaupt keine Plugin-Administration – ist also doch CMSimple_XH 1.7 kompatibel. :)
Christoph M. Becker –Plugins for CMSimple_XH, but not for CMSimple 4+

Hartmut
Posts: 406
Joined: Sat Nov 05, 2011 6:13 pm
Location: Butzbach, Deutschland
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Postby Hartmut » Mon Oct 02, 2017 6:57 pm

cmb wrote:
cmb wrote:[…] Audio_XH habe ich als inkompatibel vermerkt.

Upps! Bei Audio_XH gibt es bisher überhaupt keine Plugin-Administration – ist also doch CMSimple_XH 1.7 kompatibel. :)


Ich habe es in meiner Plugin Kompabilitätsliste vermerkt.

Hier kommen die nächsten Kompabilittätstests von Plugins unter CMSimple_XH 1.7.0:

Rahmenbedingungen:
Installierte CMSimple Version
CMSimple_XH 1.7.0 Released: 2017-07-02
Standardplugins
Webserver: Apache/2.2.31 (Unix)
PHP-Version: 5.6.31
Template: richu 172

Ergebnis:
Testergebnis nach der Installation im Plugin Verzeichnis in der oben aufgeführten Testinstallation (FF Webconsole und Debug Modus sind aktiviert):

Tetris_XH 1.0:
Im Pluginmenü sichtbar, beim Anklicken erscheint anstelle der Plugin Startseite mit "Konfiguration", "Sprache", ... eine leere Seite.
Im Admin-Ansichtsmodus und in der Besucher-Ansicht kann Tetris fehlerfrei gespielt werden.
CMSimple_XH 1.7 Kompabilität: Ja (mit Vorbehalt)

Debug Modus (im Admin-Ansichtsmodus):
NOTICE: Indirect modification of overloaded element of XH\PluginConfig has no effect
/.../plugins/tetris/index.php:231
NOTICE: Indirect modification of overloaded element of XH\PluginConfig has no effect
/../plugins/tetris/index.php:104
NOTICE: Indirect modification of overloaded element of XH\PluginConfig has no effect
/mnt/.../plugins/tetris/index.php:105
NOTICE: Indirect modification of overloaded element of XH\PluginConfig has no effect
/.../plugins/tetris/index.php:53
NOTICE: Indirect modification of overloaded element of XH\PluginConfig has no effect
/.../plugins/tetris/index.php:170
NOTICE: Indirect modification of overloaded element of XH\PluginConfig has no effect
/.../plugins/tetris/index.php:189
NOTICE: Indirect modification of overloaded element of XH\PluginConfig has no effect
/.../plugins/tetris/index.php:209
FF Web Console (Besucher Modus (nicht als Admin angemeldet)):
JQMIGRATE: Migrate is installed, version 1.4.1 jquery-migrate-1.4.1.min.js:2:542
Synchrone XMLHttpRequests am Haupt-Thread sollte nicht mehr verwendet werden, weil es nachteilige Effekte für das Erlebnis der Endbenutzer hat. Für weitere Hilfe siehe http://xhr.spec.whatwg.org/

Slideshow_XH 1beta3:
Im Pluginmenü sichtbar, aufrufbar und eine geänderte Konfiguration speicherbar.
Bilder im angegebenen Verzeichnis des Plugin Aufrufs werden je nach gewählter Konfiguration angezeigt.
CMSimple_XH 1.7 Kompabilität: Ja

Feedview_XH-1.0beta1:
Im Pluginmenü sichtbar, aufrufbar und eine geänderte Konfiguration speicherbar.
Feeds werden angezeigt.
CMSimple_XH 1.7 Kompabilität: Ja

Achim
Posts: 12
Joined: Wed Feb 24, 2016 11:53 am

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Postby Achim » Tue Oct 03, 2017 11:00 am

Hallo zusammen,

ist noch geplant, das Plugin COCO_XH an CMSimple_XH 1.7 anzupassen. Oder gibt es Alternativen?

Achim

Hartmut
Posts: 406
Joined: Sat Nov 05, 2011 6:13 pm
Location: Butzbach, Deutschland
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Postby Hartmut » Tue Oct 03, 2017 2:27 pm

Hallo Achim,
Achim wrote:ist noch geplant, das Plugin COCO_XH an CMSimple_XH 1.7 anzupassen. Oder gibt es Alternativen?

ich vermute einmal das Christoph (cmb) sein Coco_XH Plugin noch anpassen wird.

Für die Einbindung von "fremden Dateien" (also Text bzw. Bilder die nicht in der Content.htm enthalten sind) würden sich eventuell auch die Plugins Extedit_XH (XH 1.7 Kompatibel) bzw. Miniblog_XH (XH 1.7 Kompabilitätstest liegt noch nicht vor) anbieten. Dies dürfte allerdings vom jeweiligen Anwendungsfall abhängen.

Viele Grüße
Hartmut

cmb
Posts: 11886
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Postby cmb » Tue Oct 03, 2017 2:54 pm

Hartmut wrote:Im Pluginmenü sichtbar, beim Anklicken erscheint anstelle der Plugin Startseite mit "Konfiguration", "Sprache", ... eine leere Seite.

Danke! Vermerkt.

Hartmut wrote:NOTICE: Indirect modification of overloaded element of XH\PluginConfig has no effect
/.../plugins/tetris/index.php:231

Autsch! (was ich da für einen Unfug programmiert habe…) Vermerkt.

Hartmut wrote:Synchrone XMLHttpRequests am Haupt-Thread sollte nicht mehr verwendet werden, weil es nachteilige Effekte für das Erlebnis der Endbenutzer hat.

Das betrifft nicht nur XH 1.7.0, sondern ist ein allgemeines Problem von Tetris_XH.

Tetris_XH steht allerdings recht weit unten auf meiner Prioritätsliste. Ich habe die XH 1.7.0 Inkompatibilität vermerkt.

Achim wrote:ist noch geplant, das Plugin COCO_XH an CMSimple_XH 1.7 anzupassen.

Ja, ist geplant. Ich hatte Anfang Mai schon einiges gemacht, bin dann aber am neuen Page-Splitting hängen geblieben, und habe mich geärgert, dass ich mich überzeugen ließ, die Daten nicht direkt in den Page-Data zu speichern (dann wäre hier nämlich nichts zu tun gewesen; so aber muss nun nicht nur auf die neue Variante umgestellt werden, sondern auch noch die Konvertierung programmiert werden).
Christoph M. Becker –Plugins for CMSimple_XH, but not for CMSimple 4+

Hartmut
Posts: 406
Joined: Sat Nov 05, 2011 6:13 pm
Location: Butzbach, Deutschland
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Postby Hartmut » Sun Oct 08, 2017 7:29 pm

Hallo,
hier kommen noch zwei Kompabilittätstests von Plugins unter CMSimple_XH 1.7.0:

Rahmenbedingungen:
Installierte CMSimple Version
CMSimple_XH 1.7.0 Released: 2017-07-02
Installierte Plugins
adc 1.0beta1
Fa 1.1
Feedview 1.0beta1
Filebrowser for CMSimple_XH 1.7.0
Gallery
Hi_updatecheck 1.4
Jquery 1.6.4
Meta_tags for CMSimple_XH 1.7.0
Pagemanager 3.0
Page_params for CMSimple_XH 1.7.0
Tinymce4
Webserver
Apache/2.2.31 (Unix)
PHP-Version
5.6.31
Template
richu 172

Systemprüfung der o.g. Installation:
Bis auf die Meldung "Prüfe, dass die Erweiterung 'intl' geladen ist … Warnung" alles OK.
Die FF Web Console und der CMSimple_XH Debug Modus sind aktiviert.

Ergebnis:
Testergebnis nach der Installation im Plugin Verzeichnis in der oben aufgeführten Testinstallation (FF Webconsole und Debug Modus sind aktiviert):

adc 1.0beta1:
Im Pluginmenü sichtbar, aufrufbar und eine geänderte Konfiguration speicherbar.
Cryptographp_XH wurde nicht in Kombination mit einem anderen Plugin getestet.
CMSimple_XH 1.7 Kompabilität: Ja

Gallery (vom 17.12.2013, Holger Irmler)
Im Pluginmenü sichtbar, beim Anklicken erscheint anstelle der Plugin Startseite mit "Konfiguration", "Sprache", ... eine leere Seite.
CMSimple_XH 1.7 Kompabilität: Nein
Debug Modus:
XH-DEPRECATED: Function initvar() is deprecated
/mnt/web122/e0/76/51287576/htdocs/cms_keil-portal/cmsimplexh17rc1/plugins/gallery/admin.php:25
(Weißer Bildschirm beim anklicken im Plugin-Menü)

Viele Grüße
Hartmut


Return to “Deutsch”

Who is online

Users browsing this forum: olape and 2 guests