Page 1 of 22

Plugin-Kompatibilität zu CMSimple_XH 1.7

Posted: Fri Jul 07, 2017 7:04 am
by Achim
Hallo zusammen,

vielen Dank an die Entwickler für die Weiterentwicklung des CMS. Es ist auch in Ordnung, dass die "alte" Version 1.6 abgekündigt wird.

Allerdings ist es so, dass ein CMS meist nicht nur mit dem Core betrieben wird, sondern einige Plugins verwendet werden. Ein Wechsel von 1.6 auf 1.7 ist aber aufgrund der fehlenden Plugin-Kompabilität oft nicht möglich.

Beispiele: Coco, Flexslider, Pictures

Wie seht ihr das? Wie löst ihr das Problem? Ich vermisse auch eine Übersicht der Plugins, die mit 1.7 kompatibel sind.

Gruß Achim

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Posted: Fri Jul 07, 2017 7:19 am
by Hartmut
Hallo Achim,

eine Übersicht der CMSimple_XH Plugins mit ihrer Kompabilität kann auf der Seite http://cmsimplexh.webdesign-keil.de/?CMSimple_XH_Referenzlisten/Plugins/Kompabilitaet eingesehen werden.

Dort ist beispielsweise das Plugin Flexslider als XH 1.7 kompatibel aufgelistet, aber wenn es bei Dir nicht funktionieren sollte, dann poste dieses Problem bitte hier im Forum, damit Dir geholfen werden kann.

Die Plugin Entwickler sind um eine zeitnahe Bearbeitung bzw. Realisierung der XH 1.7 Version bemüht, aber dazu können sie selbst mehr bzw. besser Auskunft geben.

Viele Grüße
Hartmut

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Posted: Fri Jul 07, 2017 7:23 am
by Achim
Danke für den Link.

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Posted: Fri Jul 07, 2017 9:19 am
by isometric
Könnte man diesen Thread mal oben anpinnen?

Ich suche ihn immer mal wieder, wenn ich kurz schauen will, was schon alles kompatibel ist.

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Posted: Fri Jul 07, 2017 10:38 am
by cmb
Achim wrote:Ein Wechsel von 1.6 auf 1.7 ist aber aufgrund der fehlenden Plugin-Kompabilität oft nicht möglich.

Ja, leider hängt es da noch etwas, gerade auch weil sich niemand mehr um einige der älteren Plugins kümmert. Daher bitte konkret melden, wenn ein Plugin unter XH 1.7 nicht funktioniert, und bitte auch kurz beschreiben, was nicht geht. Dann nimmt sich jemand vielleicht der Sache an.

Achim wrote:Ich vermisse auch eine Übersicht der Plugins, die mit 1.7 kompatibel sind.

Hartmut hat ja bereits den Link zu Kompatibilitätsliste gepostet. Es gibt im Wiki auch eine Seite wo inkompatible Plugins gelistet sind.

Achim wrote:Beispiele: Coco, Flexslider, Pictures

Flexslider 0.5.1 sollte wie erwähnt tatsächlich mit XH 1.7 kompatibel sein (da werden zwar noch viele Notices etc. im Debug-Modus ausgegeben), aber mir scheint alles zu funktionieren.

Coco_XH ist ein bekanntest Problem – leider ist die Umstellung doch etwas aufwändiger als erhofft. Kann also noch etwas dauern.

An Pictures wird leider seit längerem nicht mehr gearbeitet. Auf jeden Fall kann die Pluginadministration unter XH 1.7 nicht mehr aufgerufen werden. Dazu müsste aber nur diese Zeile geändert werden:

Code: Select all

if (function_exists('XH_wantsPluginAdministration') && XH_wantsPluginAdministration('pictures') || isset($pictures)) 


isometric wrote:Könnte man diesen Thread mal oben anpinnen?

Mache ich.

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Posted: Fri Jul 07, 2017 7:02 pm
by Holger
cmb wrote:
isometric wrote:Könnte man diesen Thread mal oben anpinnen?

Mache ich.

Das würde mehr Sinn machen, wenn man auch gleich am Anfang die Infos zum aktuellen Stand bekommen würde. Da es ja bereits Listen gibt, könnte man die Links dazu vielleicht in einem entsprechenden Thread listen und diesen dann (global?) pinnen...

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Posted: Sat Jul 08, 2017 7:16 am
by hixi
Guten Morgen zusammen

Offenbar ist Realblog_XH 3.0beta8 nicht mit CMSimple_XH 1.7 kompatibel. Auf einer unserer Seiten verwenden wir Realblog_XH 3.0beta8. Die Seite, auf der Realblog aufgerufen wird, bleibt leer.

Was können wir tun?

Vielen Dank für die Hilfe und sommerliche Grüsse aus der Schweiz

Beat + Susanne

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Posted: Sat Jul 08, 2017 8:26 am
by Hartmut
hixi wrote:Guten Morgen zusammen

Offenbar ist Realblog_XH 3.0beta8 nicht mit CMSimple_XH 1.7 kompatibel. Auf einer unserer Seiten verwenden wir Realblog_XH 3.0beta8. Die Seite, auf der Realblog aufgerufen wird, bleibt leer.

Was können wir tun?

Vielen Dank für die Hilfe und sommerliche Grüsse aus der Schweiz

Beat + Susanne

Hallo Beat und Susanne,

Realblog_XH 3.0beta8 ist laut Plugin Kopabilitätsliste noch nicht für CMSimple_XH 1.7 "optimiert".
Ich hoffe dass dies cmb bald beheben wird, damit auch diese Lücke bald geschlossen ist.

Viele Grüße
Hartmut

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Posted: Sat Jul 08, 2017 11:35 am
by cmb
hixi wrote:Was können wir tun?

Probiert mal Realblog_XH 3.0beta9; einfach den PATCH herunter laden, und die Installation mit diesen Dateien aktualisieren. Falls irgendwas noch nicht klappt, bitte melden! :)

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Posted: Sat Jul 08, 2017 11:39 am
by cmb
Holger wrote:Das würde mehr Sinn machen, wenn man auch gleich am Anfang die Infos zum aktuellen Stand bekommen würde. Da es ja bereits Listen gibt, könnte man die Links dazu vielleicht in einem entsprechenden Thread listen und diesen dann (global?) pinnen...

Ja, wäre besser. Andererseits hoffe ich, dass die Masse der Inkompatibilitäten möglichst bald ausgeräumt sind, was natürlich noch viel besser wäre. :)