CMSimple_XH 1.7.0

Ein CMSimple Support Forum für deutsch sprechende Nutzer und Entwickler
Post Reply
cmb
Posts: 13272
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: CMSimple_XH 1.7.0

Post by cmb » Sat Jul 08, 2017 2:14 pm

aceaccis wrote:Ja das Thema ist sehr oft in diesem Forum gefallen eine Lösung scheint es jedoch keine zu geben. Ich habe jedenfalls gute Möglichkeiten auf Apache und PHP.ini zugreifen zu können auch die Rechte der einzelnen Dateien passen bzw. die direkte Erreichbarkeit ist nicht möglich. Die .htaccess scheint also zu greifen.
Zuletzt hatten wir das Thema unter https://cmsimpleforum.com/viewtopic.php ... =20#p61074. Per E-Mail sind wir weiter gekommen: Michael verwendete ErrorDocument-Handler, die auf Seiten weiter geleitet haben, die 200 Ok geliefert haben. Dann denkt die Systemprüfung halt, die Seiten seien nicht geschützt. Eventuell ist das bei dir auch der Fall.

Bezüglich session.use_trans_sid siehe https://cmsimpleforum.com/viewtopic.php ... 076#p39548.
aceaccis wrote:mir tut es schon fast Leid das ich mit meinen beschränkten Programmier- Kenntnissen gerade so mir helfen kann und wenig Mitarbeit leisten kann
Das melden von potentiellen Bugs ist doch auch schon eine gute Hilfe. :)
Christoph M. Becker – Plugins for CMSimple_XH

aceaccis
Posts: 71
Joined: Tue May 30, 2017 7:09 am

Re: CMSimple_XH 1.7.0

Post by aceaccis » Mon Jul 10, 2017 3:05 pm

Hallo zusammen,

ich bekomme nun schon in immer kürzer werdenden Abständen folgende Fehlermeldung zu Gesicht.
NOTICE: session_start(): ps_files_cleanup_dir: opendir(/tmp) failed: Permission denied (13)
/kunden/webseite2/cmsimple/functions.php:2670
Fehlen hier Rechte die beim upload verschitt gingen ?

Auftauchen tut diese Meldung meist nach dem Edit Modus aber auch nicht immer .

In diesem Fall war es nach dem editieren der css nach dem drücken des Speichern Buttons kam die Meldung .

Diese tritt eigentlich nicht immer auf aber in letzter Zeit immer öffters.

Im Admin Bereich unter Info erscheint ebenfalls :
WARNING: get_headers(): http:// wrapper is disabled in the server configuration by allow_url_fopen=0
/kunden/webseite2/cmsimple/adminfuncs.php:196
WARNING: get_headers(): This function may only be used against URLs
/kunden/webseite2/cmsimple/adminfuncs.php:196
Danke und Gruß

Chris
Chris S. aus B
Hoster: df.eu
Domains: 25 an der Zahl
CMS: CMSimple_XH, jeweils 1.6.10 und nun 1.7.0

cmb
Posts: 13272
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: CMSimple_XH 1.7.0

Post by cmb » Mon Jul 10, 2017 4:21 pm

aceaccis wrote:ich bekomme nun schon in immer kürzer werdenden Abständen folgende Fehlermeldung zu Gesicht.
NOTICE: session_start(): ps_files_cleanup_dir: opendir(/tmp) failed: Permission denied (13)
/kunden/webseite2/cmsimple/functions.php:2670
Das sieht mir ganz danach aus, dass der session.save_path nicht richtig konfiguriert ist, oder dass eben dem PHP-User für den eingestellten Pfad keine Ausführungsrechte gewährt wurden. Das sollte der Provider eigentlich für dich schon korrekt vorbereitet haben.
aceaccis wrote:Im Admin Bereich unter Info erscheint ebenfalls :
WARNING: get_headers(): http:// wrapper is disabled in the server configuration by allow_url_fopen=0
/kunden/webseite2/cmsimple/adminfuncs.php:196
WARNING: get_headers(): This function may only be used against URLs
/kunden/webseite2/cmsimple/adminfuncs.php:196
Siehe https://github.com/cmsimple-xh/cmsimple ... -289217708. Ist bei dir die cURL Extension verfügbar (siehe Einstellungen → Info → PHP-Info)?
Christoph M. Becker – Plugins for CMSimple_XH

pergachris
Posts: 177
Joined: Fri Aug 31, 2012 9:28 pm
Location: Hemden (NRW)

Re: CMSimple_XH 1.7.0

Post by pergachris » Mon Jul 10, 2017 9:59 pm

Hallo,

heute habe ich versucht weitere Projekte auf 1.7.x zu ändern. Quasi ein Neuaufbau mit aktualisierten Plugins aber mit altem Template.
Das sieht für den Anfang schon gut aus.

Eine Kopie davon habe ich dann bei einem anderen Hoster hochgeladen.
Tja, und da bemerkte ich dann ein Problem:
Die Toolbar beim tinymce4 ist nicht sichtbar bzw. nicht da.

Ich habe dann hin und her kopiert und die Tempates getauscht.
Irgendwie komme ich nun nicht weiter.

Liegt das am Hoster? Die Vermutung habe ich, aber auf was muss ich da achten? Beide laufen auf php5.6

cmb
Posts: 13272
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: CMSimple_XH 1.7.0

Post by cmb » Mon Jul 10, 2017 11:11 pm

pergachris wrote:Die Toolbar beim tinymce4 ist nicht sichtbar bzw. nicht da.
Ich vermute, dass auch der eigentliche Bearbeitungsbereich nicht wirklich der des TinyMCE ist (z.B. zeigt das Kontextmenü nur allgemeine Browser-Features an, nicht aber diejenigen des TinyMCE), sondern eine einfache Textarea. Das läge dann vermutlich daran, dass entweder ein Script nicht geladen werden kann, oder ein JavaScript-Fehler auftrat. Die Browserkonsole (F12) sollte in diesem Fall eine hoffentlich aufschlussreiche Fehlermeldung enthalten. Also schau dort bitte mal nach.
Christoph M. Becker – Plugins for CMSimple_XH

pergachris
Posts: 177
Joined: Fri Aug 31, 2012 9:28 pm
Location: Hemden (NRW)

Re: CMSimple_XH 1.7.0

Post by pergachris » Tue Jul 11, 2017 4:31 am

cmb wrote: Die Browserkonsole (F12) sollte in diesem Fall eine hoffentlich aufschlussreiche Fehlermeldung enthalten. Also schau dort bitte mal nach.
Ja, da findet sich was:
SyntaxError: expected expression, got ';'[Weitere Informationen]
ReferenceError: wrFilebrowser is not defined[Weitere Informationen]


Aber mir sagt das nichts.

aceaccis
Posts: 71
Joined: Tue May 30, 2017 7:09 am

Re: CMSimple_XH 1.7.0

Post by aceaccis » Tue Jul 11, 2017 8:46 am

Hi,
aceaccis hat geschrieben:
Im Admin Bereich unter Info erscheint ebenfalls :

WARNING: get_headers(): http:// wrapper is disabled in the server configuration by allow_url_fopen=0
/kunden/webseite2/cmsimple/adminfuncs.php:196
WARNING: get_headers(): This function may only be used against URLs
/kunden/webseite2/cmsimple/adminfuncs.php:196
Siehe https://github.com/cmsimple-xh/cmsimple ... -289217708. Ist bei dir die cURL Extension verfügbar (siehe Einstellungen → Info → PHP-Info)?
also an cURL kann es nicht liegen diese ist vorhanden.


cURL support enabled
cURL Information 7.37.1

Danke und Gruß

Chris
Chris S. aus B
Hoster: df.eu
Domains: 25 an der Zahl
CMS: CMSimple_XH, jeweils 1.6.10 und nun 1.7.0

cmb
Posts: 13272
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: CMSimple_XH 1.7.0

Post by cmb » Tue Jul 11, 2017 10:58 am

pergachris wrote:
cmb wrote: Die Browserkonsole (F12) sollte in diesem Fall eine hoffentlich aufschlussreiche Fehlermeldung enthalten. Also schau dort bitte mal nach.
Ja, da findet sich was:
SyntaxError: expected expression, got ';'[Weitere Informationen]
ReferenceError: wrFilebrowser is not defined[Weitere Informationen]
Aha! Jetzt wären wohl die "[Weitere Informationen]" hilfreich, also in welcher Zeile welchen Scripts die Fehler auftreten, und wie diese Zeilen lauten. Gerade der Syntax-Error könnte direkt im ausgegeben HTML-Quellcode sein; da wäre es gut, wenn du ein paar Zeilen drumherum hier posten könntest. Oder schick mir URL und (vorübergehend geändertes) Admin-Passwort per PN; dann kann ich es mir live mal anschauen.
aceaccis wrote:also an cURL kann es nicht liegen diese ist vorhanden.
Gut. Ich fragte nur, weil wir einen Fallback auf eine cURL Lösung anbieten könnten, was natürlich nur hilft, wenn dann cURL auch verfügbar ist. Konkret dazu melde ich mich später noch.
Christoph M. Becker – Plugins for CMSimple_XH

pergachris
Posts: 177
Joined: Fri Aug 31, 2012 9:28 pm
Location: Hemden (NRW)

Re: CMSimple_XH 1.7.0

Post by pergachris » Tue Jul 11, 2017 1:20 pm

cmb wrote: Aha! Jetzt wären wohl die "[Weitere Informationen]" hilfreich, also in welcher Zeile welchen Scripts die Fehler auftreten, und wie diese Zeilen lauten. Gerade der Syntax-Error könnte direkt im ausgegeben HTML-Quellcode sein; da wäre es gut, wenn du ein paar Zeilen drumherum hier posten könntest.
Hallo,
ich habe heute die ganze Zeit herumexperimentiert. Ein nach dem anderen Plugin gelöscht. Seite für Seite gelöscht. Ich habe es dann irgendwann eigegrenzt bekommen.

Das Problem war (so vermute ich nun), ein pdf-file im Ordner "userfiles/download", welches in seinem Namen den Buchstaben "ü" hatte.
Nach dem Ändern un "ue" war das Problem weg.

cmb
Posts: 13272
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: CMSimple_XH 1.7.0

Post by cmb » Tue Jul 11, 2017 1:44 pm

pergachris wrote:Das Problem war (so vermute ich nun), ein pdf-file im Ordner "userfiles/download", welches in seinem Namen den Buchstaben "ü" hatte.
Nach dem Ändern un "ue" war das Problem weg.
Ja, das klingt plausibel. Der TinyMCE legt eine Linkliste an und da werden auch alle Dateien in userfiles/download/ hinzugefügt. Dabei ignoriert der TinyMCE die Zeichen-Kodierung, und wenn ungültiges UTF-8 vorliegt, dann wird fehlerhaftes JavaScript erzeugt.

Ich denke, CMSimple_XH sollte wenigstens eine Funktion zur Verfügung stellen, die Dateinamen nach UTF-8 konvertiert, und eine weitere für die umgekehrte Konvertierung, vermutlich in Verbindung mit einer Konfigurationsoption, in der das Encoding des Dateisystems eingestellt werden muss. Raten ist hier immer ein bisschen heikel. Siehe https://github.com/cmsimple-xh/cmsimple-xh/issues/272.
Christoph M. Becker – Plugins for CMSimple_XH

Post Reply