PHP-Upgrade CMSimple_XH 1.6.7

Ein CMSimple Support Forum für deutsch sprechende Nutzer und Entwickler
Post Reply
Lariss
Posts: 159
Joined: Thu Dec 16, 2010 8:32 am

PHP-Upgrade CMSimple_XH 1.6.7

Post by Lariss » Sun Mar 06, 2016 11:22 am

Hallo Community,
ich habe zwei Websites, die bereits als CMSimple_XH 1.6.7 laufen.
Gestern haben wir ein Email vom Serverbetreiber bekommen:

"Auf unserem Server ist bisher die PHP Version 5.3 vorinstalliert. Da
diese Version aber bereits seit längerem nicht mehr mit Sicherheitsupdates
versorgt wird, müssen wir die PHP Version auf 5.6 upgraden. Dieses Upgrade wird am 2. Mai 2016 durchgeführt.
Bitte überprüfen Sie die Programmierung Ihrer Internetseiten dahingehend ob
diese auch mit der neuen PHP Version kompatibel ist. Gegebenenfalls müssen
Sie auch ein Update Ihres Content-Management-Systems durchführen damit Ihre
Internetseiten auch weiterhin funktionieren."


Die PHP-Version auf CMSimple_XH 1.6.7 ist 5.3.29. und meine beiden Websites sind dovon getroffen.

Meine Frage ist, wie geht’s weiter mit CMSimple_XH PHP-Upgrade?
Gruß Sam

Hartmut
Posts: 536
Joined: Sat Nov 05, 2011 6:13 pm
Location: Butzbach, Deutschland
Contact:

Re: PHP-Upgrade CMSimple_XH 1.6.7

Post by Hartmut » Sun Mar 06, 2016 12:15 pm

Hallo Lariss,

Du kannst CMSimple_XH 1.6.7 problemlos auch mit PHP 5.6 betreiben.
Ich habe CMSimple_XH 1.6.7 in einer Grundinstallation testweise auch mit PHP 7 betrieben und da sind mir auch keine Fehler aufgefallen.

Du brauchst also CMSimple_XH nicht updaten und wenn Du möchtest kannst Du in der Adminstrationsoberfläche deines Providers auf z.B. PHP 5.6 umstellen.

Viele Grüße
Hartmut

Lariss
Posts: 159
Joined: Thu Dec 16, 2010 8:32 am

Re: PHP-Upgrade CMSimple_XH 1.6.7

Post by Lariss » Sun Mar 06, 2016 12:46 pm

Hallo Hartmut,
besten Dank für deine Antwort.
Das ist natürlich eine gute Nachricht, dass die Websites problemlos auf neue PHP-Version weiterhin laufen werden :D . Das dumme ist bei uns, dass der Serverbetreiber ein städtischer Server ist, wo wir als Kunde kein Zugangsrecht auf Administration haben.
Gruß Sam

Michael_G
Posts: 86
Joined: Thu Feb 18, 2016 11:01 pm

Re: PHP-Upgrade CMSimple_XH 1.6.7

Post by Michael_G » Mon Mar 07, 2016 10:21 am

Hallo Lariss,

auch ich kann Dich da beruhigen.
Mein CMSimple_XH v1.6.7 lief von Anfang an mit PHP 5.6.irgendwas und weil alle eingesetzten Plug-ins für PHP 7.0 geeignet sind, hatte ich etwa vorletzte Woche meine kleine Website (26 Seiten) auf PHP 7.0.3 umgestellt und weil die ohne Probleme lief, letzten Freitag auch meine große Website (mit über 700 Seiten) darauf umgestellt (sicherheitshalber mehrfaches Backup auf verschiedene Datenträger).

Wenn Du darauf achtest, nur für PHP 7.0 geeignete Plug-ins zu installieren, ist Deine Website zukunftssicher, denn wer als Entwickler jetzt schon auf Lauffähigkeit mit PHP 7.0 testet, wird wohl generell auf aktuelles PHP achten und immer regelmäßig aktualisieren.
Ist keine Garantie, aber größere Sicherheit als wenn das jemand nicht mit angibt und die Version schon länger nicht mehr aktualisiert wurde.
Ciao
Michael

Lariss
Posts: 159
Joined: Thu Dec 16, 2010 8:32 am

Re: PHP-Upgrade CMSimple_XH 1.6.7

Post by Lariss » Tue Mar 15, 2016 1:14 pm

Hallo Michael,
danke für deinen Hinweis. Das werden ich mir merken.
Gruß Sam

Post Reply