Plugin-Kompatibilität zu CMSimple_XH 1.7

Ein CMSimple Support Forum für deutsch sprechende Nutzer und Entwickler
cmb
Posts: 12036
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Postby cmb » Tue Dec 05, 2017 10:15 pm

Hartmut wrote:Test Plugin Imgzoom_XH Version: 1.0 beta2

Plugin im Admin-Menü aufrufbar? => Nein (leere Seite)

Danke. Das hatte ich im master schon vor langem gefixt – wird Zeit für ein neues Release.
Christoph M. Becker –Plugins for CMSimple_XH, but not for CMSimple 4+

Hartmut
Posts: 463
Joined: Sat Nov 05, 2011 6:13 pm
Location: Butzbach, Deutschland
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Postby Hartmut » Wed Dec 06, 2017 8:38 pm

cmb wrote:
Hartmut wrote:Test Plugin Imgzoom_XH Version: 1.0 beta2

Plugin im Admin-Menü aufrufbar? => Nein (leere Seite)

Danke. Das hatte ich im master schon vor langem gefixt – wird Zeit für ein neues Release.


Ich würde mich über ein Release freuen, damit der CMSimple_XH Anwender ein weiteres Plugin für Bilder zur Verfügung hat. ;-)
Ich habe mir schon überlegt für die Plugins mit einem Workaround für CMSimple_XH 1.7.x eine temporär gepatchte Version mit reingebastelten XH 1.7 Workaround im Downloadbereich anzubieten. Dann müssten die Anwender nicht zu lange auf eine funktionsfähige XH 1.7 Version warten und vor allem müssen sie nicht selbt den Workaround "reinbasteln" , was aus meiner Sicht nicht gerade Anwenderfreundlich ist.

Viele Grüße
Hartmut

Hartmut
Posts: 463
Joined: Sat Nov 05, 2011 6:13 pm
Location: Butzbach, Deutschland
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Postby Hartmut » Wed Dec 06, 2017 8:38 pm

Test Plugin Chess_XH Version: 1.0 beta2

Getestet lokal unter
Xampp
PHP-Version 7.1.1
CMSimple_XH 1.7.1
Template fhs-simple

Plugin in der Sytem-Info sichtbar? => Chess 1.0beta2
Plugin im Admin-Menü sichtbar? => Ja
Plugin im Admin-Menü aufrufbar? => Nein (leere Seite)
Plugin Konfiguration / Sprache änderbar und speicherbar? => Nein (Plugin Konfigurationsseiten nicht sichtbar)
Plugin Aufruf auf der Seite: Nicht getestet
Plugin Aufruf im Template: Nicht getestet

Xampp-Fehlermeldungen: Nein
Debug-Meldung: Nein

Ergebnis:
CMSimple_XH 1.6 Kompatibilität: Ja
CMSimple_XH 1.7 Kompatibilität: Nein
PHP 7.0 Kompatibilität: ?? (vermutl. Ja, aber nicht testbar da o.g. Fehler)
PHP 7.1 Kompatibilität: ?? (vermutl. Ja, aber nicht testbar da o.g. Fehler)

Hartmut
Posts: 463
Joined: Sat Nov 05, 2011 6:13 pm
Location: Butzbach, Deutschland
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Postby Hartmut » Wed Dec 06, 2017 8:50 pm

Test Plugin Facebook_XH Version: 1.0Beta3

Getestet lokal unter
Xampp
PHP-Version 7.1.1
CMSimple_XH 1.7.1
Template fhs-simple

Plugin in der Sytem-Info sichtbar? => Ja, Facebook 1.0beta3
Plugin im Admin-Menü sichtbar? => Ja
Plugin im Admin-Menü aufrufbar? => Nein (leere Seite)
Plugin Konfiguration / Sprache änderbar und speicherbar? => Nein (Plugin Konfigurationsseiten nicht sichtbar)
Plugin Aufruf auf der Seite: Nicht getestet
Plugin Aufruf im Template: Nicht getestet

Xampp-Fehlermeldungen: Nein
Debug-Meldung: Nein

Ergebnis:
CMSimple_XH 1.6 Kompatibilität: Ja
CMSimple_XH 1.7 Kompatibilität: Nein
PHP 7.0 Kompatibilität: ?? (vermutl. Ja, aber nicht testbar da o.g. Fehler)
PHP 7.1 Kompatibilität: ?? (vermutl. Ja, aber nicht testbar da o.g. Fehler)

Hartmut
Posts: 463
Joined: Sat Nov 05, 2011 6:13 pm
Location: Butzbach, Deutschland
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Postby Hartmut » Thu Dec 07, 2017 8:48 pm

Test Plugin gbookplus Version: gbookplus 2010

Getestet lokal unter
Xampp
PHP-Version 7.1.1
CMSimple_XH 1.7.1
Template fhs-simple

Plugin in der Sytem-Info sichtbar? => Ja, Gbookplus
Plugin im Admin-Menü sichtbar? => Ja
Plugin im Admin-Menü aufrufbar? => Nein (leere Seite)
Plugin Konfiguration / Sprache änderbar und speicherbar? => Nein (Plugin Konfigurationsseiten nicht sichtbar)
Plugin Aufruf auf der Seite: Nicht getestet
Plugin Aufruf im Template: Nicht getestet

Xampp-Fehlermeldungen: Nein
Debug-Meldung: Nein

Ergebnis:
CMSimple_XH 1.6 Kompatibilität: Ja
CMSimple_XH 1.7 Kompatibilität: Nein
PHP 7.0 Kompatibilität: ?? (vermutl. Ja, aber nicht testbar da o.g. Fehler)
PHP 7.1 Kompatibilität: ?? (vermutl. Ja, aber nicht testbar da o.g. Fehler)

Hartmut
Posts: 463
Joined: Sat Nov 05, 2011 6:13 pm
Location: Butzbach, Deutschland
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Postby Hartmut » Fri Dec 08, 2017 6:23 pm

Test Plugin hi_Shutter_Reloaded Version: 1.0

Getestet lokal unter
Xampp
PHP-Version 7.1.1
CMSimple_XH 1.7.1
Template fhs-simple

Plugin in der Sytem-Info sichtbar? => Ja, Hi_shutter_reloaded v. 1.0
Plugin im Admin-Menü sichtbar? => Ja
Plugin im Admin-Menü aufrufbar? => Nein, leere Seite
Plugin Konfiguration / Sprache änderbar und speicherbar? => Nein (Plugin Konfigurationsseiten nicht sichtbar)
Plugin Aufruf auf der Seite: Nicht getestet
Plugin Aufruf im Template: Nicht getestet

Xampp-Fehlermeldungen: Nein
Debug-Meldung: Ja, dauerhafte Anzeige:
XH-DEPRECATED: Function initvar() is deprecated
C:\xampp\htdocs\plugins\hi_shutter_reloaded\admin.php:34

Ergebnis:
CMSimple_XH 1.6 Kompatibilität: Ja
CMSimple_XH 1.7 Kompatibilität: Nein
PHP 7.0 Kompatibilität: ?? (vermutl. Ja, aber nicht testbar da o.g. Fehler)
PHP 7.1 Kompatibilität: ?? (vermutl. Ja, aber nicht testbar da o.g. Fehler)

Hartmut
Posts: 463
Joined: Sat Nov 05, 2011 6:13 pm
Location: Butzbach, Deutschland
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Postby Hartmut » Fri Dec 08, 2017 7:15 pm

Test Plugin Ipban_XH Version: 1 beta2

Getestet lokal unter
Xampp
PHP-Version 7.1.1
CMSimple_XH 1.7.1
Template fhs-simple

Plugin in der Sytem-Info sichtbar? => Ja, Ipban
Plugin im Admin-Menü sichtbar? => Ja
Plugin im Admin-Menü aufrufbar? => Nein, leere Seite
Plugin Konfiguration / Sprache änderbar und speicherbar? => Nein (Plugin Konfigurationsseiten nicht sichtbar)
Plugin Aufruf auf der Seite: Nicht getestet
Plugin Aufruf im Template: Nicht getestet

Xampp-Fehlermeldungen: Nein
Debug-Meldung: Nein

Ergebnis:
CMSimple_XH 1.6 Kompatibilität: Ja
CMSimple_XH 1.7 Kompatibilität: Nein
PHP 7.0 Kompatibilität: ?? (vermutl. Ja, aber nicht testbar da o.g. Fehler)
PHP 7.1 Kompatibilität: ?? (vermutl. Ja, aber nicht testbar da o.g. Fehler)

Hartmut
Posts: 463
Joined: Sat Nov 05, 2011 6:13 pm
Location: Butzbach, Deutschland
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Postby Hartmut » Fri Dec 08, 2017 7:37 pm

Test Plugin Pdeditor_XH Version: 1.0

Getestet lokal unter
Xampp
PHP-Version 7.1.1
CMSimple_XH 1.7.1
Template fhs-simple

Plugin in der Sytem-Info sichtbar? => Ja, Pdeditor 1.0
Plugin im Admin-Menü sichtbar? => Ja
Plugin im Admin-Menü aufrufbar? => Ja
Plugin Stylesheet / Sprache / Pagedata änderbar und speicherbar? => Ja

Xampp-Fehlermeldungen: Nein
Debug-Meldung: Nein

Ergebnis:
CMSimple_XH 1.6 Kompatibilität: Ja
CMSimple_XH 1.7 Kompatibilität: Ja
PHP 7.0 Kompatibilität: Ja
PHP 7.1 Kompatibilität: Ja

Hartmut
Posts: 463
Joined: Sat Nov 05, 2011 6:13 pm
Location: Butzbach, Deutschland
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Postby Hartmut » Fri Dec 08, 2017 9:06 pm

Test Plugin PluginInstallerXH Version: 1.0 RC2

Getestet lokal unter
Xampp
PHP-Version 7.1.1
CMSimple_XH 1.7.1
Template fhs-simple

Plugin in der Sytem-Info sichtbar? => Ja, PluginInstallerXH 1.0 RC2
Plugin im Admin-Menü sichtbar? => Ja
Plugin im Admin-Menü aufrufbar? => Ja
Plugin Konfiguration / Sprache änderbar und speicherbar? => Ja
Plugin Aufruf "hinzufügen/löschen von Plugins/Templates" im Admin-Bereich:
Plugin löschen: Funktioniert fehlerfrei


Xampp-Fehlermeldungen: Nein
Debug-Meldung: Ja:
Beim Aufruf von "löschen von Plugins":
Das Plugin wird gelöscht.
Debug-Modus Meldungen:
NOTICE: Undefined index: plugintodelete
C:\xampp\htdocs\plugins\PluginInstallerXH\core.php:80
NOTICE: Undefined index: templatetodelete
C:\xampp\htdocs\plugins\PluginInstallerXH\core.php:95
Beim Aufruf von "hinzufügen von Plugins" (Debug-Modus):
Das Plugin wird nicht installiert (Es wird nur das Verzeichnis angelegt).
Debug-Modus Meldungen:
NOTICE: Undefined index: plugintodelete
C:\xampp\htdocs\plugins\PluginInstallerXH\core.php:80
NOTICE: Undefined index: templatetodelete
C:\xampp\htdocs\plugins\PluginInstallerXH\core.php:95
DEPRECATED: Methods with the same name as their class will not be constructors in a future version of PHP; PclZip has a deprecated constructor
C:\xampp\htdocs\plugins\PluginInstallerXH\pclzip.lib.php:190
NOTICE: A non well formed numeric value encountered
C:\xampp\htdocs\plugins\PluginInstallerXH\pclzip.lib.php:1845

Ergebnis:
CMSimple_XH 1.6 Kompatibilität: Ja
CMSimple_XH 1.7 Kompatibilität: ??
PHP 7.0 Kompatibilität: ??
PHP 7.1 Kompatibilität: ??
Weitere Anmerkungen:
Eine weitere Kompabilitätsprüfung erfolgt nach der Bereinigung der Fehler im Plugin

cmb
Posts: 12036
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Plugin-Kompatibilität zu CMSimple_XH 1.7

Postby cmb » Fri Dec 08, 2017 10:54 pm

Hartmut wrote:Test Plugin Ipban_XH Version: 1 beta2

Uff, das gibt's ja auch noch! Ich persönlich fand das Plugin schon immer fraglich, und stelle daher auch aus Zeitgründen die Entwicklung ein (habe ich auf der Projektseite bereits vermerkt).
Christoph M. Becker –Plugins for CMSimple_XH, but not for CMSimple 4+


Return to “Deutsch”

Who is online

Users browsing this forum: No registered users and 2 guests