Plugin Compatibility with PHP 8

Third Party Plugins to CMSimple - how to install, use and create plugins

Moderator: Tata

Hartmut
Posts: 553
Joined: Sat Nov 05, 2011 6:13 pm
Location: Butzbach, Deutschland
Contact:

Re: Plugin Compatibility with PHP 8

Post by Hartmut » Sun Feb 05, 2023 5:35 pm

frase wrote:
Sun Feb 05, 2023 1:11 pm
Hallo Hartmut,
ich habe gerade nochmal einen neuen Test mit dem aktuellen Master gestartet – und da sind alle beschriebenen Probleme behoben.
Das gilt sowohl für PHP 7.4.2 als auch für PHP 8.2.0

Du könntest ja mal dein momentan aktives Teaser-Plugin deaktivieren (einfach vor den Ordnernamen einen Punkt setzen = „.teaser“).
Dann könntest du den heruntergeladenen Ordner „teaser-master“ in deinen Plugin-Ordner kopieren und umbenennen zu „teaser“.
Normalerweise (Standard-Einstellungen) liegen die Teaser-Daten (*.txt) im Ordner „\userfiles\plugins\teaser\“.
Falls das bei dir anders konfiguriert war, dann musst du die Konfiguration noch ändern und den Ordner an die entsprechende Stelle kopieren.
Theoretisch sollte bei dieser Aktion nichts zerstört werden. Das hoffe ich zumindest.
Damit könnten wir vielleicht herausfinden, ob es nun in Ordnung ist, oder ob bei mir etwas nicht stimmt.
Hallo Frank,

das Teaser Thema gestaltet sich etwas zäh. ;-)

Master installiert, altes Plugin deaktiviert, Master umbenannt.

8.0.27:
Anwendersicht OK
Admin:
Plugin Aufruf OK
Teaserseite 1 mit Text füllen + speichern: => OK
Teaserseite 2 hinzufügen (über Button): OK ("Tab 2" als Button neben "Tab 1" sichtbar.)
Teaserseite 2 über Button "Tab 2" auswählen: => Whitescreen + Fehlermeldung:
Uncaught TypeError: Unsupported operand types: string - int in /mnt/.../plugins/teaser/admin.php:259
Stack trace:
#0 /mnt/.../cmsimple/cms.php(1123): include()
#1 /mnt/.../index.php(6): include('...')
#2 {main}
thrown in /mnt/.../plugins/teaser/admin.php on line 259

PHP 7.4.33:
Anwendersicht OK
Admin:
Teaserseite 1 mit Text füllen + speichern: => OK
Teaserseite 2 hinzufügen (über Button): OK ("Tab 2" als Button neben "Tab 1" sichtbar.)
Teaserseite 2 über Button "Tab 2" auswählen: => Whitescreen + Fehlermeldung:

Was mir aufgefallen ist:
Bei der Masterversion gibt es keine config/config.php mehr und wir testen wohl in unterschiedlichen PHP 7 bzw. 8 Versionen.

cmb
Posts: 14225
Joined: Tue Jun 21, 2011 11:04 am
Location: Bingen, RLP, DE
Contact:

Re: Plugin Compatibility with PHP 8

Post by cmb » Sun Feb 05, 2023 6:53 pm

Hartmut wrote:
Sun Feb 05, 2023 5:35 pm
Master installiert, altes Plugin deaktiviert, Master umbenannt.
Wirklich den aktuellen Entwicklungsstand?`Das wäre zur Zeit https://github.com/cmsimple-xh/teaser/a ... 29a89f.zip.
Hartmut wrote:
Sun Feb 05, 2023 5:35 pm
Bei der Masterversion gibt es keine config/config.php mehr, […]
Das ist normal; die Datei wird bei der Aktivierung des Plugins erzeugt.
Hartmut wrote:
Sun Feb 05, 2023 5:35 pm
[…] und wir testen wohl in unterschiedlichen PHP 7 bzw. 8 Versionen.
Frank testet vermutlich mit PHP 8.2, aber das sollte sich mit PHP 8.0 nicht viel nehmen, was die Probleme angeht.
Christoph M. Becker – Plugins for CMSimple_XH

frase
Posts: 5085
Joined: Thu Apr 21, 2016 6:32 am
Location: Saxony
Contact:

Re: Plugin Compatibility with PHP 8

Post by frase » Sun Feb 05, 2023 6:54 pm

Hartmut wrote:
Sun Feb 05, 2023 5:35 pm
das Teaser Thema gestaltet sich etwas zäh. ;-)
Ja, leider. Worauf habe ich mich da bloß wieder eingelassen … ;)
Hartmut wrote:
Sun Feb 05, 2023 5:35 pm
Was mir aufgefallen ist:
Bei der Masterversion gibt es keine config/config.php mehr und wir testen wohl in unterschiedlichen PHP 7 bzw. 8 Versionen.
Das ist, soweit ich es verstehe, von Svasti so gewollt.
Ruft man das Plugin im Adminmodus zum ersten Mal auf, dann sollte ein ziemlich auffälliger Hinweis erscheinen:
Nicht aktiviertes Plugin!
Hier klicken zum Aktivieren
Klickt man nun, dann wird eine config.php angelegt.
Warum und wieso das so ist? Keine Ahnung.

frase
Posts: 5085
Joined: Thu Apr 21, 2016 6:32 am
Location: Saxony
Contact:

Re: Plugin Compatibility with PHP 8

Post by frase » Sun Feb 05, 2023 6:56 pm

cmb wrote:
Sun Feb 05, 2023 6:53 pm
Frank testet vermutlich mit PHP 8.2, aber das sollte sich mit PHP 8.0 nicht viel nehmen, was die Probleme angeht.
Ich testete mit PHP 7.4.2 UND mit PHP 8.2.0.
In beiden Varianten funktioniert der Master wie erwartet ohne Whitescreen.

cmb
Posts: 14225
Joined: Tue Jun 21, 2011 11:04 am
Location: Bingen, RLP, DE
Contact:

Re: Plugin Compatibility with PHP 8

Post by cmb » Sun Feb 05, 2023 7:40 pm

frase wrote:
Sun Feb 05, 2023 6:54 pm
Klickt man nun, dann wird eine config.php angelegt.
Warum und wieso das so ist? Keine Ahnung.
Einfacheres Update, besonders bevor defaultconfig.php eingeführt wurde. Und hinter den Kulissen kann bei Bedarf die bestehende Konfiguration noch angepasst werden. Eigentlich ganz nett, aber m.E. viel zu aufwendig, wenn man das bei jedem Plugins selbst machen will. Mir genügt defaultconfig.php vollkommen.
frase wrote:
Sun Feb 05, 2023 6:56 pm
Ich testete mit PHP 7.4.2 UND mit PHP 8.2.0.
In beiden Varianten funktioniert der Master wie erwartet ohne Whitescreen.
:D
Christoph M. Becker – Plugins for CMSimple_XH

Hartmut
Posts: 553
Joined: Sat Nov 05, 2011 6:13 pm
Location: Butzbach, Deutschland
Contact:

Re: Plugin Compatibility with PHP 8

Post by Hartmut » Sun Feb 05, 2023 7:56 pm

So, jetzt funktioniert "Teaser" fehlerfrei unter PHP 7.4 + 8.0. :D
(Pluginaufruf, Auswahl TXT-Datei, Auswahl verschiedener Teaserboxen, Änderung Content in Teaserbox)

Bei mir war die Masterversion vom 0‎4.02.‎2023, ‏‎16:03:30 und nicht vom 0‎4.02.‎2023, ‏‎18:16:14 installiert gewesen. => die Version von ‏‎18:16:14 installiert.

Die Datei config/config.php wurde nicht angelegt da die Meldung "Bitte Plugin aktivieren" bei den letzten Neuinstallationen nicht angezeigt worden ist. => manuell aus der Sicherung ins Serververzeichnis kopiert.

In die css/stylesheet.css die selbstgestylten Teaserboxen aus der Sicherung reinkopiert.

Weiterhin den Cache von den Browsern gelöscht und Browser neu gestartet.

Herzlichen Dank für eure Mühe und Hilfe.
Viele Grüße
Hartmut

mhz
Posts: 676
Joined: Tue Jun 25, 2013 8:46 pm
Location: Heusenstamm, Hessen
Contact:

Re: Plugin Compatibility with PHP 8

Post by mhz » Mon Feb 20, 2023 6:56 pm

Hallo zusammen,
bei mir funktionieren diese Plugins unter der PHP-Version 8.2.2:
Boilerplate 2.0
Downloadcontrol_XH 1.7.1
Downloadcontrol_XH 1.7.2
Expandcontract 1.0
Fa 1.3
Flipimage
Maintenance_XH Version 2.0-rc.1
Pfw 0.2.0
Privacy 1.0beta3
Simpleplugins_xh
Slideshow 1.3
Switchdebug 1.0rc1
Video_XH Version 2.0
Wdir 1.1 von cmb

Gruß Michael
Michael Zajusch (mhz)-- Mein Tutorial für CMSimple_XH. Früher

cmb
Posts: 14225
Joined: Tue Jun 21, 2011 11:04 am
Location: Bingen, RLP, DE
Contact:

Re: Plugin Compatibility with PHP 8

Post by cmb » Wed Mar 01, 2023 10:31 am

mhz wrote:
Mon Feb 20, 2023 6:56 pm
bei mir funktionieren diese Plugins unter der PHP-Version 8.2.2:
Danke! Habe ich in die Liste oben integriert (ich gehe davon aus, dass Plugins, die mit PHP 8.2 kompatibel sind, auch unter PHP 8.0 und 8.1 funktionieren).
Christoph M. Becker – Plugins for CMSimple_XH

doczimut
Posts: 126
Joined: Thu Dec 25, 2008 1:10 pm
Location: Normandy (France)

Re: Plugin Compatibility with PHP 8 (jm landing page)

Post by doczimut » Thu Mar 02, 2023 8:14 am

Hello
With the plugin jm landing page by cmsimple.sk and PHP 8.2, I have the error message:

Uncaught ArgumentCountError: define() expects at least 2 arguments, 1 given in \plugins\jm_landingpage\admin.php:12
Stack trace:
#0 \plugins\jm_landingpage\admin.php(12): define('jm_landingpage')
#1 \cmsimple\cms.php(1123): include('...')
#2 /index.php(6): include('...')
#3 {main} vthrown in \plugins\jm_landingpage\admin.php on line 12

Line 12 contains: define('jm_landingpage'); and obviously asks for 2 arguments. Error not apparent with PHP 7.4.
Is there a solution? Even if the plugin seems abandoned.

olape
Posts: 2695
Joined: Fri Mar 13, 2015 8:47 am
Contact:

Re: Plugin Compatibility with PHP 8

Post by olape » Thu Mar 02, 2023 10:47 am

doczimut wrote:
Thu Mar 02, 2023 8:14 am
Line 12 contains: define('jm_landingpage');
Hm, when I download the plugin, line 12 says:

Code: Select all

define('jm_landingpage', '1beta01');
And that should have been it.
Either you have a newer or older version than the one offered for download.
Gruß Olaf, Plugins for CMSimple_XH

Ich habe schon lange den Verdacht, dass so viele so eifrig auf Gender, Trans und Queer machen:
Weil sie für das Fachliche ganz einfach zu doof sind.

Post Reply