fotorama

Third Party Plugins to CMSimple - how to install, use and create plugins

Moderator: Tata

pergachris
Posts: 160
Joined: Fri Aug 31, 2012 9:28 pm
Location: Hemden (NRW)

fotorama

Postby pergachris » Wed Jul 12, 2017 7:14 am

Hallo,

bislang habe ich gerne "Pictures" von David Stutz verwendet. Unter 1.7.x scheint mir eine Alternative sinnvoll zu sein.

Da bin ich nun auf "Fotorama" gestoßen.

Es geht mir um das <gallery> Element, dem man weitere Attribute zufügen kann: width, ratio, nav, fullscreen, transition

Wäre es möglich in einer zukünftigen Version das unter Konfiguration anzubieten?

Im Moment ist es so, dass ich immer die gleichen Attribute verwende. Da bin ich glücklicherweise auf die Stelle gestoßen, wo der xml generiert wird:
Unter fotorama/classes/CreateGalleryCommand.php

Ich habe dort Zeile 41 erweitert.

Code: Select all

. '<gallery path="' . $path . '" width="100%" ratio="4/3" nav="thumbs" fullscreen="true" transition="crossfade">' . PHP_EOL;

cmb
Posts: 11571
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: fotorama

Postby cmb » Mon Aug 07, 2017 2:08 pm

pergachris wrote:Wäre es möglich in einer zukünftigen Version das unter Konfiguration anzubieten?

Ja, das erscheint sinnvoll.
Christoph M. Becker –Plugins for CMSimple_XH, but not for CMSimple 4+

bastingse
Posts: 220
Joined: Fri Jun 06, 2008 9:38 pm
Location: Netherlands
Contact:

Re: fotorama

Postby bastingse » Sun Aug 20, 2017 3:26 pm

I try to use fotorama plugin on xh 1.7 installation but got this error:

Code: Select all

Parse error: syntax error, unexpected T_OBJECT_OPERATOR in /home/....../public_html/versie170/plugins/fotorama/classes/Controller.php on line 98


In the manual of fotorama i read this:
"Fotorama_XH is a plugin for CMSimple_XH ≥ 1.6. It requires PHP ≥ 5.3.0 and the "fileinfo", "gd" and "SimpleXML" extensions."

Can this be the problem?
Where can i check if i'm using those extensions???

cmb
Posts: 11571
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: fotorama

Postby cmb » Sun Aug 20, 2017 4:20 pm

bastingse wrote:I try to use fotorama plugin on xh 1.7 installation but got this error:

Code: Select all

Parse error: syntax error, unexpected T_OBJECT_OPERATOR in /home/....../public_html/versie170/plugins/fotorama/classes/Controller.php on line 98

That is already fixed in the repo, but has not yet been released. See the diff on how to fix it yourself (delete the red line, and add the green lines without the + sign at the start of the lines).

bastingse wrote:Where can i check if i'm using those extensions???

You can go to Adminmenu → Settings → Info → PHP-Info. Each available PHP extension has a separate section there.
Christoph M. Becker –Plugins for CMSimple_XH, but not for CMSimple 4+

bastingse
Posts: 220
Joined: Fri Jun 06, 2008 9:38 pm
Location: Netherlands
Contact:

Re: fotorama

Postby bastingse » Tue Aug 22, 2017 6:51 am

cmb wrote:That is already fixed in the repo, but has not yet been released. See the diff on how to fix it yourself (delete the red line, and add the green lines without the + sign at the start of the lines).


Is there a fix too for this error in Folder gallery?

Code: Select all

Parse error: syntax error, unexpected T_OBJECT_OPERATOR in /home/......./public_html/versie170/plugins/foldergallery/index.php on line 34

cmb
Posts: 11571
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: fotorama

Postby cmb » Tue Aug 22, 2017 8:44 am

bastingse wrote:Is there a fix too for this error in Folder gallery?

Code: Select all

Parse error: syntax error, unexpected T_OBJECT_OPERATOR in /home/......./public_html/versie170/plugins/foldergallery/index.php on line 34

Foldergallery_XH 1.0beta1 requires PHP ≥ 5.4.0. Can't you update to some more recent PHP version?
Christoph M. Becker –Plugins for CMSimple_XH, but not for CMSimple 4+

bastingse
Posts: 220
Joined: Fri Jun 06, 2008 9:38 pm
Location: Netherlands
Contact:

Re: fotorama

Postby bastingse » Tue Aug 22, 2017 9:01 am

cmb wrote:Foldergallery_XH 1.0beta1 requires PHP ≥ 5.4.0. Can't you update to some more recent PHP version?


Yes, a update is possible but then i first have to finish the new website for this client. Thanks for the info, i should have read better!!

bastingse
Posts: 220
Joined: Fri Jun 06, 2008 9:38 pm
Location: Netherlands
Contact:

Re: fotorama

Postby bastingse » Wed Aug 30, 2017 9:21 am

Thanks Christoph, it works perfectly under php 7.0.14 !!
Only problem i'm running into is that flexslider does not work on a cmsimple 1.7 version.....


Return to “Addons and Plugins”

Who is online

Users browsing this forum: No registered users and 1 guest