Fa_XH

Third Party Plugins to CMSimple - how to install, use and create plugins

Moderator: Tata

cmb
Posts: 12876
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Fa_XH

Post by cmb » Fri Mar 31, 2017 6:20 pm

frase wrote:
cmb wrote:Beim Testen ist mir aber ein größeres Problem aufgefallen. Wenn das Font-Awesome Plugin installiert ist, und ich im IE 11 die Dev-Tools öffne, dann schmiert der Browser ab. Gar nicht schön.
Ist bei mir auch noch nicht passiert (IE11).
Interessant! Bei mir (IE 11.953.14393.0) passiert das immer sobald ich die Konsole öffne, oder wenn ich die Seite lade, wenn die Konsole offen ist. Aber halt nur, wenn der TinyMCE 4 mit dem Font Awesome Plugin aktiv ist. Hat irgendwas mit Font Awesomes @font-face zu tun. Ob das nun ein Problem des Font Awesome Plugins ist, oder ein Problem der IE-Konsole, oder sonstwas, kann ich nicht sagen. Wirklich debuggen kann ich ja leider nicht. Ich werde es als Limitation dokumentieren.
frase wrote:Schaut euch mal den Quellcode in der Console an für die Veröffentlichungsdaten-Felder in PD (hier mal FF & Firebug):
Ja, war mir auch aufgefallen, und ich hatte es gleich gefixt (blöder Refactoring-Fehler).
Christoph M. Becker –Plugins for CMSimple_XH, but not for CMSimple 4+

lck
Posts: 1360
Joined: Wed Mar 23, 2011 11:43 am
Contact:

Re: Fa_XH

Post by lck » Fri Mar 31, 2017 8:36 pm

cmb wrote:Du hast vermutlich den Kommentar in Zeile 18 entfernt, aber Zeile 19 nicht auskommentiert. Ich sollte die Beschreibung im Handbuch wohl noch klarer machen,
Genau. Das wollte ich anfangs, aber ich dachte ich halte mich mal strikt an die Hilfedatei ;) . Auskommentiert und die Notiz ist verschwunden.
cmb wrote:Beim Testen ist mir aber ein größeres Problem aufgefallen. Wenn das Font-Awesome Plugin installiert ist, und ich im IE 11 die Dev-Tools öffne, dann schmiert der Browser ab.
Hm, bei mir bisher nicht :?

Mit was ich teste, habe ich ja bereits am Anfang des Threads erwähnt. Testet bitte mal Einstellungen > Info. Ich bekomme da einen Fatal error:
Fatal error: Maximum execution time of 30 seconds exceeded in D:\xampp\htdocs\Portable_XH-2.0dev6\www\cmsimple\functions.php on line 1259
Vielleicht sollten wir uns auf ein einheitliches Testsystem einigen? Es gibt momentan einfach zu viele Baustellen, ein richtiges Testen scheint gar nicht möglich. Knackpunkt ist der TinyMCE4 und der Pagemanager.
„Bevor du den Pfeil der Wahrheit abschießt, tauche die Spitze in Honig!“   👉 Ludwig's XH-Templates for MultiPage & OnePage

cmb
Posts: 12876
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Fa_XH

Post by cmb » Fri Mar 31, 2017 9:24 pm

lck wrote:
cmb wrote:Beim Testen ist mir aber ein größeres Problem aufgefallen. Wenn das Font-Awesome Plugin installiert ist, und ich im IE 11 die Dev-Tools öffne, dann schmiert der Browser ab.
Hm, bei mir bisher nicht :?
Vielleicht tritt das Problem nur bei mir, oder zumindest nur in gewissen Ausnahmefällen auf – das wäre ja dann umso erfreulicher. :)
lck wrote:Mit was ich teste, habe ich ja bereits am Anfang des Threads erwähnt. Testet bitte mal Einstellungen > Info. Ich bekomme da einen Fatal error:
Kann ich nicht reproduzieren; bei mir erscheint die Seite sofort. Ich kann habe aber spontan die ein oder andere Vermutung woran es liegen könnte; ist aber mit dem einfachen Debug-Output nicht wirklich zu verifizieren. Ein debug_backtrace() wäre hilfreich; spontan halte ich das für eine sinnvolle Verbesserung, die eventuell einen weiteren Debug-Level rechtfertigen würde.
lck wrote:Vielleicht sollten wir uns auf ein einheitliches Testsystem einigen? Es gibt momentan einfach zu viele Baustellen, ein richtiges Testen scheint gar nicht möglich. Knackpunkt ist der TinyMCE4 und der Pagemanager.
Ja, Du hast leider recht – ist gerade ziemliches Chaos. Ich schlage vor, das Testen jetzt erst einmal zurückzustellen (es wurden ja schon hilfreicherweise diverse Bugs gemeldet, die halt erst mal gefixt werden sollten). Ich versuche die noch völlig offenen Punkte auf der CMSimple_XH 1.7 Roadmap übers Wochenende anzugehen, und die Abstimmung zu starten. Während diese läuft, wäre dann Zeit für Pagemanager, Fa usw., und vielleicht ist es dann auch sinnvoll eine neue Portable-Version zu veröffentlichen. Spätestens wenn zeitnah nach der Abstimmung dann XH 1.7.0beta1 veröffentlicht wird, könnte das Testen wieder aufgenommen werden.
Christoph M. Becker –Plugins for CMSimple_XH, but not for CMSimple 4+

frase
Posts: 2260
Joined: Thu Apr 21, 2016 6:32 am
Location: Saxony
Contact:

Re: Fa_XH

Post by frase » Sat Apr 01, 2017 7:30 am

lck wrote:Testet bitte mal Einstellungen > Info. Ich bekomme da einen Fatal error:
In Sachsen taucht der Error auch nicht auf.
lck wrote:Vielleicht sollten wir uns auf ein einheitliches Testsystem einigen? Es gibt momentan einfach zu viele Baustellen, ein richtiges Testen scheint gar nicht möglich. Knackpunkt ist der TinyMCE4 und der Pagemanager.
+1
Tatsächlich verliere ich langsam den Überblick. zig Installationen mit: "Probier mal das ... füge mal das ein ..." usw.
cmb wrote:Ich schlage vor, das Testen jetzt erst einmal zurückzustellen [...] Spätestens wenn zeitnah nach der Abstimmung dann XH 1.7.0beta1 veröffentlicht wird, könnte das Testen wieder aufgenommen werden.
Das klingt sehr vernünftig. Einverstanden.

---
Noch eine Frage:
Ich habe bei mir noch nie Portable_XH installiert. Aus unerklärlichen Gründen weigert sich mein Inneres Visual C++ (usw.) zu installieren.
Ich verwende dann immer eine möglichst neue xampp-Version (z.z. mit PHP 7.1.1).
Sind dannn Tests noch sinnvoll - oder sind die Unterschiede zu groß?

cmb
Posts: 12876
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Fa_XH

Post by cmb » Sat Apr 01, 2017 8:05 am

frase wrote:Ich habe bei mir noch nie Portable_XH installiert. Aus unerklärlichen Gründen weigert sich mein Inneres Visual C++ (usw.) zu installieren.
Visual C++ (usw.) musst Du nicht installieren (das wäre tatsächlich eine Zumutung), sondern nur die jeweilige C++ Runtime; gut möglich, dass diese bereits auf Deinem Rechner installiert ist.
frase wrote:Ich verwende dann immer eine möglichst neue xampp-Version (z.z. mit PHP 7.1.1).
Sind dannn Tests noch sinnvoll - oder sind die Unterschiede zu groß?
Im Gegenteil! Es sollte grundsätzlich unter möglichst vielen unterschiedlichen Umgebungen getestet werden, denn CMSimple_XH ist ja darauf ausgelegt "überall" zu laufen. Ich arbeite und teste übrigens in der Regel noch unter XAMPP 5.6.15. Und gut wäre es sicherlich auch unter Linux und mit diversen Webservern (IIS und Nginx, zum Beispiel) zu testen.
Christoph M. Becker –Plugins for CMSimple_XH, but not for CMSimple 4+

frase
Posts: 2260
Joined: Thu Apr 21, 2016 6:32 am
Location: Saxony
Contact:

Re: Fa_XH

Post by frase » Sat Apr 01, 2017 8:28 am

cmb wrote:... gut möglich, dass diese bereits auf Deinem Rechner installiert ist.
Denke nicht. Die Installationsroutine bricht gleich zu Anfang ab mit: vcruntime140.dll fehlt (oder so ähnlich).

Egal. Wenn es mit xampp auch geht.
cmb wrote:Ich arbeite und teste übrigens in der Regel noch unter XAMPP 5.6.15
Ich habe momentan 5(!) xampp-Versionen im Einsatz. Die laufen zwar nicht parallel, aber manchmal muss ich noch auf Versionen ohne Controlcenter zurückgreifen (php 4.x), wenn sich Kunden von vor 10 Jahren melden mit Software aus dieser Zeit (nicht unbedingt nur CMSXH - aber auch).

cmb
Posts: 12876
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Fa_XH

Post by cmb » Sat Apr 01, 2017 9:34 am

frase wrote:Egal. Wenn es mit xampp auch geht.
Ja, natürlich. Und letztlich: Portable_XH ist nicht als Entwicklungsumgebung gedacht; XAMPP schon.
frase wrote:Ich habe momentan 5(!) xampp-Versionen im Einsatz. Die laufen zwar nicht parallel, aber manchmal muss ich noch auf Versionen ohne Controlcenter zurückgreifen (php 4.x), wenn sich Kunden von vor 10 Jahren melden mit Software aus dieser Zeit (nicht unbedingt nur CMSXH - aber auch).
Ich habe auch mehrere XAMPPs am Start, aus eben diesem Grund. Und ja, das ist eine leidige Sache, aber da sollte man die User umerziehen, denn wer heute noch ein Produktivsystem mit PHP 4 fährt, hat den Schuss nicht gehört, und wer heute noch PHP 4 Code wartet, macht was falsch, oder hat (wie im Fall von CMSimple_XH) was falsch gemacht.
Christoph M. Becker –Plugins for CMSimple_XH, but not for CMSimple 4+

frase
Posts: 2260
Joined: Thu Apr 21, 2016 6:32 am
Location: Saxony
Contact:

Re: Fa_XH

Post by frase » Sat Apr 01, 2017 1:11 pm

Manchmal habe ich das Gefühl, dass hier Leute mitlesen und sich für ihre eigene Arbeit inspirieren lassen (das fände ich überhaupt nicht schlecht).

Just heute, nachdem ich obigen Beitrag geschrieben hatte, fand ich diesen Artikel (vom 1.4.2017 10:39).
Das ist doch erstaunlich - oder? Fehlende DLLs, portable Anwendung ...

cmb
Posts: 12876
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Fa_XH

Post by cmb » Sat Apr 01, 2017 3:07 pm

frase wrote:Just heute, nachdem ich obigen Beitrag geschrieben hatte, fand ich diesen Artikel (vom 1.4.2017 10:39).
Das ist doch erstaunlich - oder? Fehlende DLLs, portable Anwendung ...
Sachen gibt's … :)

Aber bitte die DLL nicht von dll-files.com herunter laden, sondern direkt von Microsoft (Links stehen in der jeweiligen Portable_XH README.txt). Das ist dann zumindest legal.
Christoph M. Becker –Plugins for CMSimple_XH, but not for CMSimple 4+

bca
Posts: 288
Joined: Tue Sep 15, 2009 4:49 pm

Re: Fa_XH

Post by bca » Tue Apr 04, 2017 11:01 am

Just added this to a testsite and it seems to work OK for me after one initial problem.
Perhaps you should say in the help file "Dont cut and paste ... define('TINYMCE4_VARIANT, '');"
Killed the site when I did this. When I typed it in it was ok. :oops:

B

Post Reply