Calendar v1.4.8

A place to report and discuss bugs - please mention CMSimple-version, server, platform and browser version
Post Reply
Tata
Posts: 2792
Joined: Tue May 20, 2008 5:34 am
Location: Slovakia
Contact:

Calendar v1.4.8

Post by Tata » Tue Jan 16, 2018 8:45 pm

I continue with the page http://plugins_171.cmsimple.sk. Installed are the most frequently used plugins (IMHO, at least) and I test the CMSimple_XH v1.7.2 compatibility, write the SK translations etc.
Now I am at Calendar v1.4.8 and can't find the reason, why the plugins works fine online, but on localhost returns the call
Warning: A non-numeric value encountered in /Users/msereday/webpages/plugins_171/plugins/calendar/includes/eventlist.php on line 84

Warning: A non-numeric value encountered in /Users/msereday/webpages/plugins_171/plugins/calendar/includes/eventlist.php on line 84
Cannot modify header information - headers already sent (output started at /Users/msereday/webpages/plugins_171/plugins/calendar/includes/eventlist.php:84)
In admin mode, however comes the calendar as expected.
CMSimple.sk
It's no shame to ask for an answer if all efforts failed.
But it's awful to ask without any effort to find the answer yourself.

cmb
Posts: 12774
Joined: Tue Jun 21, 2011 11:04 am
Location: Mü-Sa, RLP, DE
Contact:

Re: Calendar v1.4.8

Post by cmb » Tue Jan 16, 2018 11:24 pm

Tata wrote:
Tue Jan 16, 2018 8:45 pm
Now I am at Calendar v1.4.8 and can't find the reason, why the plugins works fine online, but on localhost returns the call
Warning: A non-numeric value encountered in /Users/msereday/webpages/plugins_171/plugins/calendar/includes/eventlist.php on line 84
I suppose that you're running PHP ≥ 7.1 on localhost, but PHP < 7.1 on the server.
Christoph M. Becker –Plugins for CMSimple_XH, but not for CMSimple 4+

Tata
Posts: 2792
Joined: Tue May 20, 2008 5:34 am
Location: Slovakia
Contact:

Re: Calendar v1.4.8

Post by Tata » Wed Jan 17, 2018 6:18 am

Well, the server runs still with PHP v5.6. I have tested all PHP versions (5.4.45 ... 7.1.8) on localhost. But in this issue nothing has changed.
I also have change the PHP setting on the subdomain to PHP7. The webpage runs well, but I can't login
Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at support@exohosting.sk to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.
In the error.log I found the problem in main index.php - empty line after closing "?>"
CMSimple.sk
It's no shame to ask for an answer if all efforts failed.
But it's awful to ask without any effort to find the answer yourself.

Post Reply