Search found 4601 matches

by frase
Sun Feb 05, 2023 6:56 pm
Forum: Addons and Plugins
Topic: Plugin Compatibility with PHP 8
Replies: 45
Views: 892

Re: Plugin Compatibility with PHP 8

cmb wrote:
Sun Feb 05, 2023 6:53 pm
Frank testet vermutlich mit PHP 8.2, aber das sollte sich mit PHP 8.0 nicht viel nehmen, was die Probleme angeht.
Ich testete mit PHP 7.4.2 UND mit PHP 8.2.0.
In beiden Varianten funktioniert der Master wie erwartet ohne Whitescreen.
by frase
Sun Feb 05, 2023 6:54 pm
Forum: Addons and Plugins
Topic: Plugin Compatibility with PHP 8
Replies: 45
Views: 892

Re: Plugin Compatibility with PHP 8

das Teaser Thema gestaltet sich etwas zäh. ;-) Ja, leider. Worauf habe ich mich da bloß wieder eingelassen … ;) Was mir aufgefallen ist: Bei der Masterversion gibt es keine config/config.php mehr und wir testen wohl in unterschiedlichen PHP 7 bzw. 8 Versionen. Das ist, soweit ich es verstehe, von S...
by frase
Sun Feb 05, 2023 1:11 pm
Forum: Addons and Plugins
Topic: Plugin Compatibility with PHP 8
Replies: 45
Views: 892

Re: Plugin Compatibility with PHP 8

Teaser 1.2.1 Beim Pluginaufruf unter PHP 7.4 (Tabs werden angezeigt): => OK Wechsel (Auswahlmenü) von anderen Teaser-TXT-Dateien => OK Auswahl einer anderen Teaserseite in Teaser-TXT-Dateien im Plugin: Nicht möglich (auch nach mehrmaliger Auswahl nicht.) Beim Pluginaufruf unter PHP 8.0 (Tabs werden...
by frase
Sat Feb 04, 2023 5:29 pm
Forum: Addons and Plugins
Topic: Plugin Compatibility with PHP 8
Replies: 45
Views: 892

Re: Plugin Compatibility with PHP 8

cmb wrote:
Sat Feb 04, 2023 5:22 pm
Sollte nun aber wieder passen.
Yep, tut es!
Also:
Teaser_XH v. 1.2.1 MASTER => OK
by frase
Sat Feb 04, 2023 4:25 pm
Forum: Addons and Plugins
Topic: Plugin Compatibility with PHP 8
Replies: 45
Views: 892

Re: Plugin Compatibility with PHP 8

Ja, das hatte ich bei Hartmuts Post ganz vergessen, und dann konnte ich es nicht reproduzieren. Aber so kann ich; es ist das leidige Problem mit der Änderung der Vergleiche von Strings und Zahlen (https://3v4l.org/H6THZ); die Lösung ist einfach, aber ich gehe nach wie vor davon aus, dass viele Plug...
by frase
Sat Feb 04, 2023 3:44 pm
Forum: Addons and Plugins
Topic: Plugin Compatibility with PHP 8
Replies: 45
Views: 892

Re: Plugin Compatibility with PHP 8

Teaser_XH v. 1.2.1 - Master Dieses Plugin kannte ich noch nicht :oops: Und mir ist auch (noch) nicht ganz klar, welche Vorteile es eigentlich bringt. Ein Schnelltest des Masters zeigte aber folgende Probleme: Teaser bearbeiten. Unterhalb des Editors wird eine Teaser-Vorschau angezeigt. Ein Klick dar...
by frase
Sat Feb 04, 2023 9:22 am
Forum: Addons and Plugins
Topic: Plugin Compatibility with PHP 8
Replies: 45
Views: 892

Re: Plugin Compatibility with PHP 8

Swiper 1.0rc1 Handling (Besuchersicht): PHP 7.4 + PHP 8.0 => OK Adminmenü Plugin Funktion / Bedienung: PHP 7.4 + PHP 8.0 => OK Dauerhafte Debug Meldungen unter PHP 7.4 + PHP 8.0: WARNING: Trying to access array offset on value of type bool /mnt/.../plugins/swiper/swiperfuncs.php:105 Diese Meldung e...
by frase
Fri Feb 03, 2023 8:50 am
Forum: Addons and Plugins
Topic: Plugin Compatibility with PHP 8
Replies: 45
Views: 892

Re: Plugin Compatibility with PHP 8

Kümmert sich jemand um die anderen gebündelten Plugins? Da sind noch 3 Sachen offen. Wenn PHP 8, 8.1, 8.2 passt, dann wäre ja nur noch jQuery … jQuery und hi_updatecheck (da ist der Master neuer als das letzte Release + Help-Files sind neu). Holger schlägt vor, diese Standard-Plugins auf Github unt...
by frase
Fri Feb 03, 2023 8:40 am
Forum: Addons and Plugins
Topic: Plugin Compatibility with PHP 8
Replies: 45
Views: 892

Re: Plugin Compatibility with PHP 8

Da ist wohl ein Update fällig? Ja, wie bei vielen meiner Plugins. Ich tue, was ich kann. Sorry, wenn ich so etwas schreibe, klingt es wie eine Aufforderung :oops: Das ist nicht so gemeint! Ich schätze deine Arbeit sehr – und ich glaube, das tun andere auch. Mir ist sowieso nicht klar, wie du das al...
by frase
Wed Feb 01, 2023 6:45 pm
Forum: Addons and Plugins
Topic: Plugin Compatibility with PHP 8
Replies: 45
Views: 892

Re: Plugin Compatibility with PHP 8

Hole dir doch mal HTML Purifier 4.15.0 Standalone, und ersetze damit plugins/twocents/htmlpurifier/. Ich gehe mal davon aus, dass dann alles wieder funktioniert. Getan. Formular verschickt. Die Seite antwortet mir in schönster XH-Folklore mit einem blauen Hinweis: Dein Kommentar erscheint hier erst...